CVE-2016-6333
Cross-site scripting (XSS) vulnerability in the CSS user subpage preview feature in MediaWiki...
Cross-site scripting (XSS) vulnerability in the CSS user subpage preview feature in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to inject arbitrary web script or HTML via the edit box in Special:MyPage/common.css.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting (XSS) vulnerability in the CSS user subpage preview feature in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to inject arbitrary web script or HTML via the edit box in Special:MyPage/common.css.
- Record
CVE-2016-6333- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the CSS user subpage preview feature in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to inject arbitrary web script or HTML via the edit box in Special:MyPage/common.css.
- Record
CVE-2016-6333- Updated
- 2026-11-02
EUVDEUVD-2016-7260 No score
Cross-site scripting (XSS) vulnerability in the CSS user subpage preview feature in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to inject arbitrary web script or HTML via the edit box in Special:MyPage/common.css.
- Record
EUVD-2016-7260- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hxwm-9f7g-wg4h
6.1
Cross-site scripting (XSS) vulnerability in the CSS user subpage preview feature in MediaWiki...
Cross-site scripting (XSS) vulnerability in the CSS user subpage preview feature in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to inject arbitrary web script or HTML via the edit box in Special:MyPage/common.css.
- Record
GHSA-hxwm-9f7g-wg4h- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Cross-site scripting (XSS) vulnerability in the CSS user subpage preview feature in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to inject arbitrary web script or HTML via the edit box in Special:MyPage/common.css.
- Record
CVE-2016-6333- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-6333
6.1
Cross-site scripting (XSS) vulnerability in the CSS user subpage preview feature in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to inject arbitrary web script or HTML via the edit box in Special:MyPage/common.css.
- Record
DEBIAN-CVE-2016-6333- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVMGASA-2016-0305 No score
Updated mediawiki packages fix security vulnerability
Check read permission when loading page content in ApiParse (CVE-2016-6331)
Make blocks log users out if $wgBlockDisablesLogin is true (CVE-2016-6332)
Make $wgBlockDisablesLogin also restrict logged in permissions (CVE-2016-6332)
Require login to preview user CSS pages (CVE-2016-6333)
Escape '<' and ']]>' in inline <style> blocks (CVE-2016-6333)
XSS in unclosed internal links (CVE-2016-6334)
API: Generate head items in the context of the given title (CVE-2016-6335)
Do not allow undeleting a revision deleted file if it is the top file (CVE-2016-6336)
The mediawiki package has been updated to version 1.23.15, which contains the above fixes.
- Record
MGASA-2016-0305- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-6333 is a medium vulnerability (CVSS 6.1) in Mediawiki, published September 16, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.02%, the 63rd percentile. Fixed in mediawiki 1:1.27.1-1.
References
lists.wikimedia.org/pipermail/mediawiki-announce/2016-August/000195.html
bugzilla.redhat.com/show_bug.cgi?id=1369613
phabricator.wikimedia.org/T133147
securityfocus.com/bid/98053
nvd.nist.gov/vuln/detail/CVE-2016-6333
github.com/advisories/GHSA-hxwm-9f7g-wg4h
security-tracker.debian.org/tracker/CVE-2016-6333
advisories.mageia.org/MGASA-2016-0305.html
bugs.mageia.org/show_bug.cgi?id=19252