Every CVE Search/ Get API key

CVE-2016-6621

phpMyAdmin server-side request forgery (SSRF)

8.6 HighFix available

The setup script for phpMyAdmin before 4.0.10.19, 4.4.x before 4.4.15.10, and 4.6.x before 4.6.6 allows remote attackers to conduct server-side request forgery (SSRF) attacks via unspecified vectors.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.93%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.6

The setup script for phpMyAdmin before 4.0.10.19, 4.4.x before 4.4.15.10, and 4.6.x before 4.6.6 allows remote attackers to conduct server-side request forgery (SSRF) attacks via unspecified vectors.

Record
CVE-2016-6621
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-918
Updated
2026-11-02
CVE List No score

The setup script for phpMyAdmin before 4.0.10.19, 4.4.x before 4.4.15.10, and 4.6.x before 4.6.6 allows remote attackers to conduct server-side request forgery (SSRF) attacks via unspecified vectors.

Record
CVE-2016-6621
Updated
2026-11-02
EUVDEUVD-2016-7534 No score

The setup script for phpMyAdmin before 4.0.10.19, 4.4.x before 4.4.15.10, and 4.6.x before 4.6.6 allows remote attackers to conduct server-side request forgery (SSRF) attacks via unspecified vectors.

Record
EUVD-2016-7534
Updated
2026-11-03
GitHub AdvisoriesGHSA-44vv-mm86-7cg6 8.6

phpMyAdmin server-side request forgery (SSRF)

The setup script for phpMyAdmin before 4.0.10.19, 4.4.x before 4.4.15.10, and 4.6.x before 4.6.6 allows remote attackers to conduct server-side request forgery (SSRF) attacks via unspecified vectors.

Record
GHSA-44vv-mm86-7cg6
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Weakness
CWE-918
Updated
2026-11-02
OSV 8.6

The setup script for phpMyAdmin before 4.0.10.19, 4.4.x before 4.4.15.10, and 4.6.x before 4.6.6 allows remote attackers to conduct server-side request forgery (SSRF) attacks via unspecified vectors.

Record
CVE-2016-6621
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2016-6621 8.6

The setup script for phpMyAdmin before 4.0.10.19, 4.4.x before 4.4.15.10, and 4.6.x before 4.6.6 allows remote attackers to conduct server-side request forgery (SSRF) attacks via unspecified vectors.

Record
DEBIAN-CVE-2016-6621
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-44vv-mm86-7cg6 8.6

phpMyAdmin server-side request forgery (SSRF)

The setup script for phpMyAdmin before 4.0.10.19, 4.4.x before 4.4.15.10, and 4.6.x before 4.6.6 allows remote attackers to conduct server-side request forgery (SSRF) attacks via unspecified vectors.

Record
GHSA-44vv-mm86-7cg6
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Weakness
CWE-918
Updated
2026-11-02
OSVUBUNTU-CVE-2016-6621 8.6

The setup script for phpMyAdmin before 4.0.10.19, 4.4.x before 4.4.15.10, and 4.6.x before 4.6.6 allows remote attackers to conduct server-side request forgery (SSRF) attacks via unspecified vectors.

Record
UBUNTU-CVE-2016-6621
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Updated
2026-11-02
OSVMGASA-2017-0038 No score

Updated phpmyadmin packages fix security vulnerabilities

Multiple vulnerabilities in setup script (CVE-2016-6621 / PMASA-2016-44).

Open redirect (PMASA-2017-1).

php-gettext code execution (CVE-2015-8980 / PMASA-2017-2).

DOS vulnerability in table editing (PMASA-2017-3).

CSS injection in themes (PMASA-2017-4).

SSRF in replication (PMASA-2017-6).

DOS in replication status (PMASA-2017-7).

Record
MGASA-2017-0038
Updated
2026-11-02
OSVopenSUSE-SU-2024:10054-1 No score

phpMyAdmin-4.6.5.2-1.1 on GA media

These are all security issues fixed in the phpMyAdmin-4.6.5.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10054-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpmyadmin/phpmyadmin
Packagist
4.6.0 up to 4.6.6
4.6.6
phpmyadmin/phpmyadmin
Packagist
4.4.0 up to 4.4.15.10
4.4.15.10
phpmyadmin/phpmyadmin
Packagist
before 4.0.10.19
4.0.10.19
phpmyadmin
Debian:12
before 4:4.6.6-1
4:4.6.6-1
phpmyadmin
Debian:13
before 4:4.6.6-1
4:4.6.6-1
phpmyadmin
Debian:14
before 4:4.6.6-1
4:4.6.6-1
phpmyadmin
Debian:8
From an advisory covering 11 CVEs
before 4:4.2.12-2+deb8u3, plus listed versions
4:4.2.12-24:4.2.12-2+deb8u14:4.2.12-2+deb8u2
4:4.2.12-2+deb8u3
phpmyadmin
Debian:7
before 4:3.4.11.1-2+deb7u8, plus listed versions
4:3.4.11.1-24:3.4.11.1-2+deb7u14:3.4.11.1-2+deb7u24:3.4.11.1-2+deb7u34:3.4.11.1-2+deb7u44:3.4.11.1-2+deb7u54:3.4.11.1-2+deb7u64:3.4.11.1-2+deb7u7
4:3.4.11.1-2+deb7u8
phpmyadmin/phpmyadmin
Packagist
before 4.0.10.19, plus listed versions
4.0.04.0.14.0.104.0.10.14.0.10.2
Show 17 moreShow less
4.0.10.34.0.10.44.0.10.54.0.10.64.0.10.74.0.10.84.0.10.94.0.24.0.34.0.44.0.4.14.0.4.24.0.54.0.64.0.74.0.84.0.9
4.0.10.19
phpmyadmin
Mageia:5
From an advisory covering 2 CVEs
before 4.4.15.10-1.mga5
4.4.15.10-1.mga5
phpmyadmin
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
4:4.0.6-14:4.0.8-14:4.0.9-14:4.0.10-14:4.0.10-1ubuntu0.1
Show 4 moreShow less
4:4.0.10-1ubuntu0.1+esm14:4.0.10-1ubuntu0.1+esm24:4.0.10-1ubuntu0.1+esm34:4.0.10-1ubuntu0.1+esm4
None known
phpmyadmin
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
4:4.4.13.1-14:4.5.0.2-24:4.5.1-14:4.5.1-24:4.5.1-3
Show 13 moreShow less
4:4.5.2-14:4.5.2-24:4.5.3.1-14:4.5.4-14:4.5.4.1-24:4.5.4.1-2ubuntu14:4.5.4.1-2ubuntu24:4.5.4.1-2ubuntu2.14:4.5.4.1-2ubuntu2.1+esm24:4.5.4.1-2ubuntu2.1+esm34:4.5.4.1-2ubuntu2.1+esm44:4.5.4.1-2ubuntu2.1+esm54:4.5.4.1-2ubuntu2.1+esm6
None known
phpMyAdmin
openSUSE:Tumbleweed
From an advisory covering 124 CVEs
before 4.6.5.2-1.1
4.6.5.2-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-6621 is a high vulnerability (CVSS 8.6) in Phpmyadmin, published January 31, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.93%, the 80th percentile. Fixed in phpmyadmin/phpmyadmin 4.6.6.

References

Show 139 moreShow less
MoveEnter Open