CVE-2016-7071
It was found that the CloudForms before 5.6.2.2, and 5.7.0.7 did not properly apply permissions...
It was found that the CloudForms before 5.6.2.2, and 5.7.0.7 did not properly apply permissions controls to VM IDs passed by users. A remote, authenticated attacker could use this flaw to execute arbitrary VMs on systems managed by CloudForms if they know the ID of the VM.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.8
It was found that the CloudForms before 5.6.2.2, and 5.7.0.7 did not properly apply permissions controls to VM IDs passed by users. A remote, authenticated attacker could use this flaw to execute arbitrary VMs on systems managed by CloudForms if they know the ID of the VM.
- Record
CVE-2016-7071- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-285
- Updated
- 2026-11-02
EUVDEUVD-2016-7951
8.8
It was found that the CloudForms before 5.6.2.2, and 5.7.0.7 did not properly apply permissions controls to VM IDs passed by users. A remote, authenticated attacker could use this flaw to execute arbitrary VMs on systems managed by CloudForms if they know the ID of the VM.
- Record
EUVD-2016-7951- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-82ph-q482-5fhg
8.8
It was found that the CloudForms before 5.6.2.2, and 5.7.0.7 did not properly apply permissions...
It was found that the CloudForms before 5.6.2.2, and 5.7.0.7 did not properly apply permissions controls to VM IDs passed by users. A remote, authenticated attacker could use this flaw to execute arbitrary VMs on systems managed by CloudForms if they know the ID of the VM.
- Record
GHSA-82ph-q482-5fhg- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-285
- Updated
- 2026-11-02
NVD
8.8
It was found that the CloudForms before 5.6.2.2, and 5.7.0.7 did not properly apply permissions controls to VM IDs passed by users. A remote, authenticated attacker could use this flaw to execute arbitrary VMs on systems managed by CloudForms if they know the ID of the VM.
- Record
CVE-2016-7071- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 9.0 High
AV:N/AC:L/Au:S/C:C/I:C/A:C - Weakness
- CWE-285
- Updated
- 2026-11-02
OSVRHSA-2016:2091
8.8
Red Hat Security Advisory: CFME 5.6.2.2 security, and bug fix update
- Record
RHSA-2016:2091- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cfmeRed Hat:cloudforms_managementengine:5.6::el7 |
before 0:5.6.2.2-1.el7cf | 0:5.6.2.2-1.el7cf |
cfme-applianceRed Hat:cloudforms_managementengine:5.6::el7 |
before 0:5.6.2.2-1.el7cf | 0:5.6.2.2-1.el7cf |
cfme-appliance-debuginfoRed Hat:cloudforms_managementengine:5.6::el7 |
before 0:5.6.2.2-1.el7cf | 0:5.6.2.2-1.el7cf |
cfme-debuginfoRed Hat:cloudforms_managementengine:5.6::el7 |
before 0:5.6.2.2-1.el7cf | 0:5.6.2.2-1.el7cf |
cfme-gemsetRed Hat:cloudforms_managementengine:5.6::el7 |
before 0:5.6.2.2-1.el7cf | 0:5.6.2.2-1.el7cf |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-7071 is a high vulnerability (CVSS 8.8) in Redhat Cloudforms, published September 10, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.20%, the 82nd percentile. Fixed in cfme 0:5.6.2.2-1.el7cf.
References
rhn.redhat.com/errata/RHSA-2016-2091.html
bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-7071
nvd.nist.gov/vuln/detail/CVE-2016-7071
github.com/advisories/GHSA-82ph-q482-5fhg
access.redhat.com/errata/RHSA-2016:2091
access.redhat.com/security/updates/classification