Every CVE Search/ Get API key

CVE-2016-7142

The m_sasl module in InspIRCd before 2.0.23, when used with a service that supports SASL_EXTERNAL...

5.9 MediumFix available

CVE-2016-7142 is a medium vulnerability (CVSS 5.9) in Inspircd, published September 8, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.08%, the 65th percentile. Fixed in inspircd 2.0.23-1.

The m_sasl module in InspIRCd before 2.0.23, when used with a service that supports SASL_EXTERNAL authentication, allows remote attackers to spoof certificate fingerprints and consequently log in as another user via a crafted SASL message.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.08%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.9

The m_sasl module in InspIRCd before 2.0.23, when used with a service that supports SASL_EXTERNAL authentication, allows remote attackers to spoof certificate fingerprints and consequently log in as another user via a crafted SASL message.

Record
CVE-2016-7142
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:P/I:N/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The m_sasl module in InspIRCd before 2.0.23, when used with a service that supports SASL_EXTERNAL authentication, allows remote attackers to spoof certificate fingerprints and consequently log in as another user via a crafted SASL message.

Record
CVE-2016-7142
Updated
2026-11-02
EUVDEUVD-2016-8014 No score

The m_sasl module in InspIRCd before 2.0.23, when used with a service that supports SASL_EXTERNAL authentication, allows remote attackers to spoof certificate fingerprints and consequently log in as another user via a crafted SASL message.

Record
EUVD-2016-8014
Updated
2026-11-03
GitHub AdvisoriesGHSA-2vvc-952f-f8xg 5.9

The m_sasl module in InspIRCd before 2.0.23, when used with a service that supports SASL_EXTERNAL...

The m_sasl module in InspIRCd before 2.0.23, when used with a service that supports SASL_EXTERNAL authentication, allows remote attackers to spoof certificate fingerprints and consequently log in as another user via a crafted SASL message.

Record
GHSA-2vvc-952f-f8xg
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSV 5.9

The m_sasl module in InspIRCd before 2.0.23, when used with a service that supports SASL_EXTERNAL authentication, allows remote attackers to spoof certificate fingerprints and consequently log in as another user via a crafted SASL message.

Record
CVE-2016-7142
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2016-7142 5.9

The m_sasl module in InspIRCd before 2.0.23, when used with a service that supports SASL_EXTERNAL authentication, allows remote attackers to spoof certificate fingerprints and consequently log in as another user via a crafted SASL message.

Record
DEBIAN-CVE-2016-7142
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2016-7142 5.9

The m_sasl module in InspIRCd before 2.0.23, when used with a service that supports SASL_EXTERNAL authentication, allows remote attackers to spoof certificate fingerprints and consequently log in as another user via a crafted SASL message.

Record
UBUNTU-CVE-2016-7142
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUSN-7405-1 No score

inspircd vulnerabilities

It was discovered that InspIRCd did not correctly handle certificate fingerprints, which could lead to spoofing. A remote attacker could possibly use this issue to bypass authentication. This issue only affected Ubuntu 16.04 LTS. (CVE-2016-7142)

It was discovered that InspIRCd did not correctly handle certain memory operations, which could lead to a NULL pointer dereference. A remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2019-20917)

It was discovered that InspIRCd did not correctly handle certain memory operations, which could lead to a use-after-free. A remote attacker could possibly use this issue to cause a denial of service. (CVE-2020-25269)

Record
USN-7405-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
inspircd
Debian:12
before 2.0.23-1
2.0.23-1
inspircd
Debian:13
before 2.0.23-1
2.0.23-1
inspircd
Debian:8
before 2.0.17-1+deb8u2, plus listed versions
2.0.17-12.0.17-1+deb8u1
2.0.17-1+deb8u2
inspircd
Ubuntu:Pro:16.04:LTS
before 2.0.20-5ubuntu0.1~esm1, plus listed versions
2.0.20-32.0.20-42.0.20-52.0.20-5build12.0.20-5build2
2.0.20-5ubuntu0.1~esm1
inspircd
Ubuntu:Pro:18.04:LTS
before 2.0.24-1ubuntu1+esm1, plus listed versions
2.0.24-1ubuntu1
2.0.24-1ubuntu1+esm1
inspircd
Ubuntu:Pro:20.04:LTS
before 3.4.0-2ubuntu1+esm1, plus listed versions
2.0.27-1ubuntu23.4.0-2ubuntu1
3.4.0-2ubuntu1+esm1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 7 moreShow less
MoveEnter Open