CVE-2015-5607
IPython vulnerable to cross site request forgery (CSRF)
Cross-site request forgery in the REST API in IPython 2 and 3.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
Cross-site request forgery in the REST API in IPython 2 and 3.
- Record
CVE-2015-5607- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-352
- Updated
- 2026-11-02
CVE List No score
Cross-site request forgery in the REST API in IPython 2 and 3.
- Record
CVE-2015-5607- Updated
- 2026-11-02
EUVDEUVD-2017-0064 No score
Cross-site request forgery in the REST API in IPython 2 and 3.
- Record
EUVD-2017-0064- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-7fc2-rm35-2pp7
8.6
IPython vulnerable to cross site request forgery (CSRF)
IPython (Interactive Python) is a command shell. Cross-site request forgery in the REST API is possible in in IPython 2 and 3. Versions 2.4.1 and 3.2.3 contain patches.
- Record
GHSA-7fc2-rm35-2pp7- CVSS 4.0
- 8.6 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
OSV
8.8
Cross-site request forgery in the REST API in IPython 2 and 3.
- Record
CVE-2015-5607- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-5607
8.8
Cross-site request forgery in the REST API in IPython 2 and 3.
- Record
DEBIAN-CVE-2015-5607- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVGHSA-7fc2-rm35-2pp7
8.6
IPython vulnerable to cross site request forgery (CSRF)
IPython (Interactive Python) is a command shell. Cross-site request forgery in the REST API is possible in in IPython 2 and 3. Versions 2.4.1 and 3.2.3 contain patches.
- Record
GHSA-7fc2-rm35-2pp7- CVSS 4.0
- 8.6 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-5607
8.8
Cross-site request forgery in the REST API in IPython 2 and 3.
- Record
UBUNTU-CVE-2015-5607- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2015-0300 No score
Updated ipython package fixes security vulnerability
JSON error responses from the IPython notebook REST API contained URL parameters and were incorrectly reported as text/html instead of application/json. The error messages included some of these URL params, resulting in a cross site scripting attack (CVE-2015-4707).
POST requests exposed via the IPython REST API are vulnerable to cross-site request forgery (CSRF). Web pages on different domains can make non-AJAX POST requests to known IPython URLs, and IPython will honor them. The user's browser will automatically send IPython cookies along with the requests. The response is blocked by the Same-Origin Policy, but the request isn't (CVE-2015-5607).
The Mageia 5 package has been patched to fix these issues. The Mageia 4 package wasn't vulnerable to CVE-2015-4707, but it has been updated and patched to fix CVE-2015-5607.
- Record
MGASA-2015-0300- Updated
- 2026-11-02
OSVPYSEC-2017-47 No score
Cross-site request forgery in the REST API in IPython 2 and 3.
- Record
PYSEC-2017-47- Updated
- 2026-11-02
OSVUSN-5953-1 No score
ipython vulnerabilities
It was discovered that IPython incorrectly processed REST API POST requests. An attacker could possibly use this issue to launch a cross-site request forgery (CSRF) attack and leak user's sensitive information. This issue only affected Ubuntu 14.04 ESM. (CVE-2015-5607)
It was discovered that IPython did not properly manage cross user temporary files. A local attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2022-21699)
- Record
USN-5953-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ipythonPyPI |
0.12 up to 2.4.1 | 2.4.1 |
ipythonPyPI |
3.0.0 up to 3.2.3 | 3.2.3 |
ipythonDebian:12 |
before 2.4.1-1 | 2.4.1-1 |
ipythonDebian:13 |
before 2.4.1-1 | 2.4.1-1 |
ipythonDebian:14 |
before 2.4.1-1 | 2.4.1-1 |
ipythonPyPI |
0.12 up to 2.4.1, plus listed versions 0.12.10.130.13.10.13.21.0.0 Show 9 moreShow less1.1.01.2.01.2.12.0.02.1.02.2.02.3.02.3.12.4.0 |
2.4.1 |
ipythonPyPI |
3.0.0 up to 3.2.3, plus listed versions 3.1.03.2.03.2.13.2.2 |
3.2.3 |
ipythonMageia:4 From an advisory covering 2 CVEs |
before 2.3.0-1.mga4 | 2.3.0-1.mga4 |
ipythonMageia:5 From an advisory covering 2 CVEs |
before 2.3.0-2.2.mga5 | 2.3.0-2.2.mga5 |
ipythonPyPI |
before 3.2.1, plus listed versions 0.100.10.10.10.20.110.12 Show 43 moreShow less0.12.10.130.13.10.13.20.6.100.6.110.6.120.6.130.6.140.6.150.6.40.6.50.6.60.6.70.6.80.6.90.7.00.7.10.7.1.fix10.7.20.7.30.7.4.svn.r20100.8.00.8.10.8.20.8.30.8.40.90.9.11.0.01.1.01.2.01.2.12.0.02.1.02.2.02.3.02.3.12.4.02.4.13.0.03.1.03.2.0 |
3.2.1 |
Show 4 moreShow less
| Package | Affected | Fixed |
|---|---|---|
ipythonUbuntu:Pro:14.04:LTS |
before 1.2.1-2ubuntu0.1~esm1, plus listed versions 0.13.2-21.1.0-11.2.0~rc1-11.2.1-2 |
1.2.1-2ubuntu0.1~esm1 |
ipythonUbuntu:Pro:14.04:LTS From an advisory covering 2 CVEs |
before 1.2.1-2ubuntu0.1~esm1, plus listed versions 0.13.2-21.1.0-11.2.0~rc1-11.2.1-2 |
1.2.1-2ubuntu0.1~esm1 |
ipythonUbuntu:Pro:18.04:LTS From an advisory covering 2 CVEs |
before 5.5.0-1ubuntu0.1~esm1, plus listed versions 5.1.0-35.5.0-1 |
5.5.0-1ubuntu0.1~esm1 |
ipythonUbuntu:Pro:20.04:LTS From an advisory covering 2 CVEs |
before 7.13.0-1ubuntu0.1~esm1, plus listed versions 5.8.0-15.8.0-1build15.8.0-27.12.0-17.13.0-1 |
7.13.0-1ubuntu0.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-5607 is a high vulnerability (CVSS 8.8) in Ipython, published August 3, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.21%, the 68th percentile. Fixed in ipython 2.4.1.
References
bugzilla.redhat.com/show_bug.cgi?id=1243842
lists.fedoraproject.org/pipermail/package-announce/2015-July/162671.html
lists.fedoraproject.org/pipermail/package-announce/2015-July/162936.html
github.com/ipython/ipython/commit/1415a9710407e7c14900531813c15ba6165f0816
github.com/ipython/ipython/commit/a05fe052a18810e92d9be8c1185952c13fe4e5b0
openwall.com/lists/oss-security/2015/07/21/3
Show 13 moreShow less
nvd.nist.gov/vuln/detail/CVE-2015-5607
github.com/advisories/GHSA-7fc2-rm35-2pp7
github.com/pypa/advisory-database/tree/main/vulns/ipython/PYSEC-2017-47.yaml
security-tracker.debian.org/tracker/CVE-2015-5607
github.com/ipython/ipython
advisories.mageia.org/MGASA-2015-0300.html
bugs.mageia.org/show_bug.cgi?id=16183
openwall.com/lists/oss-security/2015/06/22/7
openwall.com/lists/oss-security/2015/07/12/4
ubuntu.com/security/CVE-2015-5607
ubuntu.com/security/notices/USN-5953-1
cve.org/CVERecord?id=CVE-2015-5607
ubuntu.com/security/CVE-2022-21699