Every CVE Search/ Get API key

CVE-2015-7316

Plone Cross-site Scripting Vulnerability

6.1 MediumFix available

Cross-site scripting (XSS) vulnerability in Plone 3.3.0 through 3.3.6, 4.0.0 through 4.0.10, 4.1.0 through 4.1.6, 4.2.0 through 4.2.7, 4.3.x before 4.3.7, and 5.0rc1.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.42%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

Cross-site scripting (XSS) vulnerability in Plone 3.3.0 through 3.3.6, 4.0.0 through 4.0.10, 4.1.0 through 4.1.6, 4.2.0 through 4.2.7, 4.3.x before 4.3.7, and 5.0rc1.

Record
CVE-2015-7316
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in Plone 3.3.0 through 3.3.6, 4.0.0 through 4.0.10, 4.1.0 through 4.1.6, 4.2.0 through 4.2.7, 4.3.x before 4.3.7, and 5.0rc1.

Record
CVE-2015-7316
Updated
2026-11-02
EUVDEUVD-2017-0086 No score

Cross-site scripting (XSS) vulnerability in Plone 3.3.0 through 3.3.6, 4.0.0 through 4.0.10, 4.1.0 through 4.1.6, 4.2.0 through 4.2.7, 4.3.x before 4.3.7, and 5.0rc1.

Record
EUVD-2017-0086
Updated
2026-11-03
GitHub AdvisoriesGHSA-vf8g-m3vq-6p4p 5.3

Plone Cross-site Scripting Vulnerability

Plone's URL checking infrastructure includes a method for checking if URLs valid and located in the Plone site. By passing HTML into a specially crafted url containing <script, %3Cscript, javascript:, or javascript%3A, Cross-site Scripting can be achieved.

Record
GHSA-vf8g-m3vq-6p4p
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-vf8g-m3vq-6p4p 5.3

Plone Cross-site Scripting Vulnerability

Plone's URL checking infrastructure includes a method for checking if URLs valid and located in the Plone site. By passing HTML into a specially crafted url containing <script, %3Cscript, javascript:, or javascript%3A, Cross-site Scripting can be achieved.

Record
GHSA-vf8g-m3vq-6p4p
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVPYSEC-2017-53 No score

Cross-site scripting (XSS) vulnerability in Plone 3.3.0 through 3.3.6, 4.0.0 through 4.0.10, 4.1.0 through 4.1.6, 4.2.0 through 4.2.7, 4.3.x before 4.3.7, and 5.0rc1.

Record
PYSEC-2017-53
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
plone
PyPI
5.0rc1 to 5.0rc1 None known
plone
PyPI
3.3 to 3.3.6
3.3.7
plone
PyPI
4.0 to 4.0.10
4.0.11
plone
PyPI
4.1 to 4.1.6
4.1.7
plone
PyPI
4.2 to 4.2.7
4.2.8
plone
PyPI
4.3 up to 4.3.7
4.3.7
plone
PyPI
3.3 up to 3.3.7, plus listed versions
3.3.13.3.23.3.33.3.43.3.53.3.6
3.3.7
plone
PyPI
4.0 up to 4.0.11, plus listed versions
4.0.14.0.104.0.24.0.34.0.4
Show 5 moreShow less
4.0.54.0.64.0.74.0.84.0.9
4.0.11
plone
PyPI
4.1 up to 4.1.7, plus listed versions
4.1.14.1.24.1.34.1.44.1.54.1.6
4.1.7
plone
PyPI
4.2 up to 4.2.8, plus listed versions
4.2.14.2.24.2.34.2.44.2.54.2.64.2.7
4.2.8
plone
PyPI
4.3 up to 4.3.7, plus listed versions
4.3.14.3.24.3.34.3.44.3.54.3.6
4.3.7
plone
PyPI
Listed versions
5.0rc1
None known
plone
PyPI
3.3 up to 4.0a1, 4.0 up to 4.1a1, 4.1 up to 4.2a1, 4.2 up to 4.3a1, 4.3 up to 4.3.7, 5.0a1 up to 5.0rc2, plus listed versions
3.3.13.3.23.3.33.3.43.3.5
Show 45 moreShow less
3.3.64.0.14.0.104.0.24.0.34.0.44.0.54.0.64.0.74.0.84.0.94.1.14.1.24.1.34.1.44.1.54.1.64.2.14.2.24.2.34.2.44.2.54.2.64.2.74.3.14.3.24.3.34.3.44.3.54.3.65.0a25.0a35.0b15.0b25.0b35.0b45.0rc15.0b1.post14.3b24.3a24.2b24.2b14.2a24.2a14.1.0
4.0a14.1a14.2a14.3a14.3.75.0rc2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-7316 is a medium vulnerability (CVSS 6.1) in Plone, published September 25, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.42%, the 72nd percentile. Fixed in plone 3.3.7.

References

This page doesn't list everything

Left out here: 5 versions. The JSON record has them.

MoveEnter Open