CVE-2015-3220
tlslite remote denial of service vulnerability
The tlslite library before 0.4.9 for Python allows remote attackers to trigger a denial of service (runtime exception and process crash).
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
The tlslite library before 0.4.9 for Python allows remote attackers to trigger a denial of service (runtime exception and process crash).
- Record
CVE-2015-3220- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
The tlslite library before 0.4.9 for Python allows remote attackers to trigger a denial of service (runtime exception and process crash).
- Record
CVE-2015-3220- Updated
- 2026-11-02
EUVDEUVD-2017-0135 No score
The tlslite library before 0.4.9 for Python allows remote attackers to trigger a denial of service (runtime exception and process crash).
- Record
EUVD-2017-0135- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4749-p7rx-8jjj
8.7
tlslite remote denial of service vulnerability
The tlslite library before 0.4.9 for Python allows remote attackers to trigger a denial of service (runtime exception and process crash).
- Record
GHSA-4749-p7rx-8jjj- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSVGHSA-4749-p7rx-8jjj
8.7
tlslite remote denial of service vulnerability
The tlslite library before 0.4.9 for Python allows remote attackers to trigger a denial of service (runtime exception and process crash).
- Record
GHSA-4749-p7rx-8jjj- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSVPYSEC-2017-96 No score
The tlslite library before 0.4.9 for Python allows remote attackers to trigger a denial of service (runtime exception and process crash).
- Record
PYSEC-2017-96- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
tlslitePyPI |
before 0.4.9 | 0.4.9 |
tlslitePyPI |
before 0.4.9, plus listed versions 0.3.80.4.00.4.10.4.20.4.3 Show 5 moreShow less0.4.40.4.50.4.60.4.70.4.8 |
0.4.9 |
tlslitePyPI |
before 0.4.9, plus listed versions 0.3.80.4.00.4.10.4.20.4.3 Show 10 moreShow less0.4.40.4.50.4.60.4.70.4.8v0.4.8v0.4.3v0.4.2v0.4.1v0.3.9x |
0.4.9 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-3220 is a high vulnerability (CVSS 7.5) in Tlslite Project Tlslite, published June 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.23%, the 88th percentile. Fixed in tlslite 0.4.9.
References
groups.google.com/forum
bugzilla.redhat.com/show_bug.cgi?id=1254215
github.com/trevp/tlslite/commit/aca8d4f898b436ff6754e1a9ab96cae976c8a853
nvd.nist.gov/vuln/detail/CVE-2015-3220
github.com/pypa/advisory-database/tree/main/vulns/tlslite/PYSEC-2017-96.yaml
github.com/advisories/GHSA-4749-p7rx-8jjj
github.com/trevp/tlslite