CVE-2012-1099
Cross-site Scripting in actionpack
Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_options_helper.rb in the select helper in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving certain generation of OPTION elements within SELECT elements.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_options_helper.rb in the select helper in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving certain generation of OPTION elements within SELECT elements.
- Record
CVE-2012-1099- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_options_helper.rb in the select helper in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving certain generation of OPTION elements within SELECT elements.
- Record
CVE-2012-1099- Updated
- 2026-11-02
EUVDEUVD-2017-0151 No score
Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_options_helper.rb in the select helper in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving certain generation of OPTION elements within SELECT elements.
- Record
EUVD-2017-0151- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2xjj-5x6h-8vmf No score
Cross-site Scripting in actionpack
Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_options_helper.rb in the select helper in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving certain generation of OPTION elements within SELECT elements.
- Record
GHSA-2xjj-5x6h-8vmf- Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_options_helper.rb in the select helper in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving certain generation of OPTION elements within SELECT elements.
- Record
CVE-2012-1099- Updated
- 2026-11-02
OSVDEBIAN-CVE-2012-1099 No score
Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_options_helper.rb in the select helper in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving certain generation of OPTION elements within SELECT elements.
- Record
DEBIAN-CVE-2012-1099- Updated
- 2026-11-02
OSVGHSA-2xjj-5x6h-8vmf No score
Cross-site Scripting in actionpack
Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_options_helper.rb in the select helper in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving certain generation of OPTION elements within SELECT elements.
- Record
GHSA-2xjj-5x6h-8vmf- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
actionpackRubyGems |
3.0.0 up to 3.0.12 | 3.0.12 |
actionpackRubyGems |
3.1.0 up to 3.1.4 | 3.1.4 |
actionpackRubyGems |
3.2.0 up to 3.2.2 | 3.2.2 |
railsDebian:12 |
before 2.3.14 | 2.3.14 |
railsDebian:13 |
before 2.3.14 | 2.3.14 |
railsDebian:14 |
before 2.3.14 | 2.3.14 |
railsDebian:6.0 |
before 2.3.5-1.2+squeeze3, plus listed versions 2.3.5-1.22.3.5-1.2+squeeze0.12.3.5-1.2+squeeze12.3.5-1.2+squeeze2 |
2.3.5-1.2+squeeze3 |
actionpackRubyGems |
3.0.0 up to 3.0.12, plus listed versions 3.0.13.0.103.0.10.rc13.0.113.0.12.rc1 Show 21 moreShow less3.0.23.0.33.0.43.0.4.rc13.0.53.0.5.rc13.0.63.0.6.rc13.0.6.rc23.0.73.0.7.rc13.0.7.rc23.0.83.0.8.rc13.0.8.rc23.0.8.rc43.0.93.0.9.rc13.0.9.rc33.0.9.rc43.0.9.rc5 |
3.0.12 |
actionpackRubyGems |
3.1.0 up to 3.1.4, plus listed versions 3.1.13.1.1.rc13.1.1.rc23.1.1.rc33.1.2 Show 4 moreShow less3.1.2.rc13.1.2.rc23.1.33.1.4.rc1 |
3.1.4 |
actionpackRubyGems |
3.2.0 up to 3.2.2, plus listed versions 3.2.13.2.2.rc1 |
3.2.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2012-1099 is a medium vulnerability (CVSS 4.3) in Rubyonrails Rails, published March 13, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.39%, the 83rd percentile. Fixed in actionpack 3.0.12.
References
lists.fedoraproject.org/pipermail/package-announce/2012-March/075675.html
openwall.com/lists/oss-security/2012/03/03/1
lists.fedoraproject.org/pipermail/package-announce/2012-March/075740.html
bugzilla.redhat.com/show_bug.cgi?id=799276
debian.org/security/2012/dsa-2466
openwall.com/lists/oss-security/2012/03/02/6
Show 6 moreShow less
groups.google.com/group/rubyonrails-security/msg/6fca4f5c47705488?dmode=source&output=gplain
weblog.rubyonrails.org/2012/3/1/ann-rails-3-0-12-has-been-released
nvd.nist.gov/vuln/detail/CVE-2012-1099
github.com/advisories/GHSA-2xjj-5x6h-8vmf
github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2012-1099.yml
security-tracker.debian.org/tracker/CVE-2012-1099