CVE-2014-7192
Potential for Script Injection in syntax-error
Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.
Exploit likelihood
What each source reports
NVD Score used
10.0
Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.
- Record
CVE-2014-7192- CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-94
- Updated
- 2026-11-02
CVE List No score
Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.
- Record
CVE-2014-7192- Updated
- 2026-11-02
EUVDEUVD-2017-0167 No score
Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.
- Record
EUVD-2017-0167- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5726-g6r9-5f22 No score
Potential for Script Injection in syntax-error
Versions of syntax-error prior to 1.1.1 are affected by a cross-site scripting vulnerability which may allow a malicious file to execute code when browserified.
Recommendation
Update to version 1.1.1 or later.
- Record
GHSA-5726-g6r9-5f22- Weakness
- CWE-94
- Updated
- 2026-11-02
OSVGHSA-5726-g6r9-5f22 No score
Potential for Script Injection in syntax-error
Versions of syntax-error prior to 1.1.1 are affected by a cross-site scripting vulnerability which may allow a malicious file to execute code when browserified.
Recommendation
Update to version 1.1.1 or later.
- Record
GHSA-5726-g6r9-5f22- Weakness
- CWE-94
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-7192 No score
Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.
- Record
UBUNTU-CVE-2014-7192- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
syntax-errornpm |
before 1.1.1 | 1.1.1 |
libv8-3.14Ubuntu:16.04:LTS |
All versions, plus listed versions 3.14.5.8-5ubuntu2 |
None known |
libv8-3.14Ubuntu:18.04:LTS |
All versions, plus listed versions 3.14.5.8-11ubuntu1 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Node Browserify 4.2.0 - Remote Code Execution | 2014-07-16 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-7192 is a high vulnerability (CVSS 10.0) in Joyent Node.js, published December 11, 2014. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 13.0%, the 96th percentile. Fixed in syntax-error 1.1.1.
References
github.com/substack/node-syntax-error/commit/9aa4e66eb90ec595d2dba55e6f9c2dd9a668b309
nodesecurity.io/advisories/syntax-error-potential-script-injection
exchange.xforce.ibmcloud.com/vulnerabilities/96728
www-01.ibm.com/support/docview.wss?uid=swg21690815
nvd.nist.gov/vuln/detail/CVE-2014-7192
github.com/advisories/GHSA-5726-g6r9-5f22