Every CVE Search/ Get API key

CVE-2011-0446

Rails actionpack gem vulnerable to Cross-site Scripting

4.3 MediumFix available

CVE-2011-0446 is a medium vulnerability (CVSS 4.3) in Rubyonrails Rails, published February 14, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.35%, the 83rd percentile. Fixed in actionpack 2.3.11.

Multiple cross-site scripting (XSS) vulnerabilities in the mail_to helper in Ruby on Rails before 2.3.11, and 3.x before 3.0.4, when javascript encoding is used, allow remote attackers to inject arbitrary web script or HTML via a crafted (1) name or (2) email value.

Exploit likelihood

2.35%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Multiple cross-site scripting (XSS) vulnerabilities in the mail_to helper in Ruby on Rails before 2.3.11, and 3.x before 3.0.4, when javascript encoding is used, allow remote attackers to inject arbitrary web script or HTML via a crafted (1) name or (2) email value.

Record
CVE-2011-0446
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in the mail_to helper in Ruby on Rails before 2.3.11, and 3.x before 3.0.4, when javascript encoding is used, allow remote attackers to inject arbitrary web script or HTML via a crafted (1) name or (2) email value.

Record
CVE-2011-0446
Updated
2026-11-02
EUVDEUVD-2017-0182 No score

Multiple cross-site scripting (XSS) vulnerabilities in the mail_to helper in Ruby on Rails before 2.3.11, and 3.x before 3.0.4, when javascript encoding is used, allow remote attackers to inject arbitrary web script or HTML via a crafted (1) name or (2) email value.

Record
EUVD-2017-0182
Updated
2026-11-03
GitHub AdvisoriesGHSA-75w6-p6mg-vh8j No score

Rails actionpack gem vulnerable to Cross-site Scripting

Multiple cross-site scripting (XSS) vulnerabilities in the mail_to helper in Ruby on Rails before 2.3.11, and 3.x before 3.0.4, when javascript encoding is used, allow remote attackers to inject arbitrary web script or HTML via a crafted (1) name or (2) email value.

Record
GHSA-75w6-p6mg-vh8j
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Multiple cross-site scripting (XSS) vulnerabilities in the mail_to helper in Ruby on Rails before 2.3.11, and 3.x before 3.0.4, when javascript encoding is used, allow remote attackers to inject arbitrary web script or HTML via a crafted (1) name or (2) email value.

Record
CVE-2011-0446
Updated
2026-11-02
OSVDEBIAN-CVE-2011-0446 No score

Multiple cross-site scripting (XSS) vulnerabilities in the mail_to helper in Ruby on Rails before 2.3.11, and 3.x before 3.0.4, when javascript encoding is used, allow remote attackers to inject arbitrary web script or HTML via a crafted (1) name or (2) email value.

Record
DEBIAN-CVE-2011-0446
Updated
2026-11-02
OSVGHSA-75w6-p6mg-vh8j No score

Rails actionpack gem vulnerable to Cross-site Scripting

Multiple cross-site scripting (XSS) vulnerabilities in the mail_to helper in Ruby on Rails before 2.3.11, and 3.x before 3.0.4, when javascript encoding is used, allow remote attackers to inject arbitrary web script or HTML via a crafted (1) name or (2) email value.

Record
GHSA-75w6-p6mg-vh8j
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
actionpack
RubyGems
before 2.3.11
2.3.11
actionpack
RubyGems
3.0.0 up to 3.0.4
3.0.4
actionview
RubyGems
before 2.3.11
2.3.11
actionview
RubyGems
3.0.0 up to 3.0.4
3.0.4
rails
Debian:12
before 2.3.11-0.1
2.3.11-0.1
rails
Debian:13
before 2.3.11-0.1
2.3.11-0.1
rails
Debian:14
before 2.3.11-0.1
2.3.11-0.1
rails
Debian:6.0
before 2.3.5-1.2+squeeze0.1, plus listed versions
2.3.5-1.2
2.3.5-1.2+squeeze0.1
rails
Debian:5.0
before 2.1.0-7+lenny0.1, plus listed versions
2.1.0-62.1.0-7
2.1.0-7+lenny0.1
actionpack
RubyGems
before 2.3.11, plus listed versions
0.9.00.9.51.0.01.0.11.1.0
Show 45 moreShow less
1.10.11.10.21.11.01.11.11.11.21.12.01.12.11.12.21.12.31.12.41.12.51.13.01.13.11.13.21.13.31.13.41.13.51.13.61.2.01.3.01.3.11.4.01.5.01.5.11.6.01.7.01.8.01.8.11.9.01.9.12.0.02.0.12.0.22.0.42.0.52.1.02.1.12.1.22.2.22.2.32.3.102.3.22.3.32.3.42.3.5
2.3.11
actionpack
RubyGems
3.0.0 up to 3.0.4, plus listed versions
3.0.13.0.23.0.33.0.4.rc1
3.0.4

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 18 moreShow less
This page doesn't list everything

Left out here: 6 versions. The JSON record has them.

MoveEnter Open