Every CVE Search/ Get API key

CVE-2012-3866

Puppet allows local users to obtain sensitive configuration information

2.1 LowFix available

lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml, which allows local users to obtain sensitive configuration information by leveraging access to the puppet master server to read this file.

Exploit likelihood

0.48%Down 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.1

lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml, which allows local users to obtain sensitive configuration information by leveraging access to the puppet master server to read this file.

Record
CVE-2012-3866
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml, which allows local users to obtain sensitive configuration information by leveraging access to the puppet master server to read this file.

Record
CVE-2012-3866
Updated
2026-11-02
EUVDEUVD-2017-0193 No score

lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml, which allows local users to obtain sensitive configuration information by leveraging access to the puppet master server to read this file.

Record
EUVD-2017-0193
Updated
2026-11-03
GitHub AdvisoriesGHSA-8jxj-9r5f-w3m2 No score

Puppet allows local users to obtain sensitive configuration information

lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml, which allows local users to obtain sensitive configuration information by leveraging access to the puppet master server to read this file.

Record
GHSA-8jxj-9r5f-w3m2
Updated
2026-11-02
OSV No score

lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml, which allows local users to obtain sensitive configuration information by leveraging access to the puppet master server to read this file.

Record
CVE-2012-3866
Updated
2026-11-02
OSVDEBIAN-CVE-2012-3866 No score

lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml, which allows local users to obtain sensitive configuration information by leveraging access to the puppet master server to read this file.

Record
DEBIAN-CVE-2012-3866
Updated
2026-11-02
OSVGHSA-8jxj-9r5f-w3m2 No score

Puppet allows local users to obtain sensitive configuration information

lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml, which allows local users to obtain sensitive configuration information by leveraging access to the puppet master server to read this file.

Record
GHSA-8jxj-9r5f-w3m2
Updated
2026-11-02
OSVopenSUSE-SU-2024:10581-1 No score

ruby2.2-rubygem-puppet-3.8.7-2.2 on GA media

These are all security issues fixed in the ruby2.2-rubygem-puppet-3.8.7-2.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10581-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
puppet
RubyGems
2.7.0 up to 2.7.18
2.7.18
puppet
Debian:11
before 2.7.18-1
2.7.18-1
puppet
Debian:6.0
before 2.6.2-5+squeeze6, plus listed versions
2.6.2-42.6.2-52.6.2-5+squeeze12.6.2-5+squeeze32.6.2-5+squeeze42.6.2-5+squeeze5
2.6.2-5+squeeze6
puppet
RubyGems
2.7.0 up to 2.7.18, plus listed versions
2.7.12.7.112.7.122.7.132.7.14
Show 8 moreShow less
2.7.162.7.172.7.32.7.42.7.52.7.62.7.82.7.9
2.7.18

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-3866 is a low vulnerability (CVSS 2.1) in Puppet, published July 12, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.48%, the 41st percentile. Fixed in puppet 2.7.18.

References

Show 18 moreShow less
MoveEnter Open