Every CVE Search/ Get API key

CVE-2011-0448

activerecord vulnerable to SQL Injection

7.5 HighFix available

CVE-2011-0448 is a high vulnerability (CVSS 7.5) in Rubyonrails Rails, published February 21, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.17%, the 82nd percentile. Fixed in activerecord 3.0.4.

Ruby on Rails 3.0.x before 3.0.4 does not ensure that arguments to the limit function specify integer values, which makes it easier for remote attackers to conduct SQL injection attacks via a non-numeric argument.

Exploit likelihood

2.17%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Ruby on Rails 3.0.x before 3.0.4 does not ensure that arguments to the limit function specify integer values, which makes it easier for remote attackers to conduct SQL injection attacks via a non-numeric argument.

Record
CVE-2011-0448
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

Ruby on Rails 3.0.x before 3.0.4 does not ensure that arguments to the limit function specify integer values, which makes it easier for remote attackers to conduct SQL injection attacks via a non-numeric argument.

Record
CVE-2011-0448
Updated
2026-11-02
EUVDEUVD-2017-0265 No score

Ruby on Rails 3.0.x before 3.0.4 does not ensure that arguments to the limit function specify integer values, which makes it easier for remote attackers to conduct SQL injection attacks via a non-numeric argument.

Record
EUVD-2017-0265
Updated
2026-11-03
GitHub AdvisoriesGHSA-jmm9-2p29-vh2w No score

activerecord vulnerable to SQL Injection

Ruby on Rails 3.0.x before 3.0.4 does not ensure that arguments to the limit function specify integer values, which makes it easier for remote attackers to conduct SQL injection attacks via a non-numeric argument.

Record
GHSA-jmm9-2p29-vh2w
Weakness
CWE-89
Updated
2026-11-02
OSVGHSA-jmm9-2p29-vh2w No score

activerecord vulnerable to SQL Injection

Ruby on Rails 3.0.x before 3.0.4 does not ensure that arguments to the limit function specify integer values, which makes it easier for remote attackers to conduct SQL injection attacks via a non-numeric argument.

Record
GHSA-jmm9-2p29-vh2w
Weakness
CWE-89
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
activerecord
RubyGems
3.0.0 up to 3.0.4
3.0.4
activerecord
RubyGems
3.0.0 up to 3.0.4, plus listed versions
3.0.13.0.23.0.33.0.4.rc1
3.0.4

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 6 moreShow less
MoveEnter Open