CVE-2012-1098
activesupport Cross-site Scripting vulnerability
Cross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving a SafeBuffer object that is manipulated through certain methods.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving a SafeBuffer object that is manipulated through certain methods.
- Record
CVE-2012-1098- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving a SafeBuffer object that is manipulated through certain methods.
- Record
CVE-2012-1098- Updated
- 2026-11-02
EUVDEUVD-2017-0294 No score
Cross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving a SafeBuffer object that is manipulated through certain methods.
- Record
EUVD-2017-0294- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qv8p-v9qw-wc7g No score
activesupport Cross-site Scripting vulnerability
Cross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving a SafeBuffer object that is manipulated through certain methods.
- Record
GHSA-qv8p-v9qw-wc7g- Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Cross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving a SafeBuffer object that is manipulated through certain methods.
- Record
CVE-2012-1098- Updated
- 2026-11-02
OSVDEBIAN-CVE-2012-1098 No score
Cross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving a SafeBuffer object that is manipulated through certain methods.
- Record
DEBIAN-CVE-2012-1098- Updated
- 2026-11-02
OSVGHSA-qv8p-v9qw-wc7g No score
activesupport Cross-site Scripting vulnerability
Cross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving a SafeBuffer object that is manipulated through certain methods.
- Record
GHSA-qv8p-v9qw-wc7g- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
activesupportRubyGems |
3.0.0 up to 3.0.12 | 3.0.12 |
activesupportRubyGems |
3.1.0 up to 3.1.4 | 3.1.4 |
activesupportRubyGems |
3.2.0 up to 3.2.2 | 3.2.2 |
railsDebian:12 |
before 2.3.14 | 2.3.14 |
railsDebian:13 |
before 2.3.14 | 2.3.14 |
railsDebian:14 |
before 2.3.14 | 2.3.14 |
activesupportRubyGems |
3.0.0 up to 3.0.12, plus listed versions 3.0.13.0.103.0.10.rc13.0.113.0.12.rc1 Show 21 moreShow less3.0.23.0.33.0.43.0.4.rc13.0.53.0.5.rc13.0.63.0.6.rc13.0.6.rc23.0.73.0.7.rc13.0.7.rc23.0.83.0.8.rc13.0.8.rc23.0.8.rc43.0.93.0.9.rc13.0.9.rc33.0.9.rc43.0.9.rc5 |
3.0.12 |
activesupportRubyGems |
3.1.0 up to 3.1.4, plus listed versions 3.1.13.1.1.rc13.1.1.rc23.1.1.rc33.1.2 Show 4 moreShow less3.1.2.rc13.1.2.rc23.1.33.1.4.rc1 |
3.1.4 |
activesupportRubyGems |
3.2.0 up to 3.2.2, plus listed versions 3.2.13.2.2.rc1 |
3.2.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2012-1098 is a medium vulnerability (CVSS 4.3) in Rubyonrails Rails, published March 13, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.65%, the 85th percentile. Fixed in activesupport 3.0.12.
References
lists.fedoraproject.org/pipermail/package-announce/2012-March/075675.html
openwall.com/lists/oss-security/2012/03/03/1
bugzilla.redhat.com/show_bug.cgi?id=799275
openwall.com/lists/oss-security/2012/03/02/6
groups.google.com/group/rubyonrails-security/msg/1c2e01a5e42722c9?dmode=source&output=gplain
weblog.rubyonrails.org/2012/3/1/ann-rails-3-0-12-has-been-released
nvd.nist.gov/vuln/detail/CVE-2012-1098
github.com/advisories/GHSA-qv8p-v9qw-wc7g
security-tracker.debian.org/tracker/CVE-2012-1098