Every CVE Search/ Get API key

CVE-2006-4111

Ruby on Rails vulnerable to code injection

7.5 HighFix available

Ruby on Rails before 1.1.5 allows remote attackers to execute Ruby code with "severe" or "serious" impact via a File Upload request with an HTTP header that modifies the LOAD_PATH variable, a different vulnerability than CVE-2006-4112.

Exploit likelihood

2.33%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Ruby on Rails before 1.1.5 allows remote attackers to execute Ruby code with "severe" or "serious" impact via a File Upload request with an HTTP header that modifies the LOAD_PATH variable, a different vulnerability than CVE-2006-4112.

Record
CVE-2006-4111
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

Ruby on Rails before 1.1.5 allows remote attackers to execute Ruby code with "severe" or "serious" impact via a File Upload request with an HTTP header that modifies the LOAD_PATH variable, a different vulnerability than CVE-2006-4112.

Record
CVE-2006-4111
Updated
2026-11-02
EUVDEUVD-2017-0306 No score

Ruby on Rails before 1.1.5 allows remote attackers to execute Ruby code with "severe" or "serious" impact via a File Upload request with an HTTP header that modifies the LOAD_PATH variable, a different vulnerability than CVE-2006-4112.

Record
EUVD-2017-0306
Updated
2026-11-03
GitHub AdvisoriesGHSA-rvpq-5xqx-pfpp No score

Ruby on Rails vulnerable to code injection

Ruby on Rails before 1.1.5 allows remote attackers to execute Ruby code with "severe" or "serious" impact via a File Upload request with an HTTP header that modifies the LOAD_PATH variable, a different vulnerability than CVE-2006-4112.

Record
GHSA-rvpq-5xqx-pfpp
Weakness
CWE-94
Updated
2026-11-02
OSV No score

Ruby on Rails before 1.1.5 allows remote attackers to execute Ruby code with "severe" or "serious" impact via a File Upload request with an HTTP header that modifies the LOAD_PATH variable, a different vulnerability than CVE-2006-4112.

Record
CVE-2006-4111
Updated
2026-11-02
OSVDEBIAN-CVE-2006-4111 No score

Ruby on Rails before 1.1.5 allows remote attackers to execute Ruby code with "severe" or "serious" impact via a File Upload request with an HTTP header that modifies the LOAD_PATH variable, a different vulnerability than CVE-2006-4112.

Record
DEBIAN-CVE-2006-4111
Updated
2026-11-02
OSVGHSA-rvpq-5xqx-pfpp No score

Ruby on Rails vulnerable to code injection

Ruby on Rails before 1.1.5 allows remote attackers to execute Ruby code with "severe" or "serious" impact via a File Upload request with an HTTP header that modifies the LOAD_PATH variable, a different vulnerability than CVE-2006-4112.

Record
GHSA-rvpq-5xqx-pfpp
Weakness
CWE-94
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
rails
RubyGems
1.1.0 up to 1.1.6
1.1.6
rails
Debian:12
before 1.1.5-1
1.1.5-1
rails
Debian:13
before 1.1.5-1
1.1.5-1
rails
Debian:14
before 1.1.5-1
1.1.5-1
rails
RubyGems
1.1.0 up to 1.1.6, plus listed versions
1.1.11.1.21.1.31.1.41.1.5
1.1.6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-4111 is a high vulnerability (CVSS 7.5) in Rubyonrails Rails, published August 14, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.33%, the 83rd percentile. Fixed in rails 1.1.6.

References

Show 11 moreShow less
MoveEnter Open