CVE-2015-8856
Cross-Site Scripting in serve-index
Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary web script or HTML via a crafted file or directory name.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary web script or HTML via a crafted file or directory name.
- Record
CVE-2015-8856- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary web script or HTML via a crafted file or directory name.
- Record
CVE-2015-8856- Updated
- 2026-11-02
EUVDEUVD-2017-0311 No score
Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary web script or HTML via a crafted file or directory name.
- Record
EUVD-2017-0311- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-v633-x5vv-hqwc
6.1
Cross-Site Scripting in serve-index
Versions 1.6.2 and earlier of serve-index are affected by a cross-site scripting vulnerability. Because file and directory names are not escaped in the module's HTML output, a remote attacker that can influence file or directory names can launch a persistent cross-site scripting attack on the application.
Recommendation
Update to version 1.6.3 or later.
- Record
GHSA-v633-x5vv-hqwc- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary web script or HTML via a crafted file or directory name.
- Record
CVE-2015-8856- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-8856
6.1
Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary web script or HTML via a crafted file or directory name.
- Record
DEBIAN-CVE-2015-8856- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-v633-x5vv-hqwc
6.1
Cross-Site Scripting in serve-index
Versions 1.6.2 and earlier of serve-index are affected by a cross-site scripting vulnerability. Because file and directory names are not escaped in the module's HTML output, a remote attacker that can influence file or directory names can launch a persistent cross-site scripting attack on the application.
Recommendation
Update to version 1.6.3 or later.
- Record
GHSA-v633-x5vv-hqwc- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-8856
6.1
Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary web script or HTML via a crafted file or directory name.
- Record
UBUNTU-CVE-2015-8856- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
serve-indexnpm |
before 1.6.3 | 1.6.3 |
node-serve-indexDebian:12 |
before 1.9.1-1 | 1.9.1-1 |
node-serve-indexDebian:13 |
before 1.9.1-1 | 1.9.1-1 |
node-serve-indexDebian:14 |
before 1.9.1-1 | 1.9.1-1 |
node-serve-indexUbuntu:16.04:LTS |
All versions, plus listed versions 1.4.0-1 |
None known |
node-serve-indexUbuntu:18.04:LTS |
All versions, plus listed versions 1.4.0-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-8856 is a medium vulnerability (CVSS 6.1) in Openjsf Serve-index, published January 23, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.48%, the 84th percentile. Fixed in serve-index 1.6.3.
References
securityfocus.com/bid/96392
nodesecurity.io/advisories/34
openwall.com/lists/oss-security/2016/04/20/11
nvd.nist.gov/vuln/detail/CVE-2015-8856
github.com/expressjs/serve-index/issues/28
github.com/expressjs/serve-index/commit/7381a1d1458959e57ee53ac932b06ff17904777e
Show 7 moreShow less
web.archive.org/web/20200227190911/http://www.securityfocus.com/bid/96392
github.com/advisories/GHSA-v633-x5vv-hqwc
security-tracker.debian.org/tracker/CVE-2015-8856
github.com/expressjs/serve-index
ubuntu.com/security/CVE-2015-8856
nodesecurity.io/advisories/serve-static-xss
cve.org/CVERecord?id=CVE-2015-8856