CVE-2015-8855
Regular Expression Denial of Service in semver
The semver package before 4.3.2 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
The semver package before 4.3.2 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."
- Record
CVE-2015-8855- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 7.8 High
AV:N/AC:L/Au:N/C:N/I:N/A:C - Weakness
- CWE-399
- Updated
- 2026-11-02
CVE List No score
The semver package before 4.3.2 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."
- Record
CVE-2015-8855- Updated
- 2026-11-02
EUVDEUVD-2017-0328 No score
The semver package before 4.3.2 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."
- Record
EUVD-2017-0328- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-x6fg-f45m-jf5q
7.5
Regular Expression Denial of Service in semver
Versions 4.3.1 and earlier of semver are affected by a regular expression denial of service vulnerability when extremely long version strings are parsed.
Recommendation
Update to version 4.3.2 or later
- Record
GHSA-x6fg-f45m-jf5q- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-1333
- Updated
- 2026-11-02
OSV
7.5
The semver package before 4.3.2 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."
- Record
CVE-2015-8855- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-8855
7.5
The semver package before 4.3.2 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."
- Record
DEBIAN-CVE-2015-8855- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVGHSA-x6fg-f45m-jf5q
7.5
Regular Expression Denial of Service in semver
Versions 4.3.1 and earlier of semver are affected by a regular expression denial of service vulnerability when extremely long version strings are parsed.
Recommendation
Update to version 4.3.2 or later
- Record
GHSA-x6fg-f45m-jf5q- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-1333
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-8855
7.5
The semver package before 4.3.2 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."
- Record
UBUNTU-CVE-2015-8855- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVCLSA-2026-1773793043 No score
TuxCare security update for semver (2 CVEs)
TuxCare rebuilt semver to address 2 CVEs. Fixed in 2.3.2-tuxcare.1.
- Record
CLSA-2026-1773793043- Updated
- 2026-11-02
OSVUSN-4776-1 No score
node-semver vulnerability
It was discovered that semver incorrectly handled certain inputs. A remote attacker could possibly use this issue to cause a denial of service.
- Record
USN-4776-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
semvernpm |
1.0.4 up to 4.3.2 | 4.3.2 |
semverTuxCare:npm From an advisory covering 2 CVEs |
2.3.2-tuxcare.0 up to 2.3.2-tuxcare.1, plus listed versions 2.3.2 |
2.3.2-tuxcare.1 |
node-semverDebian:12 |
before 5.3.0-1 | 5.3.0-1 |
node-semverDebian:13 |
before 5.3.0-1 | 5.3.0-1 |
node-semverDebian:14 |
before 5.3.0-1 | 5.3.0-1 |
node-semverUbuntu:Pro:14.04:LTS |
before 2.1.0-2ubuntu0.0.1~esm1, plus listed versions 2.1.0-2 |
2.1.0-2ubuntu0.0.1~esm1 |
node-semverUbuntu:Pro:16.04:LTS |
before 2.1.0-2ubuntu0.1~esm1, plus listed versions 2.1.0-2 |
2.1.0-2ubuntu0.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-8855 is a high vulnerability (CVSS 7.5) in Nodejs Node.js, published January 23, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.89%, the 94th percentile. Fixed in semver 4.3.2.
References
securityfocus.com/bid/86957
nodesecurity.io/advisories/31
openwall.com/lists/oss-security/2016/04/20/11
nvd.nist.gov/vuln/detail/CVE-2015-8855
github.com/advisories/GHSA-x6fg-f45m-jf5q
npmjs.com/advisories/31
Show 11 moreShow less
owasp.org/index.php/Regular_expression_Denial_of_Service_-_ReDoS
github.com/github/advisory-database/pull/7102
github.com/npm/node-semver/commit/5c4c9f6e26c7052a42b5ced2a7481c5c9b4363a0
github.com/npm/node-semver/commit/c80180d8341a8ada0236815c29a2be59864afd70
security-tracker.debian.org/tracker/CVE-2015-8855
github.com/npm/node-semver
ubuntu.com/security/CVE-2015-8855
nodesecurity.io/advisories/semver_redos
github.com/npm/npm/releases/tag/v2.7.5
cve.org/CVERecord?id=CVE-2015-8855
ubuntu.com/security/notices/USN-4776-1