Every CVE Search/ Get API key

CVE-2017-0691

A denial of service vulnerability in the Android media framework. Product: Android. Versions: 7.0...

5.5 MediumFix available

A denial of service vulnerability in the Android media framework. Product: Android. Versions: 7.0, 7.1.1, 7.1.2. Android ID: A-36724453.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.02%Up 0.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

A denial of service vulnerability in the Android media framework. Product: Android. Versions: 7.0, 7.1.1, 7.1.2. Android ID: A-36724453.

Record
CVE-2017-0691
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-190
Updated
2026-11-02
CVE List No score

A denial of service vulnerability in the Android media framework. Product: Android. Versions: 7.0, 7.1.1, 7.1.2. Android ID: A-36724453.

Record
CVE-2017-0691
Updated
2026-11-02
EUVDEUVD-2017-1045 No score

A denial of service vulnerability in the Android media framework. Product: Android. Versions: 7.0, 7.1.1, 7.1.2. Android ID: A-36724453.

Record
EUVD-2017-1045
Updated
2026-11-03
GitHub AdvisoriesGHSA-cvrm-xfc5-xp29 5.5

A denial of service vulnerability in the Android media framework. Product: Android. Versions: 7.0...

A denial of service vulnerability in the Android media framework. Product: Android. Versions: 7.0, 7.1.1, 7.1.2. Android ID: A-36724453.

Record
GHSA-cvrm-xfc5-xp29
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-190
Updated
2026-11-02
OSVUBUNTU-CVE-2017-0691 5.5

A denial of service vulnerability in the Android media framework. Product: Android. Versions: 7.0, 7.1.1, 7.1.2. Android ID: A-36724453.

Record
UBUNTU-CVE-2017-0691
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-7266-1 No score

digikam vulnerabilities

Zinuo Han and Ao Wang discovered that the Android DNG SDK, vendored in digiKam, did not correctly parse certain files. An attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2017-0691)

It was discovered that Platinum Upnp SDK, vendored in digiKam, was vulnerable to a path traversal attack. An attacker could possibly use this issue to leak sensitive information. This issue only affected Ubuntu 20.04 LTS. (CVE-2020-19858)

It was discovered that LibRaw, vendored in digiKam, did not correctly handle certain memory operations. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to leak sensitive information. This issue only affected Ubuntu 20.04 LTS. (CVE-2020-22628)

It was discovered that LibRaw, vendored in digiKam, did not correctly handle certain memory operations. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-35530, CVE-2020-35531, CVE-2020-35532, CVE-2020-35533)

It was discovered that LibRaw, vendored in digiKam, did not correctly handle certain memory operations. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 20.04 LTS. (CVE-2021-32142)

It was discovered that LibRaw, vendored in digiKam, did not correctly handle certain memory operations. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. (CVE-2023-1729)

Record
USN-7266-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
digikam
Ubuntu:Pro:16.04:LTS
before 4:4.12.0-0ubuntu7+esm1, plus listed versions
4:4.12.0-0ubuntu54:4.12.0-0ubuntu64:4.12.0-0ubuntu7
4:4.12.0-0ubuntu7+esm1
digikam
Ubuntu:Pro:18.04:LTS
before 4:5.6.0-0ubuntu10+esm1, plus listed versions
4:5.6.0-0ubuntu24:5.6.0-0ubuntu34:5.6.0-0ubuntu44:5.6.0-0ubuntu74:5.6.0-0ubuntu84:5.6.0-0ubuntu94:5.6.0-0ubuntu10
4:5.6.0-0ubuntu10+esm1
digikam
Ubuntu:Pro:20.04:LTS
before 4:6.4.0+dfsg-3ubuntu0.1~esm1, plus listed versions
4:5.9.0-1ubuntu44:6.4.0+dfsg-34:6.4.0+dfsg-3build1
4:6.4.0+dfsg-3ubuntu0.1~esm1
digikam
Ubuntu:Pro:22.04:LTS
before 4:7.5.0-3ubuntu0.1~esm1, plus listed versions
4:7.1.0-24:7.1.0-2ubuntu14:7.4.0-0ubuntu14:7.5.0-0ubuntu14:7.5.0-3fakesync1
4:7.5.0-3ubuntu0.1~esm1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-0691 is a medium vulnerability (CVSS 5.5) in Google Android, published July 6, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.02%, the 63rd percentile. Fixed in digikam 4:4.12.0-0ubuntu7+esm1.

References

Show 10 moreShow less
MoveEnter Open