Every CVE Search/ Get API key

CVE-2017-1651

IBM Rational Quality Manager and IBM Rational Collaborative Lifecycle Management 5.0 through 5.0...

5.4 MediumFix available

IBM Rational Quality Manager and IBM Rational Collaborative Lifecycle Management 5.0 through 5.0.2 and 6.0 through 6.0.5 are vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 133261.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.71%Down 4.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 5.4

IBM Rational Quality Manager and IBM Rational Collaborative Lifecycle Management 5.0 through 5.0.2 and 6.0 through 6.0.5 are vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 133261.

Record
CVE-2017-1651
CVSS 3.0
5.4 MediumCVSS:3.0/A:N/AC:L/AV:N/C:L/I:L/PR:L/S:C/UI:R/E:H/RC:C/RL:O
Updated
2026-11-02
EUVDEUVD-2017-10667 5.4

IBM Rational Quality Manager and IBM Rational Collaborative Lifecycle Management 5.0 through 5.0.2 and 6.0 through 6.0.5 are vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 133261.

Record
EUVD-2017-10667
CVSS 3.0
5.4 MediumCVSS:3.0/A:N/AC:L/AV:N/C:L/I:L/PR:L/S:C/UI:R/E:H/RC:C/RL:O
Updated
2026-11-03
GitHub AdvisoriesGHSA-ww94-rc43-2gm3 5.4

IBM Rational Quality Manager and IBM Rational Collaborative Lifecycle Management 5.0 through 5.0...

IBM Rational Quality Manager and IBM Rational Collaborative Lifecycle Management 5.0 through 5.0.2 and 6.0 through 6.0.5 are vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 133261.

Record
GHSA-ww94-rc43-2gm3
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 5.4

IBM Rational Quality Manager and IBM Rational Collaborative Lifecycle Management 5.0 through 5.0.2 and 6.0 through 6.0.5 are vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 133261.

Record
CVE-2017-1651
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVSUSE-RU-2017:3408-1 No score

Recommended update for rubygem-yajl-ruby

This update for rubygem-yajl-ruby provides the following fixes:

  • Update to version 1.3.1
  • Fix crafted JSON file allows to crash ruby process with a SIGABRT (bsc#1066565, CVE-2017-1651)
Record
SUSE-RU-2017:3408-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
rubygem-yajl-ruby
SUSE:OpenStack Cloud 6
before 1.3.1-4.3.2
1.3.1-4.3.2
rubygem-yajl-ruby
SUSE:OpenStack Cloud 7
before 1.3.1-4.3.2
1.3.1-4.3.2
rubygem-yajl-ruby
SUSE:Enterprise Storage 3
before 1.3.1-4.3.2
1.3.1-4.3.2
rubygem-yajl-ruby
SUSE:Enterprise Storage 4
before 1.3.1-4.3.2
1.3.1-4.3.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-1651 is a medium vulnerability (CVSS 5.4) in Ibm Rational Collaborative Lifecycle Management, published December 21, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.71%, the 53rd percentile. Fixed in rubygem-yajl-ruby 1.3.1-4.3.2.

References

MoveEnter Open