Every CVE Search/ Get API key

CVE-2017-2447

An issue was discovered in certain Apple products. iOS before 10.3 is affected. Safari before 10...

8.1 HighPublic exploitFix available

An issue was discovered in certain Apple products. iOS before 10.3 is affected. Safari before 10.1 is affected. tvOS before 10.2 is affected. The issue involves the "WebKit" component. It allows remote attackers to obtain sensitive information or cause a denial of service (memory corruption) via a crafted web site.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
High

Exploit likelihood

5.14%Up 3.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.1

An issue was discovered in certain Apple products. iOS before 10.3 is affected. Safari before 10.1 is affected. tvOS before 10.2 is affected. The issue involves the "WebKit" component. It allows remote attackers to obtain sensitive information or cause a denial of service (memory corruption) via a crafted web site.

Record
CVE-2017-2447
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

An issue was discovered in certain Apple products. iOS before 10.3 is affected. Safari before 10.1 is affected. tvOS before 10.2 is affected. The issue involves the "WebKit" component. It allows remote attackers to obtain sensitive information or cause a denial of service (memory corruption) via a crafted web site.

Record
CVE-2017-2447
Updated
2026-11-02
EUVDEUVD-2017-11630 No score

An issue was discovered in certain Apple products. iOS before 10.3 is affected. Safari before 10.1 is affected. tvOS before 10.2 is affected. The issue involves the "WebKit" component. It allows remote attackers to obtain sensitive information or cause a denial of service (memory corruption) via a crafted web site.

Record
EUVD-2017-11630
Updated
2026-11-03
GitHub AdvisoriesGHSA-3jvv-6xf5-32ff 8.1

An issue was discovered in certain Apple products. iOS before 10.3 is affected. Safari before 10...

An issue was discovered in certain Apple products. iOS before 10.3 is affected. Safari before 10.1 is affected. tvOS before 10.2 is affected. The issue involves the "WebKit" component. It allows remote attackers to obtain sensitive information or cause a denial of service (memory corruption) via a crafted web site.

Record
GHSA-3jvv-6xf5-32ff
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 8.1

An issue was discovered in certain Apple products. iOS before 10.3 is affected. Safari before 10.1 is affected. tvOS before 10.2 is affected. The issue involves the "WebKit" component. It allows remote attackers to obtain sensitive information or cause a denial of service (memory corruption) via a crafted web site.

Record
CVE-2017-2447
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-2447 8.1

An issue was discovered in certain Apple products. iOS before 10.3 is affected. Safari before 10.1 is affected. tvOS before 10.2 is affected. The issue involves the "WebKit" component. It allows remote attackers to obtain sensitive information or cause a denial of service (memory corruption) via a crafted web site.

Record
DEBIAN-CVE-2017-2447
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-2447 8.1

An issue was discovered in certain Apple products. iOS before 10.3 is affected. Safari before 10.1 is affected. tvOS before 10.2 is affected. The issue involves the "WebKit" component. It allows remote attackers to obtain sensitive information or cause a denial of service (memory corruption) via a crafted web site.

Record
UBUNTU-CVE-2017-2447
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVUSN-3257-1 No score

webkit2gtk vulnerabilities

A large number of security issues were discovered in the WebKitGTK+ Web and JavaScript engines. If a user were tricked into viewing a malicious website, a remote attacker could exploit a variety of issues related to web browser security, including cross-site scripting attacks, denial of service attacks, and arbitrary code execution.

Record
USN-3257-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
webkit2gtk
Debian:12
before 2.16.3-2
2.16.3-2
webkit2gtk
Debian:13
before 2.16.3-2
2.16.3-2
webkit2gtk
Debian:14
before 2.16.3-2
2.16.3-2
webkit2gtk
Ubuntu:16.04:LTS
before 2.16.1-0ubuntu0.16.04.1, plus listed versions
2.8.5+dfsg1-32.10.3+dfsg1-12.10.4+dfsg1-12.10.5-12.10.6-1
Show 7 moreShow less
2.10.6-1ubuntu12.10.8-1ubuntu12.10.9-1ubuntu12.12.5-0ubuntu0.16.04.12.14.2-0ubuntu0.16.04.12.14.3-0ubuntu0.16.04.12.14.5-0ubuntu0.16.04.1
2.16.1-0ubuntu0.16.04.1
qtwebkit-opensource-src
Ubuntu:16.04:LTS
All versions, plus listed versions
5.4.2+dfsg-1ubuntu2.15.5.1+dfsg-2ubuntu1
None known
qtwebkit-source
Ubuntu:16.04:LTS
All versions, plus listed versions
2.3.2-0ubuntu102.3.2-0ubuntu11
None known
webkitgtk
Ubuntu:16.04:LTS
All versions, plus listed versions
2.4.9-2ubuntu22.4.10-0ubuntu12.4.11-0ubuntu0.1
None known
qtwebkit-opensource-src
Ubuntu:18.04:LTS
All versions, plus listed versions
5.9.1+dfsg-5ubuntu15.9.1+dfsg-5ubuntu35.212.0~alpha2-5build25.212.0~alpha2-5build45.212.0~alpha2-75.212.0~alpha2-7build25.212.0~alpha2-7ubuntu1
None known
qtwebkit-source
Ubuntu:18.04:LTS
All versions, plus listed versions
2.3.2-0ubuntu13
None known
webkitgtk
Ubuntu:18.04:LTS
All versions, plus listed versions
2.4.11-32.4.11-3ubuntu22.4.11-3ubuntu3
None known
Show 4 moreShow less
Affected packages
PackageAffectedFixed
qtwebkit-opensource-src
Ubuntu:20.04:LTS
All versions, plus listed versions
5.212.0~alpha3-35.212.0~alpha3-55.212.0~alpha3-65.212.0~alpha3-75.212.0~alpha4-15.212.0~alpha4-1ubuntu15.212.0~alpha4-1ubuntu25.212.0~alpha4-1ubuntu2.1
None known
qtwebkit-opensource-src
Ubuntu:22.04:LTS
All versions, plus listed versions
5.212.0~alpha4-125.212.0~alpha4-135.212.0~alpha4-145.212.0~alpha4-14build15.212.0~alpha4-14ubuntu25.212.0~alpha4-15ubuntu1
None known
qtwebkit-opensource-src
Ubuntu:24.04:LTS
All versions, plus listed versions
5.212.0~alpha4-335.212.0~alpha4-33build15.212.0~alpha4-345.212.0~alpha4-34ubuntu35.212.0~alpha4-34ubuntu45.212.0~alpha4-36
None known
webkit2gtk
Ubuntu:16.04:LTS
From an advisory covering 34 CVEs
before 2.16.1-0ubuntu0.16.04.1, plus listed versions
2.8.5+dfsg1-32.10.3+dfsg1-12.10.4+dfsg1-12.10.5-12.10.6-1
Show 7 moreShow less
2.10.6-1ubuntu12.10.8-1ubuntu12.10.9-1ubuntu12.12.5-0ubuntu0.16.04.12.14.2-0ubuntu0.16.04.12.14.3-0ubuntu0.16.04.12.14.5-0ubuntu0.16.04.1
2.16.1-0ubuntu0.16.04.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBApple Safari - Out-of-Bounds Read when Calling Bound Function2017-03-27

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-2447 is a high vulnerability (CVSS 8.1) in Apple Safari, published April 1, 2017. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 5.14%, the 92nd percentile. Fixed in webkit2gtk 2.16.3-2.

References

Show 41 moreShow less
MoveEnter Open