CVE-2017-2818
An exploitable heap overflow vulnerability exists in the image rendering functionality of Poppler...
An exploitable heap overflow vulnerability exists in the image rendering functionality of Poppler 0.53.0. A specifically crafted PDF can cause an overly large number of color components during image rendering, resulting in heap corruption. An attacker controlled PDF file can be used to trigger this vulnerability.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
An exploitable heap overflow vulnerability exists in the image rendering functionality of Poppler 0.53.0. A specifically crafted PDF can cause an overly large number of color components during image rendering, resulting in heap corruption. An attacker controlled PDF file can be used to trigger this vulnerability.
- Record
CVE-2017-2818- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
EUVDEUVD-2017-11959
7.5
An exploitable heap overflow vulnerability exists in the image rendering functionality of Poppler 0.53.0. A specifically crafted PDF can cause an overly large number of color components during image rendering, resulting in heap corruption. An attacker controlled PDF file can be used to trigger this vulnerability.
- Record
EUVD-2017-11959- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-65cm-pc5p-2hgx
8.8
An exploitable heap overflow vulnerability exists in the image rendering functionality of Poppler...
An exploitable heap overflow vulnerability exists in the image rendering functionality of Poppler 0.53.0. A specifically crafted PDF can cause an overly large number of color components during image rendering, resulting in heap corruption. An attacker controlled PDF file can be used to trigger this vulnerability.
- Record
GHSA-65cm-pc5p-2hgx- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
NVD
7.5
An exploitable heap overflow vulnerability exists in the image rendering functionality of Poppler 0.53.0. A specifically crafted PDF can cause an overly large number of color components during image rendering, resulting in heap corruption. An attacker controlled PDF file can be used to trigger this vulnerability.
- Record
CVE-2017-2818- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
8.8
An exploitable heap overflow vulnerability exists in the image rendering functionality of Poppler 0.53.0. A specifically crafted PDF can cause an overly large number of color components during image rendering, resulting in heap corruption. An attacker controlled PDF file can be used to trigger this vulnerability.
- Record
CVE-2017-2818- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-2818
8.8
An exploitable heap overflow vulnerability exists in the image rendering functionality of Poppler 0.53.0. A specifically crafted PDF can cause an overly large number of color components during image rendering, resulting in heap corruption. An attacker controlled PDF file can be used to trigger this vulnerability.
- Record
DEBIAN-CVE-2017-2818- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVROOT-OS-DEBIAN-12-CVE-2017-2818 No score
CVE-2017-2818 in poppler - Patched by Root
Root has patched CVE-2017-2818 in the poppler package for Root:Debian:12. Multiple fixed versions available.
- Record
ROOT-OS-DEBIAN-12-CVE-2017-2818- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
popplerDebian:12 |
All versions, plus listed versions 22.12.0-222.12.0-2+deb12u122.12.0-2+deb12u222.12.0-2+deb12u322.12.0-2.1 Show 40 moreShow less22.12.0-2.223.08.0-123.08.0-223.12.0-124.02.0-124.02.0-224.02.0-324.02.0-424.02.0-524.02.0-5+loong6424.06.0-124.06.0-224.08.0-124.08.0-224.08.0-324.08.0-425.01.0-125.01.0-225.01.0-325.01.0-425.01.0-525.03.0-125.03.0-1025.03.0-1125.03.0-11.125.03.0-225.03.0-325.03.0-425.03.0-525.03.0-625.03.0-725.03.0-926.01.0-126.01.0-226.01.0-326.01.0-426.01.0-4.126.01.0-526.07.0-126.07.0-2 |
None known |
popplerDebian:13 |
All versions, plus listed versions 25.03.0-1025.03.0-1125.03.0-11.125.03.0-525.03.0-5+deb13u2 Show 13 moreShow less25.03.0-5+deb13u325.03.0-5+deb13u425.03.0-625.03.0-725.03.0-926.01.0-126.01.0-226.01.0-326.01.0-426.01.0-4.126.01.0-526.07.0-126.07.0-2 |
None known |
popplerDebian:14 |
All versions, plus listed versions 25.03.0-1025.03.0-1125.03.0-11.125.03.0-525.03.0-6 Show 10 moreShow less25.03.0-725.03.0-926.01.0-126.01.0-226.01.0-326.01.0-426.01.0-4.126.01.0-526.07.0-126.07.0-2 |
None known |
popplerRoot:Debian:12 |
before 22.12.0-2+deb12u3.aikido.7 | 22.12.0-2+deb12u3.aikido.7 |
rootio-popplerRoot:Debian:12 |
before 22.12.0-2+deb12u3.aikido.7 | 22.12.0-2+deb12u3.aikido.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-2818 is a high vulnerability (CVSS 7.5) in Freedesktop Poppler, published July 12, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.98%, the 80th percentile. Fixed in poppler 22.12.0-2+deb12u3.aikido.7.