Every CVE Search/ Get API key

CVE-2017-5330

ark before 16.12.1 might allow remote attackers to execute arbitrary code via an executable in an...

7.8 HighFix available

ark before 16.12.1 might allow remote attackers to execute arbitrary code via an executable in an archive, related to associated applications.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.12%Down 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

ark before 16.12.1 might allow remote attackers to execute arbitrary code via an executable in an archive, related to associated applications.

Record
CVE-2017-5330
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-78
Updated
2026-11-02
CVE List No score

ark before 16.12.1 might allow remote attackers to execute arbitrary code via an executable in an archive, related to associated applications.

Record
CVE-2017-5330
Updated
2026-11-02
EUVDEUVD-2017-14435 No score

ark before 16.12.1 might allow remote attackers to execute arbitrary code via an executable in an archive, related to associated applications.

Record
EUVD-2017-14435
Updated
2026-11-03
GitHub AdvisoriesGHSA-fvqq-96pq-qq6m 7.8

ark before 16.12.1 might allow remote attackers to execute arbitrary code via an executable in an...

ark before 16.12.1 might allow remote attackers to execute arbitrary code via an executable in an archive, related to associated applications.

Record
GHSA-fvqq-96pq-qq6m
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02
OSV 7.8

ark before 16.12.1 might allow remote attackers to execute arbitrary code via an executable in an archive, related to associated applications.

Record
CVE-2017-5330
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-5330 7.8

ark before 16.12.1 might allow remote attackers to execute arbitrary code via an executable in an archive, related to associated applications.

Record
DEBIAN-CVE-2017-5330
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-5330 7.8

ark before 16.12.1 might allow remote attackers to execute arbitrary code via an executable in an archive, related to associated applications.

Record
UBUNTU-CVE-2017-5330
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2017:0140-1 No score

Security update for ark

This update for ark fixes the following issues:

  • CVE-2017-5330: ark could run executable scripts when clicking on them (boo#1018648)
Record
openSUSE-SU-2017:0140-1
Updated
2026-11-02
OSVopenSUSE-SU-2017:0150-1 No score

Security update for ark

This update for ark fixes the following issues:

  • CVE-2017-5330: ark could run executable scripts when clicking on them (boo#1018648)
Record
openSUSE-SU-2017:0150-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ark
Debian:12
before 4:16.08.3-2
4:16.08.3-2
ark
Debian:13
before 4:16.08.3-2
4:16.08.3-2
ark
Debian:14
before 4:16.08.3-2
4:16.08.3-2
ark
Ubuntu:16.04:LTS
before 4:15.12.3-0ubuntu1.1, plus listed versions
4:15.08.2-0ubuntu14:15.12.1-0ubuntu14:15.12.3-0ubuntu1
4:15.12.3-0ubuntu1.1
ark
SUSE:Package Hub 12 SP1
before 15.12.3-8.1
15.12.3-8.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-5330 is a high vulnerability (CVSS 7.8) in Kde Ark, published January 16, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.12%, the 87th percentile. Fixed in ark 4:16.08.3-2.

References

Show 8 moreShow less
MoveEnter Open