CVE-2017-5563
LibTIFF version 4.0.7 is vulnerable to a heap-based buffer over-read in tif_lzw.c resulting in...
LibTIFF version 4.0.7 is vulnerable to a heap-based buffer over-read in tif_lzw.c resulting in DoS or code execution via a crafted bmp image to tools/bmp2tiff.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
LibTIFF version 4.0.7 is vulnerable to a heap-based buffer over-read in tif_lzw.c resulting in DoS or code execution via a crafted bmp image to tools/bmp2tiff.
- Record
CVE-2017-5563- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
LibTIFF version 4.0.7 is vulnerable to a heap-based buffer over-read in tif_lzw.c resulting in DoS or code execution via a crafted bmp image to tools/bmp2tiff.
- Record
CVE-2017-5563- Updated
- 2026-11-02
EUVDEUVD-2017-14664 No score
LibTIFF version 4.0.7 is vulnerable to a heap-based buffer over-read in tif_lzw.c resulting in DoS or code execution via a crafted bmp image to tools/bmp2tiff.
- Record
EUVD-2017-14664- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qvg6-9fpw-3vw9
8.8
LibTIFF version 4.0.7 is vulnerable to a heap-based buffer over-read in tif_lzw.c resulting in...
LibTIFF version 4.0.7 is vulnerable to a heap-based buffer over-read in tif_lzw.c resulting in DoS or code execution via a crafted bmp image to tools/bmp2tiff.
- Record
GHSA-qvg6-9fpw-3vw9- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSVAZL-45150
8.8
CVE-2017-5563 affecting package openjpeg2 2.3.1-12
LibTIFF version 4.0.7 is vulnerable to a heap-based buffer over-read in tif_lzw.c resulting in DoS or code execution via a crafted bmp image to tools/bmp2tiff.
- Record
AZL-45150- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
8.8
LibTIFF version 4.0.7 is vulnerable to a heap-based buffer over-read in tif_lzw.c resulting in DoS or code execution via a crafted bmp image to tools/bmp2tiff.
- Record
CVE-2017-5563- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2017-5563
8.8
LibTIFF version 4.0.7 is vulnerable to a heap-based buffer over-read in tif_lzw.c resulting in DoS or code execution via a crafted bmp image to tools/bmp2tiff.
- Record
DEBIAN-CVE-2017-5563- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-5563
8.8
LibTIFF version 4.0.7 is vulnerable to a heap-based buffer over-read in tif_lzw.c resulting in DoS or code execution via a crafted bmp image to tools/bmp2tiff.
- Record
UBUNTU-CVE-2017-5563- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVROOT-OS-DEBIAN-12-CVE-2017-5563 No score
CVE-2017-5563 in rootio-tiff - Patched by Root
Root has patched CVE-2017-5563 in the rootio-tiff package for Root:Debian:12. Multiple fixed versions available.
- Record
ROOT-OS-DEBIAN-12-CVE-2017-5563- Updated
- 2026-11-02
OSVUSN-3606-1 No score
tiff vulnerabilities
It was discovered that LibTIFF incorrectly handled certain malformed images. If a user or automated system were tricked into opening a specially crafted image, a remote attacker could crash the application, leading to a denial of service, or possibly execute arbitrary code with user privileges.
- Record
USN-3606-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openjpeg2Azure Linux:3 |
through 2.3.1-12 | None known |
tiffDebian:12 |
before 4.0.7-1 | 4.0.7-1 |
tiffDebian:13 |
before 4.0.7-1 | 4.0.7-1 |
tiffDebian:14 |
before 4.0.7-1 | 4.0.7-1 |
tiffUbuntu:14.04:LTS |
before 4.0.3-7ubuntu0.9, plus listed versions 4.0.2-4ubuntu34.0.3-5ubuntu14.0.3-64.0.3-6ubuntu14.0.3-7 Show 7 moreShow less4.0.3-7ubuntu0.14.0.3-7ubuntu0.24.0.3-7ubuntu0.34.0.3-7ubuntu0.44.0.3-7ubuntu0.64.0.3-7ubuntu0.74.0.3-7ubuntu0.8 |
4.0.3-7ubuntu0.9 |
tiffUbuntu:16.04:LTS |
before 4.0.6-1ubuntu0.4, plus listed versions 4.0.3-12.3ubuntu24.0.5-14.0.6-14.0.6-1ubuntu0.14.0.6-1ubuntu0.24.0.6-1ubuntu0.3 |
4.0.6-1ubuntu0.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-5563 is a high vulnerability (CVSS 8.8) in Libtiff, published January 23, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.41%, the 88th percentile. Fixed in tiff 4.0.7-1.
References
bugzilla.maptools.org/show_bug.cgi?id=2664
security.gentoo.org/glsa/201709-27
usn.ubuntu.com/3606-1
securityfocus.com/bid/95705
nvd.nist.gov/vuln/detail/CVE-2017-5563
github.com/advisories/GHSA-qvg6-9fpw-3vw9
Show 15 moreShow less
security-tracker.debian.org/tracker/CVE-2017-5563
ubuntu.com/security/CVE-2017-5563
ubuntu.com/security/notices/USN-3606-1
cve.org/CVERecord?id=CVE-2017-5563
ubuntu.com/security/CVE-2016-3186
ubuntu.com/security/CVE-2016-5102
ubuntu.com/security/CVE-2016-5318
ubuntu.com/security/CVE-2017-9117
ubuntu.com/security/CVE-2017-9147
ubuntu.com/security/CVE-2017-9935
ubuntu.com/security/CVE-2017-11613
ubuntu.com/security/CVE-2017-12944
ubuntu.com/security/CVE-2017-17095
ubuntu.com/security/CVE-2017-18013
ubuntu.com/security/CVE-2018-5784