CVE-2017-1000203
ROOT version 6.9.03 and below is vulnerable to an authenticated shell metacharacter injection in...
ROOT version 6.9.03 and below is vulnerable to an authenticated shell metacharacter injection in the rootd daemon resulting in remote code execution
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
ROOT version 6.9.03 and below is vulnerable to an authenticated shell metacharacter injection in the rootd daemon resulting in remote code execution
- Record
CVE-2017-1000203- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 9.0 High
AV:N/AC:L/Au:S/C:C/I:C/A:C - Weakness
- CWE-78
- Updated
- 2026-11-02
CVE List No score
ROOT version 6.9.03 and below is vulnerable to an authenticated shell metacharacter injection in the rootd daemon resulting in remote code execution
- Record
CVE-2017-1000203- Updated
- 2026-11-02
EUVDEUVD-2017-1480 No score
ROOT version 6.9.03 and below is vulnerable to an authenticated shell metacharacter injection in the rootd daemon resulting in remote code execution
- Record
EUVD-2017-1480- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fwqx-4844-vqjq
8.8
ROOT version 6.9.03 and below is vulnerable to an authenticated shell metacharacter injection in...
ROOT version 6.9.03 and below is vulnerable to an authenticated shell metacharacter injection in the rootd daemon resulting in remote code execution
- Record
GHSA-fwqx-4844-vqjq- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
8.8
ROOT version 6.9.03 and below is vulnerable to an authenticated shell metacharacter injection in the rootd daemon resulting in remote code execution
- Record
CVE-2017-1000203- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-1000203
8.8
ROOT version 6.9.03 and below is vulnerable to an authenticated shell metacharacter injection in the rootd daemon resulting in remote code execution
- Record
UBUNTU-CVE-2017-1000203- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-4801-1 No score
root-system vulnerability
It was discovered that ROOT incorrectly handled certain input arguments. An attacker could possibly use this issue to execute arbitrary code.
- Record
USN-4801-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
root-systemUbuntu:Pro:14.04:LTS |
before 5.34.14-1ubuntu0.1~esm1, plus listed versions 5.34.09-15.34.10-15.34.14-15.34.14-1build1 |
5.34.14-1ubuntu0.1~esm1 |
root-systemUbuntu:Pro:16.04:LTS |
before 5.34.30-0ubuntu8+esm1, plus listed versions 5.34.30-0ubuntu35.34.30-0ubuntu55.34.30-0ubuntu65.34.30-0ubuntu75.34.30-0ubuntu8 |
5.34.30-0ubuntu8+esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000203 is a high vulnerability (CVSS 8.8) in Cern Root, published November 17, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.91%, the 90th percentile. Fixed in root-system 5.34.14-1ubuntu0.1~esm1.