Every CVE Search/ Get API key

CVE-2017-6308

An issue was discovered in tnef before 1.4.13. Several Integer Overflows, which can lead to Heap...

7.8 HighFix available

An issue was discovered in tnef before 1.4.13. Several Integer Overflows, which can lead to Heap Overflows, have been identified in the functions that wrap memory allocation.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.54%Up 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

An issue was discovered in tnef before 1.4.13. Several Integer Overflows, which can lead to Heap Overflows, have been identified in the functions that wrap memory allocation.

Record
CVE-2017-6308
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-190
Updated
2026-11-02
CVE List No score

An issue was discovered in tnef before 1.4.13. Several Integer Overflows, which can lead to Heap Overflows, have been identified in the functions that wrap memory allocation.

Record
CVE-2017-6308
Updated
2026-11-02
EUVDEUVD-2017-15369 No score

An issue was discovered in tnef before 1.4.13. Several Integer Overflows, which can lead to Heap Overflows, have been identified in the functions that wrap memory allocation.

Record
EUVD-2017-15369
Updated
2026-11-03
GitHub AdvisoriesGHSA-pf7f-x7x4-c238 7.8

An issue was discovered in tnef before 1.4.13. Several Integer Overflows, which can lead to Heap...

An issue was discovered in tnef before 1.4.13. Several Integer Overflows, which can lead to Heap Overflows, have been identified in the functions that wrap memory allocation.

Record
GHSA-pf7f-x7x4-c238
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-190
Updated
2026-11-02
OSV 7.8

An issue was discovered in tnef before 1.4.13. Several Integer Overflows, which can lead to Heap Overflows, have been identified in the functions that wrap memory allocation.

Record
CVE-2017-6308
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-6308 7.8

An issue was discovered in tnef before 1.4.13. Several Integer Overflows, which can lead to Heap Overflows, have been identified in the functions that wrap memory allocation.

Record
DEBIAN-CVE-2017-6308
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-6308 7.8

An issue was discovered in tnef before 1.4.13. Several Integer Overflows, which can lead to Heap Overflows, have been identified in the functions that wrap memory allocation.

Record
UBUNTU-CVE-2017-6308
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2017-0083 No score

Updated tnef packages fix security vulnerability

An issue was discovered in tnef before 1.4.13. Two OOB Writes have been identified in src/mapi_attr.c:mapi_attr_read(). These might lead to invalid read and write operations, controlled by an attacker. (CVE-2017-6307)

An issue was discovered in tnef before 1.4.13. Several Integer Overflows, which can lead to Heap Overflows, have been identified in the functions that wrap memory allocation. (CVE-2017-6308)

An issue was discovered in tnef before 1.4.13. Two type confusions have been identified in the parse_file() function. These might lead to invalid read and write operations, controlled by an attacker. (CVE-2017-6309)

An issue was discovered in tnef before 1.4.13. Four type confusions have been identified in the file_add_mapi_attrs() function. These might lead to invalid read and write operations, controlled by an attacker. (CVE-2017-6310)

Record
MGASA-2017-0083
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
tnef
Debian:12
before 1.4.12-1.1
1.4.12-1.1
tnef
Debian:13
before 1.4.12-1.1
1.4.12-1.1
tnef
Debian:14
before 1.4.12-1.1
1.4.12-1.1
tnef
Debian:7
From an advisory covering 4 CVEs
before 1.4.9-1+deb7u1, plus listed versions
1.4.9-1
1.4.9-1+deb7u1
tnef
Debian:8
From an advisory covering 4 CVEs
before 1.4.9-1+deb8u1, plus listed versions
1.4.9-1
1.4.9-1+deb8u1
tnef
Mageia:5
From an advisory covering 4 CVEs
before 1.4.9-4.1.mga5
1.4.9-4.1.mga5
tnef
Ubuntu:14.04:LTS
before 1.4.9-1+deb8u2build0.14.04.1, plus listed versions
1.4.9-1
1.4.9-1+deb8u2build0.14.04.1
tnef
Ubuntu:16.04:LTS
before 1.4.9-1+deb8u2build0.16.04.1, plus listed versions
1.4.9-1
1.4.9-1+deb8u2build0.16.04.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-6308 is a high vulnerability (CVSS 7.8) in Tnef Project Tnef, published February 24, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.54%, the 75th percentile. Fixed in tnef 1.4.12-1.1.

References

Show 8 moreShow less
MoveEnter Open