Every CVE Search/ Get API key

CVE-2017-7522

OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to denial-of-service by...

6.5 MediumFix available

OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to denial-of-service by authenticated remote attacker via sending a certificate with an embedded NULL character.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

5.54%Up 4.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to denial-of-service by authenticated remote attacker via sending a certificate with an embedded NULL character.

Record
CVE-2017-7522
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:N/A:P
Weakness
CWE-20, CWE-476
Updated
2026-11-02
CVE List No score

OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to denial-of-service by authenticated remote attacker via sending a certificate with an embedded NULL character.

Record
CVE-2017-7522
Weakness
CWE-20
Updated
2026-11-02
EUVDEUVD-2017-16539 No score

OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to denial-of-service by authenticated remote attacker via sending a certificate with an embedded NULL character.

Record
EUVD-2017-16539
Updated
2026-11-03
GitHub AdvisoriesGHSA-c6pr-p5hf-w49p 6.5

OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to denial-of-service by...

OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to denial-of-service by authenticated remote attacker via sending a certificate with an embedded NULL character.

Record
GHSA-c6pr-p5hf-w49p
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20, CWE-476
Updated
2026-11-02
OSV 6.5

OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to denial-of-service by authenticated remote attacker via sending a certificate with an embedded NULL character.

Record
CVE-2017-7522
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-7522 6.5

OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to denial-of-service by authenticated remote attacker via sending a certificate with an embedded NULL character.

Record
DEBIAN-CVE-2017-7522
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-7522 6.5

OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to denial-of-service by authenticated remote attacker via sending a certificate with an embedded NULL character.

Record
UBUNTU-CVE-2017-7522
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:11128-1 No score

openvpn-2.5.3-1.2 on GA media

These are all security issues fixed in the openvpn-2.5.3-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11128-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openvpn
Debian:12
before 2.4.3-1
2.4.3-1
openvpn
Debian:13
before 2.4.3-1
2.4.3-1
openvpn
Debian:14
before 2.4.3-1
2.4.3-1
openvpn
openSUSE:Tumbleweed
From an advisory covering 10 CVEs
before 2.5.3-1.2
2.5.3-1.2

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-7522 is a medium vulnerability (CVSS 6.5) in Openvpn, published June 27, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.54%, the 92nd percentile. Fixed in openvpn 2.4.3-1.

References

Show 13 moreShow less
MoveEnter Open