CVE-2017-7862
FFmpeg before 2017-02-07 has an out-of-bounds write caused by a heap-based buffer overflow...
FFmpeg before 2017-02-07 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame function in libavcodec/pictordec.c.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
FFmpeg before 2017-02-07 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame function in libavcodec/pictordec.c.
- Record
CVE-2017-7862- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
FFmpeg before 2017-02-07 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame function in libavcodec/pictordec.c.
- Record
CVE-2017-7862- Updated
- 2026-11-02
EUVDEUVD-2017-16837 No score
FFmpeg before 2017-02-07 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame function in libavcodec/pictordec.c.
- Record
EUVD-2017-16837- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4992-8m39-592f
9.8
FFmpeg before 2017-02-07 has an out-of-bounds write caused by a heap-based buffer overflow...
FFmpeg before 2017-02-07 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame function in libavcodec/pictordec.c.
- Record
GHSA-4992-8m39-592f- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSV
9.8
FFmpeg before 2017-02-07 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame function in libavcodec/pictordec.c.
- Record
CVE-2017-7862- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-06
OSVDEBIAN-CVE-2017-7862
9.8
FFmpeg before 2017-02-07 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame function in libavcodec/pictordec.c.
- Record
DEBIAN-CVE-2017-7862- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-7862
9.8
FFmpeg before 2017-02-07 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame function in libavcodec/pictordec.c.
- Record
UBUNTU-CVE-2017-7862- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2018-0008 No score
Updated ffmpeg packages fix security vulnerability
This update provides ffmpeg version 2.4.14, which fixes several security vulnerabilities and other bugs which were corrected upstream.
- Record
MGASA-2018-0008- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ffmpegDebian:12 |
before 7:3.2.4-1 | 7:3.2.4-1 |
ffmpegDebian:13 |
before 7:3.2.4-1 | 7:3.2.4-1 |
ffmpegDebian:14 |
before 7:3.2.4-1 | 7:3.2.4-1 |
libavDebian:7 From an advisory covering 4 CVEs |
before 6:0.8.21-0+deb7u1, plus listed versions 6:0.8.10-16:0.8.12-16:0.8.13-16:0.8.15-16:0.8.16-1 Show 11 moreShow less6:0.8.17-16:0.8.17-26:0.8.17-2+deb7u16:0.8.17-2+deb7u26:0.8.18-0+deb7u16:0.8.19-0+deb7u16:0.8.20-0+deb7u16:0.8.6-16:0.8.7-16:0.8.8-16:0.8.9-1 |
6:0.8.21-0+deb7u1 |
libavDebian:8 From an advisory covering 4 CVEs |
before 6:11.11-1~deb8u1, plus listed versions 6:11.3-16:11.3-1+deb8u16:11.3-26:11.3-36:11.4-1 Show 7 moreShow less6:11.4-1~deb8u16:11.4-26:11.4-2+x32.16:11.6-1~deb8u16:11.7-1~deb8u16:11.8-1~deb8u16:11.9-1~deb8u1 |
6:11.11-1~deb8u1 |
ffmpegMageia:5 From an advisory covering 31 CVEs |
before 2.4.14-1.mga5 | 2.4.14-1.mga5 |
ffmpegMageia:5 From an advisory covering 31 CVEs |
before 2.4.14-1.mga5.tainted | 2.4.14-1.mga5.tainted |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-7862 is a critical vulnerability (CVSS 9.8) in Ffmpeg, published April 14, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.56%, the 85th percentile. Fixed in ffmpeg 7:3.2.4-1.