Every CVE Search/ Get API key

CVE-2017-8798

Integer signedness error in MiniUPnP MiniUPnPc v1.4.20101221 through v2.0 allows remote attackers...

9.8 CriticalPublic exploitFix available

Integer signedness error in MiniUPnP MiniUPnPc v1.4.20101221 through v2.0 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

24.0%Up 18.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Integer signedness error in MiniUPnP MiniUPnPc v1.4.20101221 through v2.0 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Record
CVE-2017-8798
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Integer signedness error in MiniUPnP MiniUPnPc v1.4.20101221 through v2.0 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Record
CVE-2017-8798
Updated
2026-11-02
EUVDEUVD-2017-17741 No score

Integer signedness error in MiniUPnP MiniUPnPc v1.4.20101221 through v2.0 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Record
EUVD-2017-17741
Updated
2026-11-03
GitHub AdvisoriesGHSA-3wfp-98cg-vgm9 9.8

Integer signedness error in MiniUPnP MiniUPnPc v1.4.20101221 through v2.0 allows remote attackers...

Integer signedness error in MiniUPnP MiniUPnPc v1.4.20101221 through v2.0 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Record
GHSA-3wfp-98cg-vgm9
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 9.8

Integer signedness error in MiniUPnP MiniUPnPc v1.4.20101221 through v2.0 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Record
CVE-2017-8798
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-8798 9.8

Integer signedness error in MiniUPnP MiniUPnPc v1.4.20101221 through v2.0 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Record
DEBIAN-CVE-2017-8798
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2017-8798 9.8

Integer signedness error in MiniUPnP MiniUPnPc v1.4.20101221 through v2.0 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Record
UBUNTU-CVE-2017-8798
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2017-0313 No score

Updated miniupnpc packages fix security vulnerability

It was discovered that MiniUPnP incorrectly handled memory. A remote attacker could use this issue to cause a denial of service or possibly execute arbitrary code with privileges of the user running an application that uses the MiniUPnP library (CVE-2017-8798).

Record
MGASA-2017-0313
Updated
2026-11-02
OSVopenSUSE-SU-2024:11052-1 No score

libminiupnpc-devel-2.2.2-1.2 on GA media

These are all security issues fixed in the libminiupnpc-devel-2.2.2-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11052-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11055-1 No score

monero-devel-0.17.2.0-1.1 on GA media

These are all security issues fixed in the monero-devel-0.17.2.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11055-1
Updated
2026-11-02
OSVUSN-3298-1 No score

miniupnpc vulnerability

It was discovered that MiniUPnP incorrectly handled memory. A remote attacker could use this issue to cause a denial of service or possibly execute arbitrary code with privileges of the user running an application that uses the MiniUPnP library.

Record
USN-3298-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
miniupnpc
Debian:12
before 1.9.20140610-3
1.9.20140610-3
miniupnpc
Debian:13
before 1.9.20140610-3
1.9.20140610-3
miniupnpc
Debian:14
before 1.9.20140610-3
1.9.20140610-3
miniupnpc
Debian:8
before 1.9.20140610-2+deb8u2, plus listed versions
1.9.20140610-21.9.20140610-2+deb8u1
1.9.20140610-2+deb8u2
miniupnpc
Debian:7
before 1.5-2+deb7u2, plus listed versions
1.5-21.5-2+deb7u1
1.5-2+deb7u2
miniupnpc
Mageia:5
before 1.9.20141128-1.2.mga5
1.9.20141128-1.2.mga5
miniupnpc
Ubuntu:14.04:LTS
before 1.6-3ubuntu2.14.04.3, plus listed versions
1.6-3ubuntu21.6-3ubuntu2.14.04.11.6-3ubuntu2.14.04.2
1.6-3ubuntu2.14.04.3
miniupnpc
Ubuntu:16.04:LTS
before 1.9.20140610-2ubuntu2.16.04.1, plus listed versions
1.9.20140610-2ubuntu11.9.20140610-2ubuntu2
1.9.20140610-2ubuntu2.16.04.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBMiniUPnP MiniUPnPc < 2.0 - Remote Denial of Service2017-05-11

History

History
RecordedChangedSources
facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-8798 is a critical vulnerability (CVSS 9.8) in Miniupnp Project Miniupnpd, published May 10, 2017. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 24.0%, the 97th percentile. Fixed in miniupnpc 1.9.20140610-3.

References

Show 10 moreShow less
MoveEnter Open