Every CVE Search/ Get API key

CVE-2017-8855

wolfSSL before 3.11.0 does not prevent wc_DhAgree from accepting a malformed DH key.

7.5 HighFix available

wolfSSL before 3.11.0 does not prevent wc_DhAgree from accepting a malformed DH key.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.12%Up 0.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

wolfSSL before 3.11.0 does not prevent wc_DhAgree from accepting a malformed DH key.

Record
CVE-2017-8855
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

wolfSSL before 3.11.0 does not prevent wc_DhAgree from accepting a malformed DH key.

Record
CVE-2017-8855
Updated
2026-11-02
EUVDEUVD-2017-17797 No score

wolfSSL before 3.11.0 does not prevent wc_DhAgree from accepting a malformed DH key.

Record
EUVD-2017-17797
Updated
2026-11-03
GitHub AdvisoriesGHSA-9pgp-f7j2-6cwq 7.5

wolfSSL before 3.11.0 does not prevent wc_DhAgree from accepting a malformed DH key.

wolfSSL before 3.11.0 does not prevent wc_DhAgree from accepting a malformed DH key.

Record
GHSA-9pgp-f7j2-6cwq
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSV 7.5

wolfSSL before 3.11.0 does not prevent wc_DhAgree from accepting a malformed DH key.

Record
CVE-2017-8855
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2017-8855 7.5

wolfSSL before 3.11.0 does not prevent wc_DhAgree from accepting a malformed DH key.

Record
DEBIAN-CVE-2017-8855
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2017-8855 7.5

wolfSSL before 3.11.0 does not prevent wc_DhAgree from accepting a malformed DH key.

Record
UBUNTU-CVE-2017-8855
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wolfssl
Debian:12
before 3.12.0+dfsg-1
3.12.0+dfsg-1
wolfssl
Debian:13
before 3.12.0+dfsg-1
3.12.0+dfsg-1
wolfssl
Ubuntu:16.04:LTS
All versions, plus listed versions
3.4.8+dfsg-1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-8855 is a high vulnerability (CVSS 7.5) in Wolfssl, published May 9, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.12%, the 66th percentile. Fixed in wolfssl 3.12.0+dfsg-1.

References

MoveEnter Open