Every CVE Search/ Get API key

CVE-2017-9062

In WordPress before 4.7.5, there is improper handling of post meta data values in the XML-RPC API.

8.6 HighFix available

In WordPress before 4.7.5, there is improper handling of post meta data values in the XML-RPC API.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.77%Up 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.6

In WordPress before 4.7.5, there is improper handling of post meta data values in the XML-RPC API.

Record
CVE-2017-9062
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-79, CWE-352, CWE-601
Updated
2026-11-02
CVE List No score

In WordPress before 4.7.5, there is improper handling of post meta data values in the XML-RPC API.

Record
CVE-2017-9062
Updated
2026-11-02
EUVDEUVD-2017-18001 No score

In WordPress before 4.7.5, there is improper handling of post meta data values in the XML-RPC API.

Record
EUVD-2017-18001
Updated
2026-11-03
GitHub AdvisoriesGHSA-gv93-c8vm-3g8r 8.6

In WordPress before 4.7.5, there is improper handling of post meta data values in the XML-RPC API.

In WordPress before 4.7.5, there is improper handling of post meta data values in the XML-RPC API.

Record
GHSA-gv93-c8vm-3g8r
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Weakness
CWE-79, CWE-352
Updated
2026-11-02
OSV 8.6

In WordPress before 4.7.5, there is improper handling of post meta data values in the XML-RPC API.

Record
CVE-2017-9062
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2017-9062 8.6

In WordPress before 4.7.5, there is improper handling of post meta data values in the XML-RPC API.

Record
DEBIAN-CVE-2017-9062
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2017-9062 8.6

In WordPress before 4.7.5, there is improper handling of post meta data values in the XML-RPC API.

Record
UBUNTU-CVE-2017-9062
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 4.7.5+dfsg-1
4.7.5+dfsg-1
wordpress
Debian:13
before 4.7.5+dfsg-1
4.7.5+dfsg-1
wordpress
Debian:14
before 4.7.5+dfsg-1
4.7.5+dfsg-1
wordpress
Debian:7
before 3.6.1+dfsg-1~deb7u15, plus listed versions
3.5.1+dfsg-23.5.2+dfsg-13.5.2+dfsg-1~deb6u13.5.2+dfsg-1~deb7u13.6+dfsg-1
Show 22 moreShow less
3.6.1+dfsg-1~deb6u13.6.1+dfsg-1~deb6u23.6.1+dfsg-1~deb6u33.6.1+dfsg-1~deb6u43.6.1+dfsg-1~deb6u53.6.1+dfsg-1~deb6u63.6.1+dfsg-1~deb6u73.6.1+dfsg-1~deb6u83.6.1+dfsg-1~deb6u93.6.1+dfsg-1~deb7u13.6.1+dfsg-1~deb7u103.6.1+dfsg-1~deb7u113.6.1+dfsg-1~deb7u123.6.1+dfsg-1~deb7u133.6.1+dfsg-1~deb7u143.6.1+dfsg-1~deb7u23.6.1+dfsg-1~deb7u33.6.1+dfsg-1~deb7u43.6.1+dfsg-1~deb7u53.6.1+dfsg-1~deb7u63.6.1+dfsg-1~deb7u83.6.1+dfsg-1~deb7u9
3.6.1+dfsg-1~deb7u15
wordpress
Debian:8
before 4.1+dfsg-1+deb8u14, plus listed versions
4.1+dfsg-14.1+dfsg-1+deb8u14.1+dfsg-1+deb8u104.1+dfsg-1+deb8u114.1+dfsg-1+deb8u12
Show 9 moreShow less
4.1+dfsg-1+deb8u134.1+dfsg-1+deb8u24.1+dfsg-1+deb8u34.1+dfsg-1+deb8u44.1+dfsg-1+deb8u54.1+dfsg-1+deb8u64.1+dfsg-1+deb8u74.1+dfsg-1+deb8u84.1+dfsg-1+deb8u9
4.1+dfsg-1+deb8u14
wordpress
Ubuntu:16.04:LTS
All versions, plus listed versions
4.3+dfsg-14.3.1+dfsg-14.4+dfsg-14.4.1+dfsg-14.4.2+dfsg-14.4.2+dfsg-1ubuntu1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-9062 is a high vulnerability (CVSS 8.6) in Wordpress, published May 18, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.77%, the 78th percentile. Fixed in wordpress 4.7.5+dfsg-1.

References

Show 6 moreShow less
MoveEnter Open