CVE-2017-9470
In ytnef 1.9.2, the MAPIPrint function in lib/ytnef.c allows remote attackers to cause a denial...
In ytnef 1.9.2, the MAPIPrint function in lib/ytnef.c allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted file.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
In ytnef 1.9.2, the MAPIPrint function in lib/ytnef.c allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted file.
- Record
CVE-2017-9470- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-476
- Updated
- 2026-11-02
CVE List No score
In ytnef 1.9.2, the MAPIPrint function in lib/ytnef.c allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted file.
- Record
CVE-2017-9470- Updated
- 2026-11-02
EUVDEUVD-2017-18402 No score
In ytnef 1.9.2, the MAPIPrint function in lib/ytnef.c allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted file.
- Record
EUVD-2017-18402- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3647-wp34-wwxg
5.5
In ytnef 1.9.2, the MAPIPrint function in lib/ytnef.c allows remote attackers to cause a denial...
In ytnef 1.9.2, the MAPIPrint function in lib/ytnef.c allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted file.
- Record
GHSA-3647-wp34-wwxg- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
OSV
5.5
In ytnef 1.9.2, the MAPIPrint function in lib/ytnef.c allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted file.
- Record
CVE-2017-9470- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-9470
5.5
In ytnef 1.9.2, the MAPIPrint function in lib/ytnef.c allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted file.
- Record
DEBIAN-CVE-2017-9470- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-9470
5.5
In ytnef 1.9.2, the MAPIPrint function in lib/ytnef.c allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted file.
- Record
UBUNTU-CVE-2017-9470- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libytnefDebian:12 |
before 1.9.3-1 | 1.9.3-1 |
libytnefDebian:13 |
before 1.9.3-1 | 1.9.3-1 |
libytnefDebian:14 |
before 1.9.3-1 | 1.9.3-1 |
libytnefUbuntu:16.04:LTS |
All versions, plus listed versions 1.5-61.5-91.5-9ubuntu0.1 |
None known |
libytnefUbuntu:18.04:LTS |
All versions, plus listed versions 1.9.2-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-9470 is a medium vulnerability (CVSS 5.5) in Ytnef Project Ytnef, published June 7, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.94%, the 60th percentile. Fixed in libytnef 1.9.3-1.
References
blogs.gentoo.org/ago/2017/05/24/ytnef-null-pointer-dereference-in-mapiprint-ytnef-c
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LFJWMUEUC4ILH2HEOCYVVLQT654ZMCGQ
nvd.nist.gov/vuln/detail/CVE-2017-9470
lists.fedoraproject.org/archives/list/[email protected]/message/LFJWMUEUC4ILH2HEOCYVVLQT654ZMCGQ
github.com/advisories/GHSA-3647-wp34-wwxg
security-tracker.debian.org/tracker/CVE-2017-9470
ubuntu.com/security/CVE-2017-9470
cve.org/CVERecord?id=CVE-2017-9470