Every CVE Search/ Get API key

CVE-2017-9774

Remote Code Execution was found in Horde_Image 2.x before 2.5.0 via a crafted GET request....

8.8 HighFix available

Remote Code Execution was found in Horde_Image 2.x before 2.5.0 via a crafted GET request. Exploitation requires authentication.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.38%Up 1.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

Remote Code Execution was found in Horde_Image 2.x before 2.5.0 via a crafted GET request. Exploitation requires authentication.

Record
CVE-2017-9774
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

Remote Code Execution was found in Horde_Image 2.x before 2.5.0 via a crafted GET request. Exploitation requires authentication.

Record
CVE-2017-9774
Updated
2026-11-02
EUVDEUVD-2017-18704 No score

Remote Code Execution was found in Horde_Image 2.x before 2.5.0 via a crafted GET request. Exploitation requires authentication.

Record
EUVD-2017-18704
Updated
2026-11-03
GitHub AdvisoriesGHSA-j525-v5j5-4pq2 8.8

Remote Code Execution was found in Horde_Image 2.x before 2.5.0 via a crafted GET request....

Remote Code Execution was found in Horde_Image 2.x before 2.5.0 via a crafted GET request. Exploitation requires authentication.

Record
GHSA-j525-v5j5-4pq2
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
OSV 8.8

Remote Code Execution was found in Horde_Image 2.x before 2.5.0 via a crafted GET request. Exploitation requires authentication.

Record
CVE-2017-9774
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-9774 8.8

Remote Code Execution was found in Horde_Image 2.x before 2.5.0 via a crafted GET request. Exploitation requires authentication.

Record
DEBIAN-CVE-2017-9774
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-9774 8.8

Remote Code Execution was found in Horde_Image 2.x before 2.5.0 via a crafted GET request. Exploitation requires authentication.

Record
UBUNTU-CVE-2017-9774
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php-horde-image
Debian:12
before 2.5.1-1
2.5.1-1
php-horde-image
Debian:8
before 2.1.0-4+deb8u1, plus listed versions
2.1.0-4
2.1.0-4+deb8u1
php-horde-image
Debian:9
before 2.3.6-1+deb9u1, plus listed versions
2.3.6-1
2.3.6-1+deb9u1
php-horde-image
Ubuntu:16.04:LTS
All versions, plus listed versions
2.3.2-12.3.3-22.3.4-12.3.4-1ubuntu12.3.4-2
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-9774 is a high vulnerability (CVSS 8.8) in Horde Image Api, published June 21, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.38%, the 83rd percentile. Fixed in php-horde-image 2.5.1-1.

References

MoveEnter Open