Every CVE Search/ Get API key

CVE-2017-9781

A cross site scripting (XSS) vulnerability exists in Check_MK versions 1.4.0x prior to 1.4.0p6,...

6.1 MediumFix available

A cross site scripting (XSS) vulnerability exists in Check_MK versions 1.4.0x prior to 1.4.0p6, allowing an unauthenticated remote attacker to inject arbitrary HTML or JavaScript via the _username parameter when attempting authentication to webapi.py, which is returned unencoded with content type text/html.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.45%Up 0.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

A cross site scripting (XSS) vulnerability exists in Check_MK versions 1.4.0x prior to 1.4.0p6, allowing an unauthenticated remote attacker to inject arbitrary HTML or JavaScript via the _username parameter when attempting authentication to webapi.py, which is returned unencoded with content type text/html.

Record
CVE-2017-9781
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

A cross site scripting (XSS) vulnerability exists in Check_MK versions 1.4.0x prior to 1.4.0p6, allowing an unauthenticated remote attacker to inject arbitrary HTML or JavaScript via the _username parameter when attempting authentication to webapi.py, which is returned unencoded with content type text/html.

Record
CVE-2017-9781
Updated
2026-11-02
EUVDEUVD-2017-18711 No score

A cross site scripting (XSS) vulnerability exists in Check_MK versions 1.4.0x prior to 1.4.0p6, allowing an unauthenticated remote attacker to inject arbitrary HTML or JavaScript via the _username parameter when attempting authentication to webapi.py, which is returned unencoded with content type text/html.

Record
EUVD-2017-18711
Updated
2026-11-03
GitHub AdvisoriesGHSA-85cm-vx4m-p4x4 6.1

A cross site scripting (XSS) vulnerability exists in Check_MK versions 1.4.0x prior to 1.4.0p6,...

A cross site scripting (XSS) vulnerability exists in Check_MK versions 1.4.0x prior to 1.4.0p6, allowing an unauthenticated remote attacker to inject arbitrary HTML or JavaScript via the _username parameter when attempting authentication to webapi.py, which is returned unencoded with content type text/html.

Record
GHSA-85cm-vx4m-p4x4
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

A cross site scripting (XSS) vulnerability exists in Check_MK versions 1.4.0x prior to 1.4.0p6, allowing an unauthenticated remote attacker to inject arbitrary HTML or JavaScript via the _username parameter when attempting authentication to webapi.py, which is returned unencoded with content type text/html.

Record
CVE-2017-9781
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2017-9781 6.1

A cross site scripting (XSS) vulnerability exists in Check_MK versions 1.4.0x prior to 1.4.0p6, allowing an unauthenticated remote attacker to inject arbitrary HTML or JavaScript via the _username parameter when attempting authentication to webapi.py, which is returned unencoded with content type text/html.

Record
UBUNTU-CVE-2017-9781
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUSN-5527-1 No score

check-mk vulnerabilities

It was discovered that Checkmk incorrectly handled authentication. An attacker could possibly use this issue to cause a race condition leading to information disclosure. (CVE-2017-14955)

It was discovered that Checkmk incorrectly handled certain inputs. An attacker could use these cross-site scripting issues to inject arbitrary html or javascript code to obtain sensitive information including user information, session cookies and valid credentials. (CVE-2017-9781, CVE-2021-36563, CVE-2021-40906, CVE-2022-24565)

Record
USN-5527-1
Updated
2026-11-02
OSVUSN-5527-2 No score

check-mk vulnerabilities

USN-5527-1 fixed vulnerabilities in Checkmk. This update provides the corresponding update for Ubuntu 16.04 ESM.

Original advisory details:

It was discovered that Checkmk incorrectly handled authentication. An attacker could possibly use this issue to cause a race condition leading to information disclosure. (CVE-2017-14955)

It was discovered that Checkmk incorrectly handled certain inputs. An attacker could use these cross-site scripting issues to inject arbitrary html or javascript code to obtain sensitive information including user information, session cookies and valid credentials. (CVE-2017-9781, CVE-2021-36563, CVE-2021-40906, CVE-2022-24565)

Record
USN-5527-2
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
check-mk
Ubuntu:Pro:16.04:LTS
before 1.2.6p12-1ubuntu0.16.04.1+esm1, plus listed versions
1.2.6p5-11.2.6p12-11.2.6p12-1ubuntu0.16.04.1
1.2.6p12-1ubuntu0.16.04.1+esm1
check-mk
Ubuntu:18.04:LTS
before 1.2.8p16-1ubuntu0.2, plus listed versions
1.2.8p16-1ubuntu0.1
1.2.8p16-1ubuntu0.2
check-mk
Ubuntu:18.04:LTS
From an advisory covering 5 CVEs
before 1.2.8p16-1ubuntu0.2, plus listed versions
1.2.8p16-1ubuntu0.1
1.2.8p16-1ubuntu0.2
check-mk
Ubuntu:Pro:16.04:LTS
From an advisory covering 4 CVEs
before 1.2.6p12-1ubuntu0.16.04.1+esm1, plus listed versions
1.2.6p5-11.2.6p12-11.2.6p12-1ubuntu0.16.04.1
1.2.6p12-1ubuntu0.16.04.1+esm1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-9781 is a medium vulnerability (CVSS 6.1) in Check Mk Project Mk, published June 21, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.45%, the 73rd percentile. Fixed in check-mk 1.2.6p12-1ubuntu0.16.04.1+esm1.

References

Show 7 moreShow less
MoveEnter Open