Every CVE Search/ Get API key

CVE-2017-9928

In lrzip 0.631, a stack buffer overflow was found in the function get_fileinfo in lrzip.c:979,...

5.5 MediumFix available

In lrzip 0.631, a stack buffer overflow was found in the function get_fileinfo in lrzip.c:979, which allows attackers to cause a denial of service via a crafted file.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.01%Unchanged since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

In lrzip 0.631, a stack buffer overflow was found in the function get_fileinfo in lrzip.c:979, which allows attackers to cause a denial of service via a crafted file.

Record
CVE-2017-9928
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

In lrzip 0.631, a stack buffer overflow was found in the function get_fileinfo in lrzip.c:979, which allows attackers to cause a denial of service via a crafted file.

Record
CVE-2017-9928
Updated
2026-11-02
EUVDEUVD-2017-18838 No score

In lrzip 0.631, a stack buffer overflow was found in the function get_fileinfo in lrzip.c:979, which allows attackers to cause a denial of service via a crafted file.

Record
EUVD-2017-18838
Updated
2026-11-03
GitHub AdvisoriesGHSA-684p-g32j-92wp 5.5

In lrzip 0.631, a stack buffer overflow was found in the function get_fileinfo in lrzip.c:979,...

In lrzip 0.631, a stack buffer overflow was found in the function get_fileinfo in lrzip.c:979, which allows attackers to cause a denial of service via a crafted file.

Record
GHSA-684p-g32j-92wp
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 5.5

In lrzip 0.631, a stack buffer overflow was found in the function get_fileinfo in lrzip.c:979, which allows attackers to cause a denial of service via a crafted file.

Record
CVE-2017-9928
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-9928 5.5

In lrzip 0.631, a stack buffer overflow was found in the function get_fileinfo in lrzip.c:979, which allows attackers to cause a denial of service via a crafted file.

Record
DEBIAN-CVE-2017-9928
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-9928 5.5

In lrzip 0.631, a stack buffer overflow was found in the function get_fileinfo in lrzip.c:979, which allows attackers to cause a denial of service via a crafted file.

Record
UBUNTU-CVE-2017-9928
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-5171-1 No score

lrzip vulnerabilities

It was discovered that Long Range ZIP incorrectly handled certain specially crafted lrz files. A remote attacker could possibly use this issue to cause a denial of service (crash) or other unspecified impact.

Record
USN-5171-1
Updated
2026-11-02
OSVUSN-5171-2 No score

lrzip vulnerabilities

USN-5171-1 fixed vulnerabilities in Long Range ZIP. This update provides the corresponding updates for Ubuntu 14.04 ESM and Ubuntu 16.04 ESM.

Original advisory details:

It was discovered that Long Range ZIP incorrectly handled certain specially crafted lrz files. A remote attacker could possibly use this issue to cause a denial of service (crash) or other unspecified impact.

Record
USN-5171-2
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lrzip
Debian:12
before 0.631+git180517-1
0.631+git180517-1
lrzip
Debian:13
before 0.631+git180517-1
0.631+git180517-1
lrzip
Debian:14
before 0.631+git180517-1
0.631+git180517-1
lrzip
Debian:9
before 0.631-1+deb9u1, plus listed versions
0.631-1
0.631-1+deb9u1
lrzip
Ubuntu:Pro:14.04:LTS
before 0.616-1ubuntu0.1~esm1, plus listed versions
0.608-20.616-10.616-1ubuntu0.1~esm
0.616-1ubuntu0.1~esm1
lrzip
Ubuntu:Pro:16.04:LTS
before 0.621-1ubuntu0.1~esm1, plus listed versions
0.621-1
0.621-1ubuntu0.1~esm1
lrzip
Ubuntu:18.04:LTS
before 0.631-1+deb9u1build0.18.04.1, plus listed versions
0.631-1
0.631-1+deb9u1build0.18.04.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-9928 is a medium vulnerability (CVSS 5.5) in Debian Linux, published June 26, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.01%, the 63rd percentile. Fixed in lrzip 0.631+git180517-1.

References

Show 14 moreShow less
MoveEnter Open