CVE-2017-11107
phpLDAPadmin through 1.2.3 has XSS in htdocs/entry_chooser.php via the form, element, rdn, or...
phpLDAPadmin through 1.2.3 has XSS in htdocs/entry_chooser.php via the form, element, rdn, or container parameter.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
phpLDAPadmin through 1.2.3 has XSS in htdocs/entry_chooser.php via the form, element, rdn, or container parameter.
- Record
CVE-2017-11107- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
phpLDAPadmin through 1.2.3 has XSS in htdocs/entry_chooser.php via the form, element, rdn, or container parameter.
- Record
CVE-2017-11107- Updated
- 2026-11-02
EUVDEUVD-2017-2744 No score
phpLDAPadmin through 1.2.3 has XSS in htdocs/entry_chooser.php via the form, element, rdn, or container parameter.
- Record
EUVD-2017-2744- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-563x-7v47-fh3j
6.1
phpLDAPadmin through 1.2.3 has XSS in htdocs/entry_chooser.php via the form, element, rdn, or...
phpLDAPadmin through 1.2.3 has XSS in htdocs/entry_chooser.php via the form, element, rdn, or container parameter.
- Record
GHSA-563x-7v47-fh3j- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
phpLDAPadmin through 1.2.3 has XSS in htdocs/entry_chooser.php via the form, element, rdn, or container parameter.
- Record
CVE-2017-11107- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-11107
6.1
phpLDAPadmin through 1.2.3 has XSS in htdocs/entry_chooser.php via the form, element, rdn, or container parameter.
- Record
DEBIAN-CVE-2017-11107- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-11107
6.1
phpLDAPadmin through 1.2.3 has XSS in htdocs/entry_chooser.php via the form, element, rdn, or container parameter.
- Record
UBUNTU-CVE-2017-11107- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVMGASA-2017-0270 No score
Updated phpldapadmin packages fix security vulnerability
phpLDAPadmin through 1.2.3 has XSS in htdocs/entry_chooser.php via the form, element, rdn, or container parameter (CVE-2017-11107).
- Record
MGASA-2017-0270- Updated
- 2026-11-02
OSVUSN-4620-1 No score
phpldapadmin vulnerability
It was discovered that phpLDAPadmin didn't properly sanitize before being echoed to the user. A remote attacker could inject arbitrary HTML/Javascript code in a user's context and cause a crash, resulting in denial of service or potential execution of arbitrary code.
- Record
USN-4620-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
phpldapadminDebian:12 |
before 1.2.2-6.2 | 1.2.2-6.2 |
phpldapadminDebian:13 |
before 1.2.2-6.2 | 1.2.2-6.2 |
phpldapadminDebian:14 |
before 1.2.2-6.2 | 1.2.2-6.2 |
phpldapadminDebian:7 |
before 1.2.2-5+deb7u1, plus listed versions 1.2.2-5 |
1.2.2-5+deb7u1 |
phpldapadminDebian:8 |
before 1.2.2-5.2+deb8u1, plus listed versions 1.2.2-5.2 |
1.2.2-5.2+deb8u1 |
phpldapadminMageia:5 |
before 1.2.3-5.1.mga5 | 1.2.3-5.1.mga5 |
phpldapadminMageia:6 |
before 1.2.3-7.1.mga6 | 1.2.3-7.1.mga6 |
phpldapadminUbuntu:14.04:LTS |
before 1.2.2-5ubuntu1.2, plus listed versions 1.2.2-5ubuntu11.2.2-5ubuntu1.1 |
1.2.2-5ubuntu1.2 |
phpldapadminUbuntu:16.04:LTS |
before 1.2.2-5.2ubuntu2.1, plus listed versions 1.2.2-5.21.2.2-5.2ubuntu11.2.2-5.2ubuntu2 |
1.2.2-5.2ubuntu2.1 |
phpldapadminUbuntu:18.04:LTS |
before 1.2.2-6ubuntu1.1, plus listed versions 1.2.2-6ubuntu1 |
1.2.2-6ubuntu1.1 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Nuclei | phpLDAPadmin <= 1.2.3 - Reflected XSS |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, Nuclei, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-11107 is a medium vulnerability (CVSS 6.1) in Phpldapadmin Project Phpldapadmin, published July 8, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.07%, the 81st percentile. Fixed in phpldapadmin 1.2.2-6.2.
References
github.com/leenooks/phpLDAPadmin/issues/50
lists.debian.org/debian-lts-announce/2018/10/msg00023.html
bugs.launchpad.net/ubuntu/+source/phpldapadmin/+bug/1701731
nvd.nist.gov/vuln/detail/CVE-2017-11107
github.com/advisories/GHSA-563x-7v47-fh3j
security-tracker.debian.org/tracker/CVE-2017-11107
Show 7 moreShow less
advisories.mageia.org/MGASA-2017-0270.html
bugs.mageia.org/show_bug.cgi?id=21370
lists.fedoraproject.org/archives/list/[email protected]/thread/32G6FKD3IJA6ARX774VQKNCVAH6VF4AX
ubuntu.com/security/CVE-2017-11107
github.com/leenooks/phpLDAPadmin/pull/71
ubuntu.com/security/notices/USN-4620-1
cve.org/CVERecord?id=CVE-2017-11107