CVE-2017-11282
Adobe Flash Player has an exploitable memory corruption vulnerability in the MP4 atom parser....
Adobe Flash Player has an exploitable memory corruption vulnerability in the MP4 atom parser. Successful exploitation could lead to arbitrary code execution. This affects 26.0.0.151 and earlier.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Adobe Flash Player has an exploitable memory corruption vulnerability in the MP4 atom parser. Successful exploitation could lead to arbitrary code execution. This affects 26.0.0.151 and earlier.
- Record
CVE-2017-11282- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Adobe Flash Player has an exploitable memory corruption vulnerability in the MP4 atom parser. Successful exploitation could lead to arbitrary code execution. This affects 26.0.0.151 and earlier.
- Record
CVE-2017-11282- Updated
- 2026-11-02
EUVDEUVD-2017-2916 No score
Adobe Flash Player has an exploitable memory corruption vulnerability in the MP4 atom parser. Successful exploitation could lead to arbitrary code execution. This affects 26.0.0.151 and earlier.
- Record
EUVD-2017-2916- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vq94-9f8p-793h
9.8
Adobe Flash Player has an exploitable memory corruption vulnerability in the MP4 atom parser....
Adobe Flash Player has an exploitable memory corruption vulnerability in the MP4 atom parser. Successful exploitation could lead to arbitrary code execution. This affects 26.0.0.151 and earlier.
- Record
GHSA-vq94-9f8p-793h- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSVRHSA-2017:2702
8.8
Red Hat Security Advisory: flash-plugin security update
- Record
RHSA-2017:2702- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-11282
9.8
Adobe Flash Player has an exploitable memory corruption vulnerability in the MP4 atom parser. Successful exploitation could lead to arbitrary code execution. This affects 26.0.0.151 and earlier.
- Record
UBUNTU-CVE-2017-11282- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0339 No score
Updated flash-player-plugin packages fix security vulnerability
Adobe Flash Player 27.0.0.130 contains fixes to critical security vulnerabilities found in earlier versions that could potentially allow an attacker to take control of the affected system.
This update addresses two memory corruption vulnerabilities that could lead to code execution (CVE-2017-11281, CVE-2017-11282).
- Record
MGASA-2017-0339- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
flash-player-pluginMageia:5 From an advisory covering 2 CVEs |
before 27.0.0.130-1.mga5.nonfree | 27.0.0.130-1.mga5.nonfree |
flash-player-pluginMageia:6 From an advisory covering 2 CVEs |
before 27.0.0.130-1.mga6.nonfree | 27.0.0.130-1.mga6.nonfree |
flash-pluginRed Hat:rhel_extras:6 From an advisory covering 2 CVEs |
before 0:27.0.0.130-1.el6_9 | 0:27.0.0.130-1.el6_9 |
flashplugin-nonfreeUbuntu:14.04:LTS |
before 27.0.0.130ubuntu0.14.04.1, plus listed versions 11.2.202.310ubuntu111.2.202.327ubuntu0.13.10.111.2.202.332ubuntu111.2.202.335ubuntu111.2.202.336ubuntu1 Show 45 moreShow less11.2.202.341ubuntu111.2.202.346ubuntu111.2.202.350ubuntu111.2.202.356ubuntu0.14.04.111.2.202.359ubuntu0.14.04.111.2.202.378ubuntu0.14.04.111.2.202.394ubuntu0.14.04.111.2.202.400ubuntu0.14.04.111.2.202.406ubuntu0.14.04.111.2.202.406ubuntu0.14.04.211.2.202.411ubuntu0.14.04.111.2.202.418ubuntu0.14.04.111.2.202.424ubuntu0.14.04.111.2.202.425ubuntu0.14.04.111.2.202.429ubuntu0.14.04.111.2.202.438ubuntu0.14.04.111.2.202.440ubuntu0.14.04.111.2.202.442ubuntu0.14.04.111.2.202.451ubuntu0.14.04.111.2.202.457ubuntu0.14.04.111.2.202.460ubuntu0.14.04.111.2.202.466ubuntu0.14.04.111.2.202.468ubuntu0.14.04.111.2.202.481ubuntu0.14.04.111.2.202.481ubuntu0.14.04.211.2.202.491ubuntu0.14.04.111.2.202.508ubuntu0.14.04.111.2.202.521ubuntu0.14.04.111.2.202.535ubuntu0.14.04.111.2.202.540ubuntu0.14.04.211.2.202.548ubuntu0.14.04.111.2.202.554ubuntu0.14.04.111.2.202.559ubuntu0.14.04.111.2.202.569ubuntu0.14.04.111.2.202.577ubuntu0.14.04.111.2.202.616ubuntu0.14.04.111.2.202.621ubuntu0.14.04.111.2.202.626ubuntu0.14.04.111.2.202.632ubuntu0.14.04.111.2.202.635ubuntu0.14.04.111.2.202.637ubuntu0.14.04.111.2.202.643ubuntu0.14.04.111.2.202.644ubuntu0.14.04.124.0.0.186ubuntu0.14.04.124.0.0.194ubuntu0.14.04.1 |
27.0.0.130ubuntu0.14.04.1 |
flashplugin-nonfreeUbuntu:16.04:LTS |
before 27.0.0.130ubuntu0.16.04.1, plus listed versions 11.2.202.540ubuntu211.2.202.548ubuntu111.2.202.554ubuntu111.2.202.559ubuntu111.2.202.569ubuntu1 Show 19 moreShow less11.2.202.577ubuntu111.2.202.616ubuntu111.2.202.621ubuntu0.16.04.111.2.202.626ubuntu0.16.04.111.2.202.632ubuntu0.16.04.111.2.202.635ubuntu0.16.04.111.2.202.637ubuntu0.16.04.111.2.202.643ubuntu0.16.04.111.2.202.644ubuntu0.16.04.124.0.0.186ubuntu0.16.04.124.0.0.194ubuntu0.16.04.124.0.0.221ubuntu0.16.04.125.0.0.127ubuntu0.16.04.125.0.0.148ubuntu0.16.04.125.0.0.171ubuntu0.16.04.126.0.0.126ubuntu0.16.04.126.0.0.131ubuntu0.16.04.126.0.0.137ubuntu0.16.04.126.0.0.151ubuntu0.16.04.1 |
27.0.0.130ubuntu0.16.04.1 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Adobe Flash - Out-of-Bounds Read in applyToRange | 2017-09-25 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-11282 is a critical vulnerability (CVSS 9.8) in Adobe Flash Player, published September 14, 2017. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 34.1%, the 98th percentile. Fixed in flashplugin-nonfree 27.0.0.130ubuntu0.14.04.1.
References
packetstormsecurity.com/files/144332/Adobe-Flash-appleToRange-Out-Of-Bounds-Read.html
bugs.chromium.org/p/project-zero/issues/detail?id=1323
securityfocus.com/bid/100716
youtube.com/watch?v=6iZnIQbRf5M
security.gentoo.org/glsa/201709-16
exploit-db.com/exploits/42783
Show 17 moreShow less
helpx.adobe.com/security/products/flash-player/apsb17-28.html
access.redhat.com/errata/RHSA-2017:2702
securitytracker.com/id/1039314
nvd.nist.gov/vuln/detail/CVE-2017-11282
github.com/advisories/GHSA-vq94-9f8p-793h
advisories.mageia.org/MGASA-2017-0339.html
bugs.mageia.org/show_bug.cgi?id=21703
access.redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=1491110
security.access.redhat.com/data/csaf/v2/advisories/2017/rhsa-2017_2702.json
access.redhat.com/security/cve/CVE-2017-11281
cve.org/CVERecord?id=CVE-2017-11281
nvd.nist.gov/vuln/detail/CVE-2017-11281
access.redhat.com/security/cve/CVE-2017-11282
cve.org/CVERecord?id=CVE-2017-11282
ubuntu.com/security/CVE-2017-11282
rhn.redhat.com/errata/RHSA-2017-2702.html
Left out here: 8 versions. The JSON record has them.