Every CVE Search/ Get API key

CVE-2017-11554

There is a stack consumption vulnerability in the lex function in parser.hpp (as used in sassc)...

7.5 HighFix available

There is a stack consumption vulnerability in the lex function in parser.hpp (as used in sassc) in LibSass 3.4.5. A crafted input will lead to a remote denial of service.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.88%Up 0.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

There is a stack consumption vulnerability in the lex function in parser.hpp (as used in sassc) in LibSass 3.4.5. A crafted input will lead to a remote denial of service.

Record
CVE-2017-11554
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-674
Updated
2026-11-02
CVE List No score

There is a stack consumption vulnerability in the lex function in parser.hpp (as used in sassc) in LibSass 3.4.5. A crafted input will lead to a remote denial of service.

Record
CVE-2017-11554
Updated
2026-11-02
EUVDEUVD-2017-3169 No score

There is a stack consumption vulnerability in the lex function in parser.hpp (as used in sassc) in LibSass 3.4.5. A crafted input will lead to a remote denial of service.

Record
EUVD-2017-3169
Updated
2026-11-03
GitHub AdvisoriesGHSA-qqjx-qv79-g2q3 7.5

There is a stack consumption vulnerability in the lex function in parser.hpp (as used in sassc)...

There is a stack consumption vulnerability in the lex function in parser.hpp (as used in sassc) in LibSass 3.4.5. A crafted input will lead to a remote denial of service.

Record
GHSA-qqjx-qv79-g2q3
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-674
Updated
2026-11-02
OSV 7.5

There is a stack consumption vulnerability in the lex function in parser.hpp (as used in sassc) in LibSass 3.4.5. A crafted input will lead to a remote denial of service.

Record
CVE-2017-11554
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-11554 7.5

There is a stack consumption vulnerability in the lex function in parser.hpp (as used in sassc) in LibSass 3.4.5. A crafted input will lead to a remote denial of service.

Record
DEBIAN-CVE-2017-11554
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-11554 7.5

There is a stack consumption vulnerability in the lex function in parser.hpp (as used in sassc) in LibSass 3.4.5. A crafted input will lead to a remote denial of service.

Record
UBUNTU-CVE-2017-11554
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libsass
Debian:12
before 3.5.4-1
3.5.4-1
libsass
Debian:13
before 3.5.4-1
3.5.4-1
libsass
Debian:14
before 3.5.4-1
3.5.4-1
libsass
Ubuntu:16.04:LTS
All versions, plus listed versions
3.2.5-13.2.5-23.3.2-13.3.4-1
None known
libsass
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.4.3-13.4.6-13.4.8-13.4.8-1ubuntu0.1~esm1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-11554 is a high vulnerability (CVSS 7.5) in Libsass, published July 23, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.88%, the 79th percentile. Fixed in libsass 3.5.4-1.

References

MoveEnter Open