CVE-2017-11636
GraphicsMagick 1.3.26 has a heap overflow in the WriteRGBImage() function in coders/rgb.c when...
GraphicsMagick 1.3.26 has a heap overflow in the WriteRGBImage() function in coders/rgb.c when processing multiple frames that have non-identical widths.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
GraphicsMagick 1.3.26 has a heap overflow in the WriteRGBImage() function in coders/rgb.c when processing multiple frames that have non-identical widths.
- Record
CVE-2017-11636- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
GraphicsMagick 1.3.26 has a heap overflow in the WriteRGBImage() function in coders/rgb.c when processing multiple frames that have non-identical widths.
- Record
CVE-2017-11636- Updated
- 2026-11-02
EUVDEUVD-2017-3248 No score
GraphicsMagick 1.3.26 has a heap overflow in the WriteRGBImage() function in coders/rgb.c when processing multiple frames that have non-identical widths.
- Record
EUVD-2017-3248- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-w35m-mj4p-jp8q
9.8
GraphicsMagick 1.3.26 has a heap overflow in the WriteRGBImage() function in coders/rgb.c when...
GraphicsMagick 1.3.26 has a heap overflow in the WriteRGBImage() function in coders/rgb.c when processing multiple frames that have non-identical widths.
- Record
GHSA-w35m-mj4p-jp8q- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
9.8
GraphicsMagick 1.3.26 has a heap overflow in the WriteRGBImage() function in coders/rgb.c when processing multiple frames that have non-identical widths.
- Record
CVE-2017-11636- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-11636
9.8
GraphicsMagick 1.3.26 has a heap overflow in the WriteRGBImage() function in coders/rgb.c when processing multiple frames that have non-identical widths.
- Record
DEBIAN-CVE-2017-11636- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-11636
9.8
GraphicsMagick 1.3.26 has a heap overflow in the WriteRGBImage() function in coders/rgb.c when processing multiple frames that have non-identical widths.
- Record
UBUNTU-CVE-2017-11636- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVSUSE-SU-2017:2229-1 No score
Security update for GraphicsMagick
This update for GraphicsMagick fixes the following issues:
Security issues fixed:
- CVE-2017-8350: The PNG/JNG decoder recieved an incremental fix, fixing some related issues in the same code. (bsc#1036985)
- CVE-2017-9439: A memory leak was found in the function ReadPDBImage incoders/pdb.c (bsc#1042826)
- CVE-2017-9501: An assertion failure could cause a denial of service via a crafted file (bsc#1043289)
- CVE-2017-11403: The ReadMNGImage function in coders/png.c has an out-of-order CloseBlob call, resulting in a use-after-free via a crafted file (bsc#1049072)
- CVE-2017-11643: A heap overflow in WriteCMYKImage()function in coders/cmyk.c was fixed (bsc#1050611)
- CVE-2017-11636: A heap overflow in WriteRGBImage() in coders/rgb.c was fixed (bsc#1050674)
- Record
SUSE-SU-2017:2229-1- Updated
- 2026-11-02
OSVUSN-4206-1 No score
graphicsmagick vulnerabilities
It was discovered that GraphicsMagick incorrectly handled certain image files. An attacker could possibly use this issue to cause a denial of service. (CVE-2017-10794, CVE-2017-10799, CVE-2017-11102, CVE-2017-11140, CVE-2017-11403, CVE-2017-11636, CVE-2017-11637, CVE-2017-13147, CVE-2017-14042, CVE-2017-6335)
- Record
USN-4206-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
graphicsmagickDebian:12 |
before 1.3.26-4 | 1.3.26-4 |
graphicsmagickDebian:13 |
before 1.3.26-4 | 1.3.26-4 |
graphicsmagickDebian:14 |
before 1.3.26-4 | 1.3.26-4 |
graphicsmagickDebian:7 From an advisory covering 10 CVEs |
before 1.3.16-1.1+deb7u8, plus listed versions 1.3.16-1.11.3.16-1.1+deb7u11.3.16-1.1+deb7u21.3.16-1.1+deb7u31.3.16-1.1+deb7u41.3.16-1.1+deb7u51.3.16-1.1+deb7u61.3.16-1.1+deb7u7 |
1.3.16-1.1+deb7u8 |
graphicsmagickDebian:8 From an advisory covering 27 CVEs |
before 1.3.20-3+deb8u3, plus listed versions 1.3.20-3+deb8u11.3.20-3+deb8u2 |
1.3.20-3+deb8u3 |
graphicsmagickDebian:9 From an advisory covering 56 CVEs |
before 1.3.30+hg15796-1~deb9u1, plus listed versions 1.3.25-81.3.26-11.3.26-101.3.26-111.3.26-12 Show 24 moreShow less1.3.26-131.3.26-141.3.26-151.3.26-161.3.26-171.3.26-181.3.26-191.3.26-21.3.26-31.3.26-41.3.26-51.3.26-61.3.26-71.3.26-81.3.26-91.3.27-11.3.27-21.3.27-31.3.27-41.3.28-11.3.28-21.3.29+hg15665-11.3.29-11.3.30-1 |
1.3.30+hg15796-1~deb9u1 |
GraphicsMagickSUSE:Linux Enterprise Software Development Kit 11 SP4 From an advisory covering 6 CVEs |
before 1.2.5-4.78.9.1 | 1.2.5-4.78.9.1 |
GraphicsMagickSUSE:Studio Onsite 1.3 From an advisory covering 6 CVEs |
before 1.2.5-4.78.9.1 | 1.2.5-4.78.9.1 |
graphicsmagickUbuntu:Pro:14.04:LTS |
before 1.3.18-1ubuntu3.1+esm2, plus listed versions 1.3.16-1.1ubuntu21.3.16-1.1ubuntu31.3.18-1ubuntu31.3.18-1ubuntu3.11.3.18-1ubuntu3.1+esm1 |
1.3.18-1ubuntu3.1+esm2 |
graphicsmagickUbuntu:16.04:LTS |
before 1.3.23-1ubuntu0.2, plus listed versions 1.3.21-31.3.23-11.3.23-1build11.3.23-1ubuntu0.1 |
1.3.23-1ubuntu0.2 |
graphicsmagickUbuntu:16.04:LTS From an advisory covering 10 CVEs |
before 1.3.23-1ubuntu0.2, plus listed versions 1.3.21-31.3.23-11.3.23-1build11.3.23-1ubuntu0.1 |
1.3.23-1ubuntu0.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-11636 is a critical vulnerability (CVSS 9.8) in Graphicsmagick, published July 26, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.09%, the 87th percentile. Fixed in graphicsmagick 1.3.26-4.
References
hg.code.sf.net/p/graphicsmagick/code/rev/39961adf974c
debian.org/security/2018/dsa-4321
lists.debian.org/debian-lts-announce/2018/06/msg00009.html
securityfocus.com/bid/99978
usn.ubuntu.com/4206-1
nvd.nist.gov/vuln/detail/CVE-2017-11636
Show 27 moreShow less
github.com/advisories/GHSA-w35m-mj4p-jp8q
security-tracker.debian.org/tracker/CVE-2017-11636
suse.com/support/update/announcement/2017/suse-su-20172229-1
bugzilla.suse.com/1036985
bugzilla.suse.com/1042826
bugzilla.suse.com/1043289
bugzilla.suse.com/1049072
bugzilla.suse.com/1050611
bugzilla.suse.com/1050674
suse.com/security/cve/CVE-2017-11403
suse.com/security/cve/CVE-2017-11636
suse.com/security/cve/CVE-2017-11643
suse.com/security/cve/CVE-2017-8350
suse.com/security/cve/CVE-2017-9439
suse.com/security/cve/CVE-2017-9501
ubuntu.com/security/CVE-2017-11636
ubuntu.com/security/notices/USN-4206-1
cve.org/CVERecord?id=CVE-2017-11636
ubuntu.com/security/CVE-2017-6335
ubuntu.com/security/CVE-2017-10794
ubuntu.com/security/CVE-2017-10799
ubuntu.com/security/CVE-2017-11102
ubuntu.com/security/CVE-2017-11140
ubuntu.com/security/CVE-2017-11403
ubuntu.com/security/CVE-2017-11637
ubuntu.com/security/CVE-2017-13147
ubuntu.com/security/CVE-2017-14042