Every CVE Search/ Get API key

CVE-2017-11661

The _WM_SetupMidiEvent function in internal_midi.c:2318 in WildMIDI 0.4.2 can cause a denial of...

7.5 HighPublic exploitFix available

The _WM_SetupMidiEvent function in internal_midi.c:2318 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

11.1%Up 7.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

The _WM_SetupMidiEvent function in internal_midi.c:2318 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.

Record
CVE-2017-11661
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

The _WM_SetupMidiEvent function in internal_midi.c:2318 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.

Record
CVE-2017-11661
Updated
2026-11-02
EUVDEUVD-2017-3273 No score

The _WM_SetupMidiEvent function in internal_midi.c:2318 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.

Record
EUVD-2017-3273
Updated
2026-11-03
GitHub AdvisoriesGHSA-8gh9-3698-mj6g 7.5

The _WM_SetupMidiEvent function in internal_midi.c:2318 in WildMIDI 0.4.2 can cause a denial of...

The _WM_SetupMidiEvent function in internal_midi.c:2318 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.

Record
GHSA-8gh9-3698-mj6g
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 7.5

The _WM_SetupMidiEvent function in internal_midi.c:2318 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.

Record
CVE-2017-11661
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-11661 7.5

The _WM_SetupMidiEvent function in internal_midi.c:2318 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.

Record
DEBIAN-CVE-2017-11661
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2017-11661 7.5

The _WM_SetupMidiEvent function in internal_midi.c:2318 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.

Record
UBUNTU-CVE-2017-11661
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2018-0061 No score

Updated wildmidi packages fix security vulnerabilities

The _WM_SetupMidiEvent function in internal_midi.c:2318 in WildMIDI before 0.4.2 can cause a denial of service(invalid memory read and application crash) via a crafted mid file (CVE-2017-11661).

The _WM_ParseNewMidi function in f_midi.c in WildMIDI before 0.4.2 can cause a denial of service(invalid memory read and application crash) via a crafted mid file (CVE-2017-11662).

The _WM_SetupMidiEvent function in internal_midi.c:2315 in WildMIDI before 0.4.2 can cause a denial of service(invalid memory read and application crash) via a crafted mid file (CVE-2017-11663).

The _WM_SetupMidiEvent function in internal_midi.c:2122 in WildMIDI before 0.4.2 can cause a denial of service(invalid memory read and application crash) via a crafted mid file (CVE-2017-11664).

Record
MGASA-2018-0061
Updated
2026-11-02
OSVopenSUSE-SU-2024:11512-1 No score

libWildMidi2-0.4.4-1.3 on GA media

These are all security issues fixed in the libWildMidi2-0.4.4-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11512-1
Updated
2026-11-02
OSVUSN-4807-1 No score

wildmidi vulnerabilities

It was discovered that WildMIDI incorrectly handled certain MID files. A remote attacker could possibly use this issue to cause a denial of service.

Record
USN-4807-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wildmidi
Debian:12
before 0.4.2-1
0.4.2-1
wildmidi
Debian:13
before 0.4.2-1
0.4.2-1
wildmidi
Debian:14
before 0.4.2-1
0.4.2-1
wildmidi
Mageia:6
From an advisory covering 4 CVEs
before 0.4.2-1.mga6
0.4.2-1.mga6
wildmidi
Ubuntu:14.04:LTS
All versions, plus listed versions
0.2.3.4-2.1ubuntu20.2.3.4-2.1ubuntu3
None known
wildmidi
Ubuntu:Pro:16.04:LTS
before 0.3.8-2ubuntu0.1~esm1, plus listed versions
0.3.8-2
0.3.8-2ubuntu0.1~esm1
wildmidi
Ubuntu:Pro:16.04:LTS
From an advisory covering 4 CVEs
before 0.3.8-2ubuntu0.1~esm1, plus listed versions
0.3.8-2
0.3.8-2ubuntu0.1~esm1
wildmidi
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 0.4.4-1.3
0.4.4-1.3

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBWildMIDI 0.4.2 - Multiple Vulnerabilities2017-08-08

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-11661 is a high vulnerability (CVSS 7.5) in Mindwerks Wildmidi, published August 17, 2017. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 11.1%, the 95th percentile. Fixed in wildmidi 0.4.2-1.

References

Show 11 moreShow less
MoveEnter Open