CVE-2017-12447
GdkPixBuf (aka gdk-pixbuf), possibly 2.32.2, as used by GNOME Nautilus 3.14.3 on Ubuntu 16.04,...
GdkPixBuf (aka gdk-pixbuf), possibly 2.32.2, as used by GNOME Nautilus 3.14.3 on Ubuntu 16.04, allows attackers to cause a denial of service (stack corruption) or possibly have unspecified other impact via a crafted file folder.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
GdkPixBuf (aka gdk-pixbuf), possibly 2.32.2, as used by GNOME Nautilus 3.14.3 on Ubuntu 16.04, allows attackers to cause a denial of service (stack corruption) or possibly have unspecified other impact via a crafted file folder.
- Record
CVE-2017-12447- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
GdkPixBuf (aka gdk-pixbuf), possibly 2.32.2, as used by GNOME Nautilus 3.14.3 on Ubuntu 16.04, allows attackers to cause a denial of service (stack corruption) or possibly have unspecified other impact via a crafted file folder.
- Record
CVE-2017-12447- Updated
- 2026-11-02
EUVDEUVD-2017-4019 No score
GdkPixBuf (aka gdk-pixbuf), possibly 2.32.2, as used by GNOME Nautilus 3.14.3 on Ubuntu 16.04, allows attackers to cause a denial of service (stack corruption) or possibly have unspecified other impact via a crafted file folder.
- Record
EUVD-2017-4019- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5737-crgv-prwm
7.8
GdkPixBuf (aka gdk-pixbuf), possibly 2.32.2, as used by GNOME Nautilus 3.14.3 on Ubuntu 16.04,...
GdkPixBuf (aka gdk-pixbuf), possibly 2.32.2, as used by GNOME Nautilus 3.14.3 on Ubuntu 16.04, allows attackers to cause a denial of service (stack corruption) or possibly have unspecified other impact via a crafted file folder.
- Record
GHSA-5737-crgv-prwm- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
7.8
GdkPixBuf (aka gdk-pixbuf), possibly 2.32.2, as used by GNOME Nautilus 3.14.3 on Ubuntu 16.04, allows attackers to cause a denial of service (stack corruption) or possibly have unspecified other impact via a crafted file folder.
- Record
CVE-2017-12447- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-04
OSVDEBIAN-CVE-2017-12447
7.8
GdkPixBuf (aka gdk-pixbuf), possibly 2.32.2, as used by GNOME Nautilus 3.14.3 on Ubuntu 16.04, allows attackers to cause a denial of service (stack corruption) or possibly have unspecified other impact via a crafted file folder.
- Record
DEBIAN-CVE-2017-12447- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-12447
7.8
GdkPixBuf (aka gdk-pixbuf), possibly 2.32.2, as used by GNOME Nautilus 3.14.3 on Ubuntu 16.04, allows attackers to cause a denial of service (stack corruption) or possibly have unspecified other impact via a crafted file folder.
- Record
UBUNTU-CVE-2017-12447- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-3912-1 No score
gdk-pixbuf vulnerability
It was discovered that the GDK-PixBuf library did not properly handle certain BMP images. If an user or automated system were tricked into opening a specially crafted BMP file, a remote attacker could use this flaw to cause GDK-PixBuf to crash, resulting in a denial of service, or possibly execute arbitrary code.
- Record
USN-3912-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gdk-pixbufDebian:12 |
before 2.34.0-1 | 2.34.0-1 |
gdk-pixbufDebian:13 |
before 2.34.0-1 | 2.34.0-1 |
gdk-pixbufDebian:14 |
before 2.34.0-1 | 2.34.0-1 |
gdk-pixbufUbuntu:14.04:LTS |
before 2.30.7-0ubuntu1.6, plus listed versions 2.28.1-1ubuntu22.30.0-0ubuntu22.30.1-0ubuntu22.30.2-0ubuntu12.30.2-0ubuntu2 Show 7 moreShow less2.30.3-0ubuntu12.30.4-0ubuntu12.30.5-0ubuntu12.30.6-12.30.7-0ubuntu12.30.7-0ubuntu1.12.30.7-0ubuntu1.2 |
2.30.7-0ubuntu1.6 |
gdk-pixbufUbuntu:16.04:LTS |
before 2.32.2-1ubuntu1.6, plus listed versions 2.32.1-12.32.2-12.32.2-1ubuntu12.32.2-1ubuntu1.22.32.2-1ubuntu1.32.32.2-1ubuntu1.42.32.2-1ubuntu1.5 |
2.32.2-1ubuntu1.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-12447 is a high vulnerability (CVSS 7.8) in Gnome Gdk-pixbuf, published March 7, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.15%, the 66th percentile. Fixed in gdk-pixbuf 2.34.0-1.
References
bugzilla.gnome.org/show_bug.cgi?id=785979
github.com/hackerlib/hackerlib-vul/tree/master/gnome
usn.ubuntu.com/3912-1
nvd.nist.gov/vuln/detail/CVE-2017-12447
github.com/advisories/GHSA-5737-crgv-prwm
security-tracker.debian.org/tracker/CVE-2017-12447
ubuntu.com/security/CVE-2017-12447
ubuntu.com/security/notices/USN-3912-1
cve.org/CVERecord?id=CVE-2017-12447