Every CVE Search/ Get API key

CVE-2017-12608

A vulnerability in Apache OpenOffice Writer DOC file parser before 4.1.4, and specifically in...

7.8 HighFix available

A vulnerability in Apache OpenOffice Writer DOC file parser before 4.1.4, and specifically in ImportOldFormatStyles, allows attackers to craft malicious documents that cause denial of service (memory corruption and application crash) potentially resulting in arbitrary code execution.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.89%Down 4.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

A vulnerability in Apache OpenOffice Writer DOC file parser before 4.1.4, and specifically in ImportOldFormatStyles, allows attackers to craft malicious documents that cause denial of service (memory corruption and application crash) potentially resulting in arbitrary code execution.

Record
CVE-2017-12608
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

A vulnerability in Apache OpenOffice Writer DOC file parser before 4.1.4, and specifically in ImportOldFormatStyles, allows attackers to craft malicious documents that cause denial of service (memory corruption and application crash) potentially resulting in arbitrary code execution.

Record
CVE-2017-12608
Updated
2026-11-02
EUVDEUVD-2017-4169 No score

A vulnerability in Apache OpenOffice Writer DOC file parser before 4.1.4, and specifically in ImportOldFormatStyles, allows attackers to craft malicious documents that cause denial of service (memory corruption and application crash) potentially resulting in arbitrary code execution.

Record
EUVD-2017-4169
Updated
2026-11-03
GitHub AdvisoriesGHSA-hwpq-wfjf-957h 7.8

A vulnerability in Apache OpenOffice Writer DOC file parser before 4.1.4, and specifically in...

A vulnerability in Apache OpenOffice Writer DOC file parser before 4.1.4, and specifically in ImportOldFormatStyles, allows attackers to craft malicious documents that cause denial of service (memory corruption and application crash) potentially resulting in arbitrary code execution.

Record
GHSA-hwpq-wfjf-957h
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSV 7.8

A vulnerability in Apache OpenOffice Writer DOC file parser before 4.1.4, and specifically in ImportOldFormatStyles, allows attackers to craft malicious documents that cause denial of service (memory corruption and application crash) potentially resulting in arbitrary code execution.

Record
CVE-2017-12608
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-12608 7.8

A vulnerability in Apache OpenOffice Writer DOC file parser before 4.1.4, and specifically in ImportOldFormatStyles, allows attackers to craft malicious documents that cause denial of service (memory corruption and application crash) potentially resulting in arbitrary code execution.

Record
DEBIAN-CVE-2017-12608
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-12608 7.8

A vulnerability in Apache OpenOffice Writer DOC file parser before 4.1.4, and specifically in ImportOldFormatStyles, allows attackers to craft malicious documents that cause denial of service (memory corruption and application crash) potentially resulting in arbitrary code execution.

Record
UBUNTU-CVE-2017-12608
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-3472-1 No score

libreoffice vulnerabilities

Marcin Noga discovered that LibreOffice incorrectly handled PPT documents. If a user were tricked into opening a specially crafted PPT document, a remote attacker could cause LibreOffice to crash, and possibly execute arbitrary code. (CVE-2017-12607)

Marcin Noga discovered that LibreOffice incorrectly handled Word documents. If a user were tricked into opening a specially crafted Word document, a remote attacker could cause LibreOffice to crash, and possibly execute arbitrary code. (CVE-2017-12608)

Record
USN-3472-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libreoffice
Debian:12
before 1:5.0.2-1
1:5.0.2-1
libreoffice
Debian:13
before 1:5.0.2-1
1:5.0.2-1
libreoffice
Debian:14
before 1:5.0.2-1
1:5.0.2-1
libreoffice
Debian:7
From an advisory covering 2 CVEs
before 1:3.5.4+dfsg2-0+deb7u10, plus listed versions
1:3.5.4+dfsg-41:3.5.4+dfsg2-0+deb7u11:3.5.4+dfsg2-0+deb7u21:3.5.4+dfsg2-0+deb7u31:3.5.4+dfsg2-0+deb7u4
Show 6 moreShow less
1:3.5.4+dfsg2-0+deb7u4~bpo60+11:3.5.4+dfsg2-0+deb7u51:3.5.4+dfsg2-0+deb7u61:3.5.4+dfsg2-0+deb7u71:3.5.4+dfsg2-0+deb7u81:3.5.4+dfsg2-0+deb7u9
1:3.5.4+dfsg2-0+deb7u10
libreoffice
Debian:8
From an advisory covering 2 CVEs
before 1:4.3.3-2+deb8u9, plus listed versions
1:4.3.3-21:4.3.3-2+deb8u11:4.3.3-2+deb8u1~bpo70+11:4.3.3-2+deb8u21:4.3.3-2+deb8u3
Show 8 moreShow less
1:4.3.3-2+deb8u3~bpo70+11:4.3.3-2+deb8u41:4.3.3-2+deb8u51:4.3.3-2+deb8u61:4.3.3-2+deb8u6~bpo70+11:4.3.3-2+deb8u71:4.3.3-2+deb8u7~bpo70+11:4.3.3-2+deb8u8
1:4.3.3-2+deb8u9
libreoffice
Ubuntu:14.04:LTS
before 1:4.2.8-0ubuntu5.2, plus listed versions
1:4.1.2~rc3-0ubuntu11:4.1.2~rc3-0ubuntu21:4.1.3-0ubuntu21:4.1.3-0ubuntu31:4.2.0~rc4-0ubuntu1
Show 14 moreShow less
1:4.2.0-0ubuntu11:4.2.1-0ubuntu11:4.2.3~rc2-0ubuntu11:4.2.3~rc3-0ubuntu11:4.2.3~rc3-0ubuntu21:4.2.4-0ubuntu21:4.2.6.3-0ubuntu11:4.2.7-0ubuntu11:4.2.7-0ubuntu21:4.2.8-0ubuntu21:4.2.8-0ubuntu31:4.2.8-0ubuntu41:4.2.8-0ubuntu51:4.2.8-0ubuntu5.1
1:4.2.8-0ubuntu5.2
libreoffice
Ubuntu:14.04:LTS
From an advisory covering 2 CVEs
before 1:4.2.8-0ubuntu5.2, plus listed versions
1:4.1.2~rc3-0ubuntu11:4.1.2~rc3-0ubuntu21:4.1.3-0ubuntu21:4.1.3-0ubuntu31:4.2.0~rc4-0ubuntu1
Show 14 moreShow less
1:4.2.0-0ubuntu11:4.2.1-0ubuntu11:4.2.3~rc2-0ubuntu11:4.2.3~rc3-0ubuntu11:4.2.3~rc3-0ubuntu21:4.2.4-0ubuntu21:4.2.6.3-0ubuntu11:4.2.7-0ubuntu11:4.2.7-0ubuntu21:4.2.8-0ubuntu21:4.2.8-0ubuntu31:4.2.8-0ubuntu41:4.2.8-0ubuntu51:4.2.8-0ubuntu5.1
1:4.2.8-0ubuntu5.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-12608 is a high vulnerability (CVSS 7.8) in Apache Openoffice, published November 1, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.89%, the 86th percentile. Fixed in libreoffice 1:5.0.2-1.

References

Show 9 moreShow less
MoveEnter Open