CVE-2017-12958
There is an illegal address access in the function output_hex() in data/data-out.c of the libpspp...
There is an illegal address access in the function output_hex() in data/data-out.c of the libpspp library in GNU PSPP before 1.0.1 that will lead to remote denial of service.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
There is an illegal address access in the function output_hex() in data/data-out.c of the libpspp library in GNU PSPP before 1.0.1 that will lead to remote denial of service.
- Record
CVE-2017-12958- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
There is an illegal address access in the function output_hex() in data/data-out.c of the libpspp library in GNU PSPP before 1.0.1 that will lead to remote denial of service.
- Record
CVE-2017-12958- Updated
- 2026-11-02
EUVDEUVD-2017-4479 No score
There is an illegal address access in the function output_hex() in data/data-out.c of the libpspp library in GNU PSPP before 1.0.1 that will lead to remote denial of service.
- Record
EUVD-2017-4479- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2gq9-rqpm-h5mw
7.5
There is an illegal address access in the function output_hex() in data/data-out.c of the libpspp...
There is an illegal address access in the function output_hex() in data/data-out.c of the libpspp library in GNU PSPP before 1.0.1 that will lead to remote denial of service.
- Record
GHSA-2gq9-rqpm-h5mw- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
7.5
There is an illegal address access in the function output_hex() in data/data-out.c of the libpspp library in GNU PSPP before 1.0.1 that will lead to remote denial of service.
- Record
CVE-2017-12958- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-12958
7.5
There is an illegal address access in the function output_hex() in data/data-out.c of the libpspp library in GNU PSPP before 1.0.1 that will lead to remote denial of service.
- Record
DEBIAN-CVE-2017-12958- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-12958
7.5
There is an illegal address access in the function output_hex() in data/data-out.c of the libpspp library in GNU PSPP before 1.0.1 that will lead to remote denial of service.
- Record
UBUNTU-CVE-2017-12958- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11199-1 No score
pspp-1.4.1-2.3 on GA media
These are all security issues fixed in the pspp-1.4.1-2.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11199-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
psppDebian:12 |
before 1.0.1-1 | 1.0.1-1 |
psppDebian:13 |
before 1.0.1-1 | 1.0.1-1 |
psppDebian:14 |
before 1.0.1-1 | 1.0.1-1 |
psppUbuntu:16.04:LTS |
All versions, plus listed versions 0.8.5-40.8.5-4build10.8.5-50.8.5-5build1 |
None known |
psppopenSUSE:Tumbleweed From an advisory covering 7 CVEs |
before 1.4.1-2.3 | 1.4.1-2.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-12958 is a high vulnerability (CVSS 7.5) in Gnu Pspp, published August 18, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.26%, the 69th percentile. Fixed in pspp 1.0.1-1.
References
savannah.gnu.org/forum/forum.php?forum_id=8936
bugzilla.redhat.com/show_bug.cgi?id=1482429
nvd.nist.gov/vuln/detail/CVE-2017-12958
github.com/advisories/GHSA-2gq9-rqpm-h5mw
security-tracker.debian.org/tracker/CVE-2017-12958
ubuntu.com/security/CVE-2017-12958