Every CVE Search/ Get API key

CVE-2017-14058

In FFmpeg 2.4 and 3.3.3, the read_data function in libavformat/hls.c does not restrict reload...

6.5 MediumFix available

In FFmpeg 2.4 and 3.3.3, the read_data function in libavformat/hls.c does not restrict reload attempts for an insufficient list, which allows remote attackers to cause a denial of service (infinite loop).

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.17%Up 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

In FFmpeg 2.4 and 3.3.3, the read_data function in libavformat/hls.c does not restrict reload attempts for an insufficient list, which allows remote attackers to cause a denial of service (infinite loop).

Record
CVE-2017-14058
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-835
Updated
2026-11-02
CVE List No score

In FFmpeg 2.4 and 3.3.3, the read_data function in libavformat/hls.c does not restrict reload attempts for an insufficient list, which allows remote attackers to cause a denial of service (infinite loop).

Record
CVE-2017-14058
Updated
2026-11-02
EUVDEUVD-2017-5572 No score

In FFmpeg 2.4 and 3.3.3, the read_data function in libavformat/hls.c does not restrict reload attempts for an insufficient list, which allows remote attackers to cause a denial of service (infinite loop).

Record
EUVD-2017-5572
Updated
2026-11-03
GitHub AdvisoriesGHSA-97p8-g29r-232j 6.5

In FFmpeg 2.4 and 3.3.3, the read_data function in libavformat/hls.c does not restrict reload...

In FFmpeg 2.4 and 3.3.3, the read_data function in libavformat/hls.c does not restrict reload attempts for an insufficient list, which allows remote attackers to cause a denial of service (infinite loop).

Record
GHSA-97p8-g29r-232j
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-835
Updated
2026-11-02
OSVALPINE-CVE-2017-14058 6.5

In FFmpeg 2.4 and 3.3.3, the read_data function in libavformat/hls.c does not restrict reload attempts for an insufficient list, which allows remote attackers to cause a denial of service (infinite loop).

Record
ALPINE-CVE-2017-14058
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 6.5

In FFmpeg 2.4 and 3.3.3, the read_data function in libavformat/hls.c does not restrict reload attempts for an insufficient list, which allows remote attackers to cause a denial of service (infinite loop).

Record
CVE-2017-14058
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-07
Show 4 moreShow less
OSVDEBIAN-CVE-2017-14058 6.5

In FFmpeg 2.4 and 3.3.3, the read_data function in libavformat/hls.c does not restrict reload attempts for an insufficient list, which allows remote attackers to cause a denial of service (infinite loop).

Record
DEBIAN-CVE-2017-14058
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-14058 6.5

In FFmpeg 2.4 and 3.3.3, the read_data function in libavformat/hls.c does not restrict reload attempts for an insufficient list, which allows remote attackers to cause a denial of service (infinite loop).

Record
UBUNTU-CVE-2017-14058
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2018-0008 No score

Updated ffmpeg packages fix security vulnerability

This update provides ffmpeg version 2.4.14, which fixes several security vulnerabilities and other bugs which were corrected upstream.

Record
MGASA-2018-0008
Updated
2026-11-02
OSVopenSUSE-SU-2024:10754-1 No score

ffmpeg-4-4.4-5.2 on GA media

These are all security issues fixed in the ffmpeg-4-4.4-5.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10754-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ffmpeg
Alpine:v3.4
before 3.1.11-r0
3.1.11-r0
ffmpeg
Alpine:v3.5
before 3.1.11-r0
3.1.11-r0
ffmpeg
Alpine:v3.6
before 3.2.8-r0
3.2.8-r0
ffmpeg
Alpine:v3.7
before 3.3.4-r0
3.3.4-r0
ffmpeg
Debian:12
before 7:3.3.4-1
7:3.3.4-1
ffmpeg
Debian:13
before 7:3.3.4-1
7:3.3.4-1
ffmpeg
Debian:14
before 7:3.3.4-1
7:3.3.4-1
libav
Debian:8
From an advisory covering 5 CVEs
before 6:11.12-1~deb8u6, plus listed versions
6:11.11-1~deb8u16:11.12-1~deb8u16:11.12-1~deb8u26:11.12-1~deb8u36:11.12-1~deb8u4
Show 13 moreShow less
6:11.12-1~deb8u56:11.3-16:11.3-1+deb8u16:11.3-26:11.3-36:11.4-16:11.4-1~deb8u16:11.4-26:11.4-2+x32.16:11.6-1~deb8u16:11.7-1~deb8u16:11.8-1~deb8u16:11.9-1~deb8u1
6:11.12-1~deb8u6
ffmpeg
Debian:9
From an advisory covering 13 CVEs
before 7:3.2.8-1~deb9u1, plus listed versions
7:3.2.5-17:3.2.6-17:3.2.7-1~deb9u1
7:3.2.8-1~deb9u1
ffmpeg
Mageia:5
From an advisory covering 31 CVEs
before 2.4.14-1.mga5
2.4.14-1.mga5
ffmpeg
Mageia:5
From an advisory covering 31 CVEs
before 2.4.14-1.mga5.tainted
2.4.14-1.mga5.tainted
ffmpeg
Ubuntu:16.04:LTS
before 7:2.8.14-0ubuntu0.16.04.1, plus listed versions
7:2.7.2-1build17:2.8.1-1ubuntu17:2.8.2-1ubuntu17:2.8.3-17:2.8.4-1
Show 9 moreShow less
7:2.8.4-1ubuntu17:2.8.4-1ubuntu27:2.8.4-1ubuntu37:2.8.4-1ubuntu47:2.8.6-1ubuntu17:2.8.6-1ubuntu27:2.8.8-0ubuntu0.16.04.17:2.8.10-0ubuntu0.16.04.17:2.8.11-0ubuntu0.16.04.1
7:2.8.14-0ubuntu0.16.04.1
ffmpeg-4
openSUSE:Tumbleweed
From an advisory covering 46 CVEs
before 4.4-5.2
4.4-5.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-14058 is a medium vulnerability (CVSS 6.5) in Ffmpeg, published August 31, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.17%, the 82nd percentile. Fixed in ffmpeg 3.1.11-r0.

References

Show 53 moreShow less
MoveEnter Open