Every CVE Search/ Get API key

CVE-2017-14062

Integer overflow in the decode_digit function in puny_decode.c in Libidn2 before 2.0.4 allows...

9.8 CriticalFix available

Integer overflow in the decode_digit function in puny_decode.c in Libidn2 before 2.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.89%Up 2.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Integer overflow in the decode_digit function in puny_decode.c in Libidn2 before 2.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Record
CVE-2017-14062
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-190
Updated
2026-11-02
CVE List No score

Integer overflow in the decode_digit function in puny_decode.c in Libidn2 before 2.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Record
CVE-2017-14062
Updated
2026-11-02
EUVDEUVD-2017-5576 No score

Integer overflow in the decode_digit function in puny_decode.c in Libidn2 before 2.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Record
EUVD-2017-5576
Updated
2026-11-03
GitHub AdvisoriesGHSA-783h-w6p2-278g 9.8

Integer overflow in the decode_digit function in puny_decode.c in Libidn2 before 2.0.4 allows...

Integer overflow in the decode_digit function in puny_decode.c in Libidn2 before 2.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Record
GHSA-783h-w6p2-278g
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-190
Updated
2026-11-02
OSV 9.8

Integer overflow in the decode_digit function in puny_decode.c in Libidn2 before 2.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Record
CVE-2017-14062
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-14062 9.8

Integer overflow in the decode_digit function in puny_decode.c in Libidn2 before 2.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Record
DEBIAN-CVE-2017-14062
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 7 moreShow less
OSVUBUNTU-CVE-2017-14062 9.8

Integer overflow in the decode_digit function in puny_decode.c in Libidn2 before 2.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Record
UBUNTU-CVE-2017-14062
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2017-0365 No score

Updated libidn packages fix security vulnerability

Integer overflow in the decode_digit function in puny_decode.c in Libidn2 before 2.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact. (CVE-2017-14062)

Record
MGASA-2017-0365
Updated
2026-11-02
OSVopenSUSE-SU-2024:10949-1 No score

libidn-devel-1.38-1.2 on GA media

These are all security issues fixed in the libidn-devel-1.38-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10949-1
Updated
2026-11-02
OSVSUSE-SU-2018:0878-1 No score

Security update for libidn

This update for libidn fixes one issues.

This security issue was fixed:

  • CVE-2017-14062: Prevent integer overflow in the decode_digit function that allowed remote attackers to cause a denial of service or possibly have unspecified other impact (bsc#1056450).
Record
SUSE-SU-2018:0878-1
Updated
2026-11-02
OSVSUSE-SU-2018:0903-1 No score

Security update for libidn

This update for libidn fixes one issues.

This security issue was fixed:

  • CVE-2017-14062: Prevent integer overflow in the decode_digit function that allowed remote attackers to cause a denial of service or possibly have unspecified other impact (bsc#1056450).
Record
SUSE-SU-2018:0903-1
Updated
2026-11-02
OSVUSN-3421-2 No score

libidn2-0 vulnerability

USN-3421-1 fixed a vulnerability in Libidn2. This update provides the corresponding update for Ubuntu 14.04 ESM and Ubuntu 16.04 ESM.

Record
USN-3421-2
Updated
2026-11-02
OSVUSN-3434-1 No score

libidn vulnerability

It was discovered that Libidn incorrectly handled decoding certain digits. A remote attacker could use this issue to cause Libidn to crash, resulting in a denial of service, or possibly execute arbitrary code.

Record
USN-3434-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libidn
Debian:12
before 1.33-2
1.33-2
libidn
Debian:13
before 1.33-2
1.33-2
libidn
Debian:14
before 1.33-2
1.33-2
libidn
Debian:7
before 1.25-2+deb7u3, plus listed versions
1.25-21.25-2+deb7u11.25-2+deb7u2
1.25-2+deb7u3
libidn2-0
Debian:7
before 0.8-2+deb7u1, plus listed versions
0.8-2
0.8-2+deb7u1
libidn
Debian:8
before 1.29-1+deb8u3, plus listed versions
1.29-11.29-1+deb8u11.29-1+deb8u2
1.29-1+deb8u3
libidn2-0
Debian:8
before 0.10-2+deb8u1, plus listed versions
0.10-2
0.10-2+deb8u1
libidn2-0
Debian:9
before 0.16-1+deb9u1, plus listed versions
0.16-1
0.16-1+deb9u1
libidn
Mageia:5
before 1.33-1.1.mga5
1.33-1.1.mga5
libidn
Mageia:6
before 1.33-1.1.mga6
1.33-1.1.mga6
Show 11 moreShow less
Affected packages
PackageAffectedFixed
libidn
SUSE:Linux Enterprise Desktop 12 SP3
before 1.28-5.3.1
1.28-5.3.1
libidn
SUSE:Linux Enterprise Software Development Kit 12 SP3
before 1.28-5.3.1
1.28-5.3.1
libidn
SUSE:Linux Enterprise Server 12 SP3
before 1.28-5.3.1
1.28-5.3.1
libidn
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 1.28-5.3.1
1.28-5.3.1
libidn
SUSE:Linux Enterprise Software Development Kit 11 SP4
before 1.10-7.3.1
1.10-7.3.1
libidn
SUSE:Linux Enterprise Server 11 SP4
before 1.10-7.3.1
1.10-7.3.1
libidn
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
before 1.10-7.3.1
1.10-7.3.1
libidn
Ubuntu:14.04:LTS
before 1.28-1ubuntu2.2, plus listed versions
1.28-1ubuntu11.28-1ubuntu21.28-1ubuntu2.1
1.28-1ubuntu2.2
libidn2-0
Ubuntu:Pro:14.04:LTS
before 0.9-1ubuntu0.1~esm1, plus listed versions
0.9-1
0.9-1ubuntu0.1~esm1
libidn
Ubuntu:16.04:LTS
before 1.32-3ubuntu1.2, plus listed versions
1.28-1ubuntu21.32-3ubuntu11.32-3ubuntu1.1
1.32-3ubuntu1.2
libidn2-0
Ubuntu:Pro:16.04:LTS
before 0.10-3ubuntu0.1~esm1, plus listed versions
0.10-3
0.10-3ubuntu0.1~esm1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-14062 is a critical vulnerability (CVSS 9.8) in Gnu Libidn2, published August 31, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.89%, the 90th percentile. Fixed in libidn 1.33-2.

References

Show 14 moreShow less
MoveEnter Open