CVE-2017-14180
Apport 2.13 through 2.20.7 does not properly handle crashes originating from a PID namespace...
Apport 2.13 through 2.20.7 does not properly handle crashes originating from a PID namespace allowing local users to create certain files as root which an attacker could leverage to perform a denial of service via resource exhaustion or possibly gain root privileges, a different vulnerability than CVE-2017-14179.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
Apport 2.13 through 2.20.7 does not properly handle crashes originating from a PID namespace allowing local users to create certain files as root which an attacker could leverage to perform a denial of service via resource exhaustion or possibly gain root privileges, a different vulnerability than CVE-2017-14179.
- Record
CVE-2017-14180- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.2 High
AV:L/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-400
- Updated
- 2026-11-02
CVE List No score
Apport 2.13 through 2.20.7 does not properly handle crashes originating from a PID namespace allowing local users to create certain files as root which an attacker could leverage to perform a denial of service via resource exhaustion or possibly gain root privileges, a different vulnerability than CVE-2017-14179.
- Record
CVE-2017-14180- Updated
- 2026-11-02
EUVDEUVD-2017-5690 No score
Apport 2.13 through 2.20.7 does not properly handle crashes originating from a PID namespace allowing local users to create certain files as root which an attacker could leverage to perform a denial of service via resource exhaustion or possibly gain root privileges, a different vulnerability than CVE-2017-14179.
- Record
EUVD-2017-5690- Updated
- 2026-11-02
GitHub AdvisoriesGHSA-q2pm-6838-p3jm
7.8
Apport 2.13 through 2.20.7 does not properly handle crashes originating from a PID namespace...
Apport 2.13 through 2.20.7 does not properly handle crashes originating from a PID namespace allowing local users to create certain files as root which an attacker could leverage to perform a denial of service via resource exhaustion or possibly gain root privileges, a different vulnerability than CVE-2017-14179.
- Record
GHSA-q2pm-6838-p3jm- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-14180
7.8
Apport 2.13 through 2.20.7 does not properly handle crashes originating from a PID namespace allowing local users to create certain files as root which an attacker could leverage to perform a denial of service via resource exhaustion or possibly gain root privileges, a different vulnerability than CVE-2017-14179.
- Record
UBUNTU-CVE-2017-14180- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-3480-1 No score
apport vulnerabilities
Sander Bos discovered that Apport incorrectly handled core dumps for setuid binaries. A local attacker could use this issue to perform a denial of service via resource exhaustion or possibly gain root privileges. (CVE-2017-14177)
Sander Bos discovered that Apport incorrectly handled core dumps for processes in a different PID namespace. A local attacker could use this issue to perform a denial of service via resource exhaustion or possibly gain root privileges. (CVE-2017-14180)
- Record
USN-3480-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
apportUbuntu:14.04:LTS |
before 2.14.1-0ubuntu3.27, plus listed versions 2.12.5-0ubuntu22.12.6-0ubuntu12.12.7-0ubuntu12.12.7-0ubuntu22.12.7-0ubuntu3 Show 34 moreShow less2.12.7-0ubuntu62.13.1-0ubuntu12.13.1-0ubuntu22.13.2-0ubuntu22.13.2-0ubuntu32.13.2-0ubuntu42.13.2-0ubuntu52.13.3-0ubuntu12.14-0ubuntu12.14.1-0ubuntu12.14.1-0ubuntu22.14.1-0ubuntu32.14.1-0ubuntu3.12.14.1-0ubuntu3.22.14.1-0ubuntu3.32.14.1-0ubuntu3.42.14.1-0ubuntu3.52.14.1-0ubuntu3.62.14.1-0ubuntu3.72.14.1-0ubuntu3.82.14.1-0ubuntu3.92.14.1-0ubuntu3.102.14.1-0ubuntu3.112.14.1-0ubuntu3.122.14.1-0ubuntu3.132.14.1-0ubuntu3.152.14.1-0ubuntu3.162.14.1-0ubuntu3.182.14.1-0ubuntu3.192.14.1-0ubuntu3.202.14.1-0ubuntu3.212.14.1-0ubuntu3.232.14.1-0ubuntu3.242.14.1-0ubuntu3.25 |
2.14.1-0ubuntu3.27 |
apportUbuntu:16.04:LTS |
before 2.20.1-0ubuntu2.12, plus listed versions 2.19.1-0ubuntu32.19.2-0ubuntu12.19.2-0ubuntu22.19.2-0ubuntu32.19.2-0ubuntu4 Show 20 moreShow less2.19.2-0ubuntu52.19.2-0ubuntu62.19.2-0ubuntu82.19.2-0ubuntu92.19.3-0ubuntu12.19.3-0ubuntu22.19.3-0ubuntu32.19.4-0ubuntu12.19.4-0ubuntu22.20-0ubuntu22.20-0ubuntu32.20.1-0ubuntu12.20.1-0ubuntu22.20.1-0ubuntu2.12.20.1-0ubuntu2.22.20.1-0ubuntu2.42.20.1-0ubuntu2.52.20.1-0ubuntu2.62.20.1-0ubuntu2.92.20.1-0ubuntu2.10 |
2.20.1-0ubuntu2.12 |
apportUbuntu:14.04:LTS From an advisory covering 2 CVEs |
before 2.14.1-0ubuntu3.27, plus listed versions 2.12.5-0ubuntu22.12.6-0ubuntu12.12.7-0ubuntu12.12.7-0ubuntu22.12.7-0ubuntu3 Show 34 moreShow less2.12.7-0ubuntu62.13.1-0ubuntu12.13.1-0ubuntu22.13.2-0ubuntu22.13.2-0ubuntu32.13.2-0ubuntu42.13.2-0ubuntu52.13.3-0ubuntu12.14-0ubuntu12.14.1-0ubuntu12.14.1-0ubuntu22.14.1-0ubuntu32.14.1-0ubuntu3.12.14.1-0ubuntu3.22.14.1-0ubuntu3.32.14.1-0ubuntu3.42.14.1-0ubuntu3.52.14.1-0ubuntu3.62.14.1-0ubuntu3.72.14.1-0ubuntu3.82.14.1-0ubuntu3.92.14.1-0ubuntu3.102.14.1-0ubuntu3.112.14.1-0ubuntu3.122.14.1-0ubuntu3.132.14.1-0ubuntu3.152.14.1-0ubuntu3.162.14.1-0ubuntu3.182.14.1-0ubuntu3.192.14.1-0ubuntu3.202.14.1-0ubuntu3.212.14.1-0ubuntu3.232.14.1-0ubuntu3.242.14.1-0ubuntu3.25 |
2.14.1-0ubuntu3.27 |
apportUbuntu:16.04:LTS From an advisory covering 2 CVEs |
before 2.20.1-0ubuntu2.12, plus listed versions 2.19.1-0ubuntu32.19.2-0ubuntu12.19.2-0ubuntu22.19.2-0ubuntu32.19.2-0ubuntu4 Show 20 moreShow less2.19.2-0ubuntu52.19.2-0ubuntu62.19.2-0ubuntu82.19.2-0ubuntu92.19.3-0ubuntu12.19.3-0ubuntu22.19.3-0ubuntu32.19.4-0ubuntu12.19.4-0ubuntu22.20-0ubuntu22.20-0ubuntu32.20.1-0ubuntu12.20.1-0ubuntu22.20.1-0ubuntu2.12.20.1-0ubuntu2.22.20.1-0ubuntu2.42.20.1-0ubuntu2.52.20.1-0ubuntu2.62.20.1-0ubuntu2.92.20.1-0ubuntu2.10 |
2.20.1-0ubuntu2.12 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-14180 is a high vulnerability (CVSS 7.8) in Apport Project Apport, published November 15, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.44%, the 38th percentile. Fixed in apport 2.14.1-0ubuntu3.27.