Every CVE Search/ Get API key

CVE-2017-14226

WP1StylesListener.cpp, WP5StylesListener.cpp, and WP42StylesListener.cpp in libwpd 0.10.1...

7.5 HighFix available

WP1StylesListener.cpp, WP5StylesListener.cpp, and WP42StylesListener.cpp in libwpd 0.10.1 mishandle iterators, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the WPXTableList class in WPXTable.cpp). This vulnerability can be triggered in LibreOffice before 5.3.7. It may lead to suffering a remote attack against a LibreOffice application.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.48%Up 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

WP1StylesListener.cpp, WP5StylesListener.cpp, and WP42StylesListener.cpp in libwpd 0.10.1 mishandle iterators, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the WPXTableList class in WPXTable.cpp). This vulnerability can be triggered in LibreOffice before 5.3.7. It may lead to suffering a remote attack against a LibreOffice application.

Record
CVE-2017-14226
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

WP1StylesListener.cpp, WP5StylesListener.cpp, and WP42StylesListener.cpp in libwpd 0.10.1 mishandle iterators, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the WPXTableList class in WPXTable.cpp). This vulnerability can be triggered in LibreOffice before 5.3.7. It may lead to suffering a remote attack against a LibreOffice application.

Record
CVE-2017-14226
Updated
2026-11-02
EUVDEUVD-2017-5736 No score

WP1StylesListener.cpp, WP5StylesListener.cpp, and WP42StylesListener.cpp in libwpd 0.10.1 mishandle iterators, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the WPXTableList class in WPXTable.cpp). This vulnerability can be triggered in LibreOffice before 5.3.7. It may lead to suffering a remote attack against a LibreOffice application.

Record
EUVD-2017-5736
Updated
2026-11-03
GitHub AdvisoriesGHSA-4m96-cjx2-px9q 7.5

WP1StylesListener.cpp, WP5StylesListener.cpp, and WP42StylesListener.cpp in libwpd 0.10.1...

WP1StylesListener.cpp, WP5StylesListener.cpp, and WP42StylesListener.cpp in libwpd 0.10.1 mishandle iterators, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the WPXTableList class in WPXTable.cpp). This vulnerability can be triggered in LibreOffice before 5.3.7. It may lead to suffering a remote attack against a LibreOffice application.

Record
GHSA-4m96-cjx2-px9q
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 7.5

WP1StylesListener.cpp, WP5StylesListener.cpp, and WP42StylesListener.cpp in libwpd 0.10.1 mishandle iterators, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the WPXTableList class in WPXTable.cpp). This vulnerability can be triggered in LibreOffice before 5.3.7. It may lead to suffering a remote attack against a LibreOffice application.

Record
CVE-2017-14226
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-14226 7.5

WP1StylesListener.cpp, WP5StylesListener.cpp, and WP42StylesListener.cpp in libwpd 0.10.1 mishandle iterators, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the WPXTableList class in WPXTable.cpp). This vulnerability can be triggered in LibreOffice before 5.3.7. It may lead to suffering a remote attack against a LibreOffice application.

Record
DEBIAN-CVE-2017-14226
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2017-14226 7.5

WP1StylesListener.cpp, WP5StylesListener.cpp, and WP42StylesListener.cpp in libwpd 0.10.1 mishandle iterators, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the WPXTableList class in WPXTable.cpp). This vulnerability can be triggered in LibreOffice before 5.3.7. It may lead to suffering a remote attack against a LibreOffice application.

Record
UBUNTU-CVE-2017-14226
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2017-0358 No score

Updated libwpd packages fix security vulnerability

WP1StylesListener.cpp, WP5StylesListener.cpp, and WP42StylesListener.cpp in libwpd 0.10.1 mishandle iterators, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the WPXTableList class in WPXTable.cpp). This vulnerability can be triggered in LibreOffice before 5.3.7. It may lead to suffering a remote attack against a LibreOffice application. (CVE-2017-14226)

Record
MGASA-2017-0358
Updated
2026-11-02
OSVopenSUSE-SU-2024:11013-1 No score

libwpd-0_10-10-0.10.3-2.3 on GA media

These are all security issues fixed in the libwpd-0_10-10-0.10.3-2.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11013-1
Updated
2026-11-02
OSVSUSE-SU-2017:2931-1 No score

Security update for libwpd

This update for libwpd fixes the following issues:

Security issue fixed:

  • CVE-2017-14226: WP1StylesListener.cpp, WP5StylesListener.cpp, and WP42StylesListener.cpp in libwpd 0.10.1 mishandle iterators, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the WPXTableList class in WPXTable.cpp). This vulnerability can be triggered in LibreOffice before 5.3.7. It may lead to suffering a remote attack against a LibreOffice application. (bnc#1058025)

Bugfixes:

  • Fix various crashes, leaks and hangs when reading damaged files found by oss-fuzz.
  • Fix crash when NULL is passed as input stream.
  • Use symbol visibility on Linux. The library only exports public functions now.
  • Avoid infinite loop. (libwpd#3)
  • Remove bashism. (libwpd#5)
  • Fix various crashes and hangs when reading broken files found with the help of american-fuzzy-lop.
  • Make --help output of all command line tools more help2man-friendly.
  • Miscellaneous fixes and cleanups.
  • Generate manpages for the libwpd-tools
Record
SUSE-SU-2017:2931-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libwpd
Debian:12
before 0.10.2-1
0.10.2-1
libwpd
Debian:13
before 0.10.2-1
0.10.2-1
libwpd
Debian:14
before 0.10.2-1
0.10.2-1
libwpd
Mageia:5
before 0.10.2-1.mga5
0.10.2-1.mga5
libwpd
Mageia:6
before 0.10.2-1.mga6
0.10.2-1.mga6
libwpd
SUSE:Linux Enterprise Desktop 12 SP2
before 0.10.2-2.4.1
0.10.2-2.4.1
libwpd
SUSE:Linux Enterprise Desktop 12 SP3
before 0.10.2-2.4.1
0.10.2-2.4.1
libwpd
SUSE:Linux Enterprise Software Development Kit 12 SP2
before 0.10.2-2.4.1
0.10.2-2.4.1
libwpd
SUSE:Linux Enterprise Software Development Kit 12 SP3
before 0.10.2-2.4.1
0.10.2-2.4.1
libwpd
SUSE:Linux Enterprise Workstation Extension 12 SP2
before 0.10.2-2.4.1
0.10.2-2.4.1
libwpd
SUSE:Linux Enterprise Workstation Extension 12 SP3
before 0.10.2-2.4.1
0.10.2-2.4.1
libwpd
Ubuntu:16.04:LTS
All versions, plus listed versions
0.10.0-2ubuntu40.10.1-1ubuntu1
None known

History

History
RecordedChangedSources
facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-14226 is a high vulnerability (CVSS 7.5) in Libreoffice, published September 9, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.48%, the 84th percentile. Fixed in libwpd 0.10.2-1.

References

Show 13 moreShow less
MoveEnter Open