Every CVE Search/ Get API key

CVE-2017-14227

In MongoDB libbson 1.7.0, the bson_iter_codewscope function in bson-iter.c miscalculates a...

7.5 HighFix available

In MongoDB libbson 1.7.0, the bson_iter_codewscope function in bson-iter.c miscalculates a bson_utf8_validate length argument, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the bson_utf8_validate function in bson-utf8.c), as demonstrated by bson-to-json.c.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

5.46%Up 3.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

In MongoDB libbson 1.7.0, the bson_iter_codewscope function in bson-iter.c miscalculates a bson_utf8_validate length argument, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the bson_utf8_validate function in bson-utf8.c), as demonstrated by bson-to-json.c.

Record
CVE-2017-14227
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

In MongoDB libbson 1.7.0, the bson_iter_codewscope function in bson-iter.c miscalculates a bson_utf8_validate length argument, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the bson_utf8_validate function in bson-utf8.c), as demonstrated by bson-to-json.c.

Record
CVE-2017-14227
Updated
2026-11-02
EUVDEUVD-2017-5737 No score

In MongoDB libbson 1.7.0, the bson_iter_codewscope function in bson-iter.c miscalculates a bson_utf8_validate length argument, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the bson_utf8_validate function in bson-utf8.c), as demonstrated by bson-to-json.c.

Record
EUVD-2017-5737
Updated
2026-11-02
GitHub AdvisoriesGHSA-98vg-qmpv-23vr 7.5

In MongoDB libbson 1.7.0, the bson_iter_codewscope function in bson-iter.c miscalculates a...

In MongoDB libbson 1.7.0, the bson_iter_codewscope function in bson-iter.c miscalculates a bson_utf8_validate length argument, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the bson_utf8_validate function in bson-utf8.c), as demonstrated by bson-to-json.c.

Record
GHSA-98vg-qmpv-23vr
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 7.5

In MongoDB libbson 1.7.0, the bson_iter_codewscope function in bson-iter.c miscalculates a bson_utf8_validate length argument, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the bson_utf8_validate function in bson-utf8.c), as demonstrated by bson-to-json.c.

Record
CVE-2017-14227
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-14227 7.5

In MongoDB libbson 1.7.0, the bson_iter_codewscope function in bson-iter.c miscalculates a bson_utf8_validate length argument, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the bson_utf8_validate function in bson-utf8.c), as demonstrated by bson-to-json.c.

Record
DEBIAN-CVE-2017-14227
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-14227 7.5

In MongoDB libbson 1.7.0, the bson_iter_codewscope function in bson-iter.c miscalculates a bson_utf8_validate length argument, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the bson_utf8_validate function in bson-utf8.c), as demonstrated by bson-to-json.c.

Record
UBUNTU-CVE-2017-14227
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-4812-1 No score

libbson vulnerabilities

It was discovered that libbson incorrectly validated input length. An attacker could possibly use this issue to cause a denial of service. This issue affected only Ubuntu 16.04 ESM. (CVE-2017-14227)

It was discovered that libbson incorrectly handled certain specially crafted bson buffers. An attacker could possibly use this issue to cause a denial of service. (CVE-2018-16790)

Record
USN-4812-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libbson-xs-perl
Debian:12
before 0.8.4-2+deb12u1, plus listed versions
0.8.4-2
0.8.4-2+deb12u1
libbson-xs-perl
Debian:11
before 0.8.4-1+deb11u1, plus listed versions
0.8.4-1
0.8.4-1+deb11u1
libbson
Ubuntu:Pro:16.04:LTS
before 1.3.1-1ubuntu0.1~esm1, plus listed versions
1.3.1-1
1.3.1-1ubuntu0.1~esm1
libbson
Ubuntu:Pro:18.04:LTS
before 1.9.2-1ubuntu0.1~esm2, plus listed versions
1.8.0-11.8.1-11.9.0-11.9.2-1
1.9.2-1ubuntu0.1~esm2

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-14227 is a high vulnerability (CVSS 7.5) in Mongodb, published September 9, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.46%, the 92nd percentile. Fixed in libbson-xs-perl 0.8.4-2+deb12u1.

References

Show 7 moreShow less
MoveEnter Open