CVE-2017-14727
logger.c in the logger plugin in WeeChat before 1.9.1 allows a crash via strftime date/time...
logger.c in the logger plugin in WeeChat before 1.9.1 allows a crash via strftime date/time specifiers, because a buffer is not initialized.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
logger.c in the logger plugin in WeeChat before 1.9.1 allows a crash via strftime date/time specifiers, because a buffer is not initialized.
- Record
CVE-2017-14727- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
logger.c in the logger plugin in WeeChat before 1.9.1 allows a crash via strftime date/time specifiers, because a buffer is not initialized.
- Record
CVE-2017-14727- Updated
- 2026-11-02
EUVDEUVD-2017-6224 No score
logger.c in the logger plugin in WeeChat before 1.9.1 allows a crash via strftime date/time specifiers, because a buffer is not initialized.
- Record
EUVD-2017-6224- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-ppv9-cgrm-wr3p
7.5
logger.c in the logger plugin in WeeChat before 1.9.1 allows a crash via strftime date/time...
logger.c in the logger plugin in WeeChat before 1.9.1 allows a crash via strftime date/time specifiers, because a buffer is not initialized.
- Record
GHSA-ppv9-cgrm-wr3p- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSVALPINE-CVE-2017-14727
7.5
logger.c in the logger plugin in WeeChat before 1.9.1 allows a crash via strftime date/time specifiers, because a buffer is not initialized.
- Record
ALPINE-CVE-2017-14727- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV
7.5
logger.c in the logger plugin in WeeChat before 1.9.1 allows a crash via strftime date/time specifiers, because a buffer is not initialized.
- Record
CVE-2017-14727- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2017-14727
7.5
logger.c in the logger plugin in WeeChat before 1.9.1 allows a crash via strftime date/time specifiers, because a buffer is not initialized.
- Record
DEBIAN-CVE-2017-14727- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-14727
7.5
logger.c in the logger plugin in WeeChat before 1.9.1 allows a crash via strftime date/time specifiers, because a buffer is not initialized.
- Record
UBUNTU-CVE-2017-14727- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0369 No score
Updated weechat packages fix security vulnerability
It was discovered that logger.c in the logger plugin in WeeChat before 1.9.1 allows a crash via strftime date/time specifiers, because a buffer is not initialized (CVE-2017-14727).
- Record
MGASA-2017-0369- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11508-1 No score
weechat-3.2-1.3 on GA media
These are all security issues fixed in the weechat-3.2-1.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11508-1- Updated
- 2026-11-02
OSVUSN-5258-1 No score
weechat vulnerabilities
Stuart Nevans Locke discovered that WeeChat's relay plugin insecurely handled malformed websocket frames. A remote attacker in control of a server could possibly use this issue to cause denial of service in a client. (CVE-2021-40516)
Stuart Nevans Locke discovered that WeeChat insecurely handled certain IRC messages. A remote attacker in control of a server could possibly use this issue to cause denial of service in a client. This issue only affected Ubuntu 16.04 ESM and Ubuntu 18.04 ESM. (CVE-2020-9760)
Stuart Nevans Locke discovered that WeeChat insecurely handled certain IRC messages. A remote unauthenticated attacker could possibly use these issues to cause denial of service in a client. These issues only affected Ubuntu 16.04 ESM and Ubuntu 18.04 ESM. (CVE-2020-9759, CVE-2020-8955)
Joseph Bisch discovered that WeeChat's logger incorrectly handled certain memory operations when handling log file names. A remote attacker could possibly use this issue to cause denial of service in a client. This issue only affected Ubuntu 16.04 ESM. (CVE-2017-14727)
- Record
USN-5258-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
weechatAlpine:v3.5 |
before 1.6.0-r2 | 1.6.0-r2 |
weechatAlpine:v3.6 |
before 1.7.1-r2 | 1.7.1-r2 |
weechatAlpine:v3.7 |
before 1.9.1-r0 | 1.9.1-r0 |
weechatAlpine:v3.8 |
before 1.9.1-r0 | 1.9.1-r0 |
weechatAlpine:v3.9 |
before 1.9.1-r0 | 1.9.1-r0 |
weechatDebian:12 |
before 1.9.1-1 | 1.9.1-1 |
weechatDebian:13 |
before 1.9.1-1 | 1.9.1-1 |
weechatDebian:14 |
before 1.9.1-1 | 1.9.1-1 |
weechatDebian:7 |
before 0.3.8-1+deb7u3, plus listed versions 0.3.8-1+deb7u10.3.8-1+deb7u2 |
0.3.8-1+deb7u3 |
weechatMageia:5 |
before 0.4.1-7.2.mga5 | 0.4.1-7.2.mga5 |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
weechatMageia:6 |
before 1.7.1-1.1.mga6 | 1.7.1-1.1.mga6 |
weechatUbuntu:Pro:16.04:LTS |
before 1.4-2ubuntu0.1+esm1, plus listed versions 1.3-11.3-1build11.4-11.4-1build11.4-1build21.4-21.4-2ubuntu0.1 |
1.4-2ubuntu0.1+esm1 |
weechatUbuntu:Pro:18.04:LTS |
before 1.9.1-1ubuntu1+esm1, plus listed versions 1.9.1-11.9.1-1build11.9.1-1ubuntu1 |
1.9.1-1ubuntu1+esm1 |
weechatUbuntu:Pro:20.04:LTS |
before 2.8-1ubuntu0.1~esm1, plus listed versions 2.6-22.6-2build12.6-2build22.6-2ubuntu12.6-2ubuntu22.8-1 |
2.8-1ubuntu0.1~esm1 |
weechatopenSUSE:Tumbleweed |
before 3.2-1.3 | 3.2-1.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-14727 is a high vulnerability (CVSS 7.5) in Weechat Logger, published September 23, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.84%, the 86th percentile. Fixed in weechat 1.6.0-r2.
References
securityfocus.com/bid/101003
weechat.org/download/security
github.com/weechat/weechat/commit/f105c6f0b56fb5687b2d2aedf37cb1d1b434d556
weechat.org/news/98/20170923-Version-1.9.1-security-release
nvd.nist.gov/vuln/detail/CVE-2017-14727
github.com/advisories/GHSA-ppv9-cgrm-wr3p
Show 16 moreShow less
security.alpinelinux.org/vuln/CVE-2017-14727
security-tracker.debian.org/tracker/CVE-2017-14727
advisories.mageia.org/MGASA-2017-0369.html
bugs.mageia.org/show_bug.cgi?id=21802
lists.opensuse.org/opensuse-updates/2017-09/msg00123.html
bugzilla.suse.com/show_bug.cgi?id=1060140
ubuntu.com/security/CVE-2017-14727
cve.org/CVERecord?id=CVE-2017-14727
ubuntu.com/security/notices/USN-5258-1
ubuntu.com/security/CVE-2020-8955
ubuntu.com/security/CVE-2020-9759
ubuntu.com/security/CVE-2020-9760
ubuntu.com/security/CVE-2021-40516
suse.com/security/cve/CVE-2017-14727
suse.com/security/cve/CVE-2017-8073
suse.com/security/cve/CVE-2020-8955