CVE-2017-14926
In Poppler 0.59.0, a NULL Pointer Dereference exists in AnnotRichMedia::Content::Content in Annot...
In Poppler 0.59.0, a NULL Pointer Dereference exists in AnnotRichMedia::Content::Content in Annot.cc via a crafted PDF document.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
In Poppler 0.59.0, a NULL Pointer Dereference exists in AnnotRichMedia::Content::Content in Annot.cc via a crafted PDF document.
- Record
CVE-2017-14926- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-476
- Updated
- 2026-11-02
CVE List No score
In Poppler 0.59.0, a NULL Pointer Dereference exists in AnnotRichMedia::Content::Content in Annot.cc via a crafted PDF document.
- Record
CVE-2017-14926- Updated
- 2026-11-02
EUVDEUVD-2017-6403 No score
In Poppler 0.59.0, a NULL Pointer Dereference exists in AnnotRichMedia::Content::Content in Annot.cc via a crafted PDF document.
- Record
EUVD-2017-6403- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-r2f3-mjhr-vxhr
5.5
In Poppler 0.59.0, a NULL Pointer Dereference exists in AnnotRichMedia::Content::Content in Annot...
In Poppler 0.59.0, a NULL Pointer Dereference exists in AnnotRichMedia::Content::Content in Annot.cc via a crafted PDF document.
- Record
GHSA-r2f3-mjhr-vxhr- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
OSV
5.5
In Poppler 0.59.0, a NULL Pointer Dereference exists in AnnotRichMedia::Content::Content in Annot.cc via a crafted PDF document.
- Record
CVE-2017-14926- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-14926
5.5
In Poppler 0.59.0, a NULL Pointer Dereference exists in AnnotRichMedia::Content::Content in Annot.cc via a crafted PDF document.
- Record
DEBIAN-CVE-2017-14926- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-14926
5.5
In Poppler 0.59.0, a NULL Pointer Dereference exists in AnnotRichMedia::Content::Content in Annot.cc via a crafted PDF document.
- Record
UBUNTU-CVE-2017-14926- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0378 No score
Updated poppler packages fix security vulnerabilities
In Poppler 0.59.0, a floating point exception exists in the isImageInterpolationRequired() function in Splash.cc via a crafted PDF document. (CVE-2017-14518)
In Poppler 0.59.0, a floating point exception occurs in the ImageStream class in Stream.cc, which may lead to a potential attack when handling malicious PDF files. (CVE-2017-14617)
In Poppler 0.59.0, a NULL Pointer Dereference exists in AnnotRichMedia::Content::Content in Annot.cc via a crafted PDF document. (CVE-2017-14926)
In Poppler 0.59.0, a NULL Pointer Dereference exists in AnnotRichMedia::Configuration::Configuration in Annot.cc via a crafted PDF document. (CVE-2017-14928)
In Poppler 0.59.0, memory corruption occurs in a call to Object::dictLookup() in Object.h after a repeating series of Gfx::display, Gfx::go, Gfx::execOp, Gfx::opFill, Gfx::doPatternFill, Gfx::doTilingPatternFill and Gfx::drawForm calls (aka a Gfx.cc infinite loop), a different vulnerability than CVE-2017-14519. (CVE-2017-14929)
The FoFiType1C::convertToType0 function in FoFiType1C.cc in Poppler 0.59.0 has a NULL pointer dereference vulnerability because a data structure is not initialized, which allows an attacker to launch a denial of service attack. (CVE-2017-14975)
The FoFiTrueType::getCFFBlock function in FoFiTrueType.cc in Poppler 0.59.0 has a NULL pointer dereference vulnerability due to lack of validation of a table pointer, which allows an attacker to launch a denial of service attack. (CVE-2017-14977)
- Record
MGASA-2017-0378- Updated
- 2026-11-02
OSVUSN-3440-1 No score
poppler vulnerabilities
It was discovered that Poppler incorrectly handled certain files. If a user or automated system were tricked into opening a crafted PDF file, an attacker could cause a denial of service. (CVE-2017-14518, CVE-2017-14520, CVE-2017-14617, CVE-2017-14929, CVE-2017-14975, CVE-2017-14977)
It was discovered that Poppler incorrectly handled certain files. If a user or automated system were tricked into opening a crafted PDF file, an attacker could cause a denial of service. This issue only affected Ubuntu 17.04 and 16.04. (CVE-2017-14926, CVE-2017-14928)
Alberto Garcia, Francisco Oca and Suleman Ali discovered that Poppler incorrectly handled certain files. If a user or automated system were tricked into opening a crafted PDF file, an attacker could cause a denial of service. (CVE-2017-9776)
- Record
USN-3440-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
popplerDebian:12 |
before 0.61.1-2 | 0.61.1-2 |
popplerDebian:13 |
before 0.61.1-2 | 0.61.1-2 |
popplerDebian:14 |
before 0.61.1-2 | 0.61.1-2 |
popplerDebian:9 |
before 0.48.0-2+deb9u4, plus listed versions 0.48.0-20.48.0-2+deb9u10.48.0-2+deb9u20.48.0-2+deb9u3 |
0.48.0-2+deb9u4 |
popplerMageia:5 |
before 0.26.5-2.5.mga5 | 0.26.5-2.5.mga5 |
popplerMageia:6 |
before 0.52.0-3.3.mga6 | 0.52.0-3.3.mga6 |
popplerUbuntu:16.04:LTS |
before 0.41.0-0ubuntu1.4, plus listed versions 0.33.0-0ubuntu30.37.0-0ubuntu10.38.0-0ubuntu10.41.0-0ubuntu10.41.0-0ubuntu1.10.41.0-0ubuntu1.20.41.0-0ubuntu1.3 |
0.41.0-0ubuntu1.4 |
popplerUbuntu:14.04:LTS |
before 0.24.5-2ubuntu4.7, plus listed versions 0.24.1-0ubuntu10.24.3-0ubuntu10.24.3-0ubuntu20.24.3-0ubuntu30.24.3-0ubuntu4 Show 16 moreShow less0.24.3-0ubuntu50.24.3-0ubuntu60.24.3-0ubuntu70.24.3-0ubuntu80.24.3-0ubuntu100.24.3-0ubuntu120.24.5-0ubuntu30.24.5-2ubuntu10.24.5-2ubuntu20.24.5-2ubuntu40.24.5-2ubuntu4.10.24.5-2ubuntu4.20.24.5-2ubuntu4.30.24.5-2ubuntu4.40.24.5-2ubuntu4.50.24.5-2ubuntu4.6 |
0.24.5-2ubuntu4.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-14926 is a medium vulnerability (CVSS 5.5) in Freedesktop Poppler, published September 29, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.67%, the 52nd percentile. Fixed in poppler 0.61.1-2.
References
bugs.freedesktop.org/show_bug.cgi?id=102601
lists.debian.org/debian-lts-announce/2020/11/msg00014.html
nvd.nist.gov/vuln/detail/CVE-2017-14926
github.com/advisories/GHSA-r2f3-mjhr-vxhr
security-tracker.debian.org/tracker/CVE-2017-14926
advisories.mageia.org/MGASA-2017-0378.html
Show 13 moreShow less
bugs.mageia.org/show_bug.cgi?id=21825
usn.ubuntu.com/usn/usn-3440-1
ubuntu.com/security/CVE-2017-14926
ubuntu.com/security/notices/USN-3440-1
cve.org/CVERecord?id=CVE-2017-14926
ubuntu.com/security/CVE-2017-9776
ubuntu.com/security/CVE-2017-14518
ubuntu.com/security/CVE-2017-14520
ubuntu.com/security/CVE-2017-14617
ubuntu.com/security/CVE-2017-14928
ubuntu.com/security/CVE-2017-14929
ubuntu.com/security/CVE-2017-14975
ubuntu.com/security/CVE-2017-14977