Every CVE Search/ Get API key

CVE-2017-17913

In GraphicsMagick 1.4 snapshot-20171217 Q8, there is a stack-based buffer over-read in...

8.8 HighFix available

In GraphicsMagick 1.4 snapshot-20171217 Q8, there is a stack-based buffer over-read in WriteWEBPImage in coders/webp.c, related to an incompatibility with libwebp versions, 0.5.0 and later, that use a different structure type.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.61%Up 0.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

In GraphicsMagick 1.4 snapshot-20171217 Q8, there is a stack-based buffer over-read in WriteWEBPImage in coders/webp.c, related to an incompatibility with libwebp versions, 0.5.0 and later, that use a different structure type.

Record
CVE-2017-17913
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

In GraphicsMagick 1.4 snapshot-20171217 Q8, there is a stack-based buffer over-read in WriteWEBPImage in coders/webp.c, related to an incompatibility with libwebp versions, 0.5.0 and later, that use a different structure type.

Record
CVE-2017-17913
Updated
2026-11-02
EUVDEUVD-2017-9056 No score

In GraphicsMagick 1.4 snapshot-20171217 Q8, there is a stack-based buffer over-read in WriteWEBPImage in coders/webp.c, related to an incompatibility with libwebp versions, 0.5.0 and later, that use a different structure type.

Record
EUVD-2017-9056
Updated
2026-11-03
GitHub AdvisoriesGHSA-m85m-8745-r3wh 8.8

In GraphicsMagick 1.4 snapshot-20171217 Q8, there is a stack-based buffer over-read in...

In GraphicsMagick 1.4 snapshot-20171217 Q8, there is a stack-based buffer over-read in WriteWEBPImage in coders/webp.c, related to an incompatibility with libwebp versions, 0.5.0 and later, that use a different structure type.

Record
GHSA-m85m-8745-r3wh
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 8.8

In GraphicsMagick 1.4 snapshot-20171217 Q8, there is a stack-based buffer over-read in WriteWEBPImage in coders/webp.c, related to an incompatibility with libwebp versions, 0.5.0 and later, that use a different structure type.

Record
CVE-2017-17913
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-17913 8.8

In GraphicsMagick 1.4 snapshot-20171217 Q8, there is a stack-based buffer over-read in WriteWEBPImage in coders/webp.c, related to an incompatibility with libwebp versions, 0.5.0 and later, that use a different structure type.

Record
DEBIAN-CVE-2017-17913
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-17913 8.8

In GraphicsMagick 1.4 snapshot-20171217 Q8, there is a stack-based buffer over-read in WriteWEBPImage in coders/webp.c, related to an incompatibility with libwebp versions, 0.5.0 and later, that use a different structure type.

Record
UBUNTU-CVE-2017-17913
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-4266-1 No score

graphicsmagick vulnerabilities

It was discovered that GraphicsMagick incorrectly handled certain image files. An attacker could possibly use this issue to cause a denial of service or other unspecified impact.

Record
USN-4266-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
graphicsmagick
Debian:12
before 1.3.27-3
1.3.27-3
graphicsmagick
Debian:13
before 1.3.27-3
1.3.27-3
graphicsmagick
Debian:14
before 1.3.27-3
1.3.27-3
graphicsmagick
Debian:9
From an advisory covering 56 CVEs
before 1.3.30+hg15796-1~deb9u1, plus listed versions
1.3.25-81.3.26-11.3.26-101.3.26-111.3.26-12
Show 24 moreShow less
1.3.26-131.3.26-141.3.26-151.3.26-161.3.26-171.3.26-181.3.26-191.3.26-21.3.26-31.3.26-41.3.26-51.3.26-61.3.26-71.3.26-81.3.26-91.3.27-11.3.27-21.3.27-31.3.27-41.3.28-11.3.28-21.3.29+hg15665-11.3.29-11.3.30-1
1.3.30+hg15796-1~deb9u1
graphicsmagick
Ubuntu:16.04:LTS
before 1.3.23-1ubuntu0.6, plus listed versions
1.3.21-31.3.23-11.3.23-1build11.3.23-1ubuntu0.11.3.23-1ubuntu0.21.3.23-1ubuntu0.31.3.23-1ubuntu0.41.3.23-1ubuntu0.5
1.3.23-1ubuntu0.6
graphicsmagick
Ubuntu:16.04:LTS
From an advisory covering 7 CVEs
before 1.3.23-1ubuntu0.6, plus listed versions
1.3.21-31.3.23-11.3.23-1build11.3.23-1ubuntu0.11.3.23-1ubuntu0.21.3.23-1ubuntu0.31.3.23-1ubuntu0.41.3.23-1ubuntu0.5
1.3.23-1ubuntu0.6

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-17913 is a high vulnerability (CVSS 8.8) in Graphicsmagick, published December 26, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.61%, the 76th percentile. Fixed in graphicsmagick 1.3.27-3.

References

Show 11 moreShow less
MoveEnter Open