Every CVE Search/ Get API key

CVE-2018-10895

Qutebrowser CSRF Vulnerability

9.3 CriticalFix available

qutebrowser before version 1.4.1 is vulnerable to a cross-site request forgery flaw that allows websites to access 'qute://*' URLs. A malicious website could exploit this to load a 'qute://settings/set' URL, which then sets 'editor.command' to a bash script, resulting in arbitrary code execution.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

1.20%Down 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 9.3

qutebrowser before version 1.4.1 is vulnerable to a cross-site request forgery flaw that allows websites to access 'qute://*' URLs. A malicious website could exploit this to load a 'qute://settings/set' URL, which then sets 'editor.command' to a bash script, resulting in arbitrary code execution.

Record
CVE-2018-10895
CVSS 3.0
9.3 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Weakness
CWE-352
Updated
2026-11-02
EUVDEUVD-2018-0130 9.3

qutebrowser before version 1.4.1 is vulnerable to a cross-site request forgery flaw that allows websites to access 'qute://*' URLs. A malicious website could exploit this to load a 'qute://settings/set' URL, which then sets 'editor.command' to a bash script, resulting in arbitrary code execution.

Record
EUVD-2018-0130
CVSS 3.0
9.3 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-wgmx-52ph-qqcw 8.8

Qutebrowser CSRF Vulnerability

qutebrowser before version 1.4.1 is vulnerable to a cross-site request forgery flaw that allows websites to access qute://* URLs. A malicious website could exploit this to load a qute://settings/set URL, which then sets editor.command to a bash script, resulting in arbitrary code execution.

Record
GHSA-wgmx-52ph-qqcw
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
NVD 9.3

qutebrowser before version 1.4.1 is vulnerable to a cross-site request forgery flaw that allows websites to access 'qute://*' URLs. A malicious website could exploit this to load a 'qute://settings/set' URL, which then sets 'editor.command' to a bash script, resulting in arbitrary code execution.

Record
CVE-2018-10895
CVSS 3.0
9.3 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-352
Updated
2026-11-02
OSV 8.8

qutebrowser before version 1.4.1 is vulnerable to a cross-site request forgery flaw that allows websites to access 'qute://*' URLs. A malicious website could exploit this to load a 'qute://settings/set' URL, which then sets 'editor.command' to a bash script, resulting in arbitrary code execution.

Record
CVE-2018-10895
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-10895 8.8

qutebrowser before version 1.4.1 is vulnerable to a cross-site request forgery flaw that allows websites to access 'qute://*' URLs. A malicious website could exploit this to load a 'qute://settings/set' URL, which then sets 'editor.command' to a bash script, resulting in arbitrary code execution.

Record
DEBIAN-CVE-2018-10895
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-wgmx-52ph-qqcw 8.8

Qutebrowser CSRF Vulnerability

qutebrowser before version 1.4.1 is vulnerable to a cross-site request forgery flaw that allows websites to access qute://* URLs. A malicious website could exploit this to load a qute://settings/set URL, which then sets editor.command to a bash script, resulting in arbitrary code execution.

Record
GHSA-wgmx-52ph-qqcw
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
OSVUBUNTU-CVE-2018-10895 8.8

qutebrowser before version 1.4.1 is vulnerable to a cross-site request forgery flaw that allows websites to access 'qute://*' URLs. A malicious website could exploit this to load a 'qute://settings/set' URL, which then sets 'editor.command' to a bash script, resulting in arbitrary code execution.

Record
UBUNTU-CVE-2018-10895
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
9.3 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Updated
2026-11-02
OSVopenSUSE-SU-2024:11292-1 No score

qutebrowser-2.3.1-2.1 on GA media

These are all security issues fixed in the qutebrowser-2.3.1-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11292-1
Updated
2026-11-02
OSVPYSEC-2018-27 No score

qutebrowser before version 1.4.1 is vulnerable to a cross-site request forgery flaw that allows websites to access 'qute://*' URLs. A malicious website could exploit this to load a 'qute://settings/set' URL, which then sets 'editor.command' to a bash script, resulting in arbitrary code execution.

Record
PYSEC-2018-27
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qutebrowser
PyPI
before 1.4.1
1.4.1
qutebrowser
Debian:12
before 1.4.1-1
1.4.1-1
qutebrowser
Debian:13
before 1.4.1-1
1.4.1-1
qutebrowser
Debian:14
before 1.4.1-1
1.4.1-1
qutebrowser
PyPI
before 1.4.1, plus listed versions
0.0.00.1.00.1.10.1.20.1.3
Show 38 moreShow less
0.1.40.10.00.10.10.11.00.11.10.2.00.2.10.3.00.4.00.4.10.5.00.5.10.6.00.6.10.6.20.7.00.8.00.8.10.8.20.8.30.8.40.9.00.9.11.0.01.0.11.0.21.0.31.0.41.1.01.1.11.1.21.2.01.2.11.3.01.3.11.3.21.3.31.4.0
1.4.1
qutebrowser
Ubuntu:18.04:LTS
before 1.1.1-1ubuntu0.1, plus listed versions
0.11.0-11.0.4-11.0.4-21.0.4-31.1.0-11.1.1-1
1.1.1-1ubuntu0.1
qutebrowser
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 2.3.1-2.1
2.3.1-2.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-10895 is a critical vulnerability (CVSS 9.3) in Qutebrowser, published July 12, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.20%, the 68th percentile. Fixed in qutebrowser 1.4.1.

References

Show 8 moreShow less
MoveEnter Open